summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-12 20:25:50 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-12 20:25:50 +0000
commit1661c5f1332e97f2fe614d314a5fb1313964fc5a (patch)
tree1827eb7838947a087582ce369002503343320a93 /net-zope/zc-buildout
parentDelete older ebuilds. (diff)
downloadgentoo-2-1661c5f1332e97f2fe614d314a5fb1313964fc5a.tar.gz
gentoo-2-1661c5f1332e97f2fe614d314a5fb1313964fc5a.tar.bz2
gentoo-2-1661c5f1332e97f2fe614d314a5fb1313964fc5a.zip
Version bump.
(Portage version: 2.2_rc80/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zc-buildout')
-rw-r--r--net-zope/zc-buildout/ChangeLog9
-rw-r--r--net-zope/zc-buildout/zc-buildout-1.5.1.ebuild37
2 files changed, 45 insertions, 1 deletions
diff --git a/net-zope/zc-buildout/ChangeLog b/net-zope/zc-buildout/ChangeLog
index b8f4080ca1af..8fb125ec3258 100644
--- a/net-zope/zc-buildout/ChangeLog
+++ b/net-zope/zc-buildout/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-zope/zc-buildout
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zc-buildout/ChangeLog,v 1.4 2010/09/12 20:13:20 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zc-buildout/ChangeLog,v 1.5 2010/09/12 20:25:50 arfrever Exp $
+
+*zc-buildout-1.5.1 (12 Sep 2010)
+
+ 12 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -zc-buildout-1.4.2.ebuild, -zc-buildout-1.4.3.ebuild,
+ +zc-buildout-1.5.1.ebuild:
+ Version bump.
*zc-buildout-1.4.4 (12 Sep 2010)
diff --git a/net-zope/zc-buildout/zc-buildout-1.5.1.ebuild b/net-zope/zc-buildout/zc-buildout-1.5.1.ebuild
new file mode 100644
index 000000000000..b2de5daeabcc
--- /dev/null
+++ b/net-zope/zc-buildout/zc-buildout-1.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zc-buildout/zc-buildout-1.5.1.ebuild,v 1.1 2010/09/12 20:25:50 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="System for managing development buildouts"
+HOMEPAGE="http://pypi.python.org/pypi/zc.buildout"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+DOCS="CHANGES.txt todo.txt"
+PYTHON_MODNAME="${PN/-//}"
+
+src_install() {
+ distutils_src_install
+
+ # Remove README.txt installed in incorrect location.
+ rm -f "${D}usr/README.txt"
+}