summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-17 14:47:36 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-17 14:47:36 +0000
commit168c5a76c887bc2475da9fabdb8ab55ac1ce7858 (patch)
tree3be8951ed3a5b03db09dd5a14573be302adacb19 /net-zope/transaction
parentDelete older ebuild. (diff)
downloadgentoo-2-168c5a76c887bc2475da9fabdb8ab55ac1ce7858.tar.gz
gentoo-2-168c5a76c887bc2475da9fabdb8ab55ac1ce7858.tar.bz2
gentoo-2-168c5a76c887bc2475da9fabdb8ab55ac1ce7858.zip
Version bump.
(Portage version: 2.2_rc83_p15/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/transaction')
-rw-r--r--net-zope/transaction/ChangeLog8
-rw-r--r--net-zope/transaction/transaction-1.1.1.ebuild35
2 files changed, 40 insertions, 3 deletions
diff --git a/net-zope/transaction/ChangeLog b/net-zope/transaction/ChangeLog
index f6eb994c61a0..45dcedd273d9 100644
--- a/net-zope/transaction/ChangeLog
+++ b/net-zope/transaction/ChangeLog
@@ -1,10 +1,12 @@
# ChangeLog for net-zope/transaction
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/transaction/ChangeLog,v 1.7 2010/09/17 14:46:32 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/transaction/ChangeLog,v 1.8 2010/09/17 14:47:36 arfrever Exp $
+
+*transaction-1.1.1 (17 Sep 2010)
17 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
- -transaction-1.1.0.ebuild:
- Delete.
+ -transaction-1.1.0.ebuild, +transaction-1.1.1.ebuild:
+ Version bump.
*transaction-1.1.0 (30 May 2010)
diff --git a/net-zope/transaction/transaction-1.1.1.ebuild b/net-zope/transaction/transaction-1.1.1.ebuild
new file mode 100644
index 000000000000..337cfb12f94d
--- /dev/null
+++ b/net-zope/transaction/transaction-1.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/transaction/transaction-1.1.1.ebuild,v 1.1 2010/09/17 14:47:36 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Transaction management for Python"
+HOMEPAGE="http://pypi.python.org/pypi/transaction"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-zope/zope-interface"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+DOCS="CHANGES.txt README.txt"
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/transaction/tests"
+ }
+ python_execute_function -q delete_tests
+}