summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-06-05 19:24:00 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-06-05 19:24:00 +0000
commit5ea924167872e8b5fa8d73c793c12e5a8e738a52 (patch)
tree287d2bbcdf7f506f7a2c6206ab4fc92ddd4f74ad /net-www
parentremove old ebuilds (diff)
downloadgentoo-2-5ea924167872e8b5fa8d73c793c12e5a8e738a52.tar.gz
gentoo-2-5ea924167872e8b5fa8d73c793c12e5a8e738a52.tar.bz2
gentoo-2-5ea924167872e8b5fa8d73c793c12e5a8e738a52.zip
Cleanup and fix #103889.
(Portage version: 2.1_rc4-r2)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mod_auth_kerb/ChangeLog8
-rw-r--r--net-www/mod_auth_kerb/files/11_mod_auth_kerb.conf15
-rw-r--r--net-www/mod_auth_kerb/metadata.xml8
-rw-r--r--net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild20
-rw-r--r--net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc7.ebuild20
5 files changed, 42 insertions, 29 deletions
diff --git a/net-www/mod_auth_kerb/ChangeLog b/net-www/mod_auth_kerb/ChangeLog
index 0c5f2b306a3f..7b1782b727db 100644
--- a/net-www/mod_auth_kerb/ChangeLog
+++ b/net-www/mod_auth_kerb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mod_auth_kerb
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/ChangeLog,v 1.13 2006/06/04 19:21:02 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/ChangeLog,v 1.14 2006/06/05 19:24:00 chtekk Exp $
+
+ 05 Jun 2006; Luca Longinotti <chtekk@gentoo.org>
+ -files/4.11-r1/11_mod_auth_kerb.conf, files/11_mod_auth_kerb.conf,
+ -files/mod_auth_kerb_register.patch, metadata.xml,
+ mod_auth_kerb-5.0_rc6.ebuild, mod_auth_kerb-5.0_rc7.ebuild:
+ Cleanup and fix bug #103889.
04 Jun 2006; Michael Stewart <vericgar@gentoo.org>
-mod_auth_kerb-4.11.ebuild, -mod_auth_kerb-4.11-r1.ebuild:
diff --git a/net-www/mod_auth_kerb/files/11_mod_auth_kerb.conf b/net-www/mod_auth_kerb/files/11_mod_auth_kerb.conf
index 58e117c84fd0..0852c1148e98 100644
--- a/net-www/mod_auth_kerb/files/11_mod_auth_kerb.conf
+++ b/net-www/mod_auth_kerb/files/11_mod_auth_kerb.conf
@@ -1,7 +1,14 @@
<IfDefine AUTH_KERB>
- <IfModule !mod_auth_kerb.c>
- LoadModule kerb_auth_module extramodules/mod_auth_kerb.so
- </IfModule>
+ LoadModule auth_kerb_module modules/mod_auth_kerb.so
</IfDefine>
-#Place configuration directives here
+<IfModule mod_auth_kerb.c>
+ <Directory "/var/www/private">
+ AuthType Kerberos
+ AuthName "Kerberos Login"
+ # See the INSTALL file about howto create the keytab
+ Krb5Keytab conf/apache.keytab
+ KrbAuthRealms EXAMPLE.COM
+ Require valid-user
+ </Directory>
+</IfModule>
diff --git a/net-www/mod_auth_kerb/metadata.xml b/net-www/mod_auth_kerb/metadata.xml
index ff5b6490402e..8f398d815b6c 100644
--- a/net-www/mod_auth_kerb/metadata.xml
+++ b/net-www/mod_auth_kerb/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>apache</herd>
-<maintainer>
- <email>apache-bugs@gentoo.org</email>
-</maintainer>
+ <herd>apache</herd>
+ <maintainer>
+ <email>apache-bugs@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild b/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild
index 586432ad9e1f..9db436ea798f 100644
--- a/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild
+++ b/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild,v 1.4 2006/05/13 21:30:08 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild,v 1.5 2006/06/05 19:24:00 chtekk Exp $
-MY_PV=${PV/_rc/-rc}
+MY_PV="${PV/_rc/-rc}"
inherit eutils apache-module
-DESCRIPTION="An Apache2 authentication DSO using Kerberos"
+DESCRIPTION="An Apache2 authentication DSO using Kerberos."
HOMEPAGE="http://modauthkerb.sourceforge.net/"
SRC_URI="mirror://sourceforge/modauthkerb/${PN}-${MY_PV}.tar.gz"
@@ -15,26 +15,26 @@ KEYWORDS="x86"
IUSE="apache2"
SLOT="0"
-DEPEND="app-crypt/mit-krb5"
+DEPEND="virtual/krb5"
RDEPEND=""
-APACHE1_MOD_CONF="4.11-r1/11_${PN}"
+APACHE1_MOD_CONF="11_${PN}"
APACHE1_MOD_DEFINE="AUTH_KERB"
-APACHE2_MOD_CONF="4.11-r1/11_${PN}"
+APACHE2_MOD_CONF="11_${PN}"
APACHE2_MOD_DEFINE="AUTH_KERB"
DOCFILES="INSTALL README"
need_apache
-S=${WORKDIR}/${PN}-${MY_PV}
+S="${WORKDIR}/${PN}-${MY_PV}"
src_compile() {
- if use apache2; then
- CFLAGS="" APXS="${APXS2}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
+ if use apache2 ; then
+ CFLAGS="" APXS="${APXS2}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
else
- CFLAGS="" APXS="${APXS}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
+ CFLAGS="" APXS="${APXS}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
fi
emake || die "make failed"
}
diff --git a/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc7.ebuild b/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc7.ebuild
index 3c8d5d767b3a..b552bcc12a13 100644
--- a/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc7.ebuild
+++ b/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc7.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc7.ebuild,v 1.1 2006/04/18 16:31:11 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc7.ebuild,v 1.2 2006/06/05 19:24:00 chtekk Exp $
-MY_PV=${PV/_rc/rc}
+MY_PV="${PV/_rc/rc}"
inherit eutils apache-module
-DESCRIPTION="An Apache2 authentication DSO using Kerberos"
+DESCRIPTION="An Apache2 authentication DSO using Kerberos."
HOMEPAGE="http://modauthkerb.sourceforge.net/"
SRC_URI="mirror://sourceforge/modauthkerb/${PN}-${MY_PV}.tar.gz"
@@ -15,26 +15,26 @@ KEYWORDS="~x86"
IUSE="apache2"
SLOT="0"
-DEPEND="app-crypt/mit-krb5"
+DEPEND="virtual/krb5"
RDEPEND=""
-APACHE1_MOD_CONF="4.11-r1/11_${PN}"
+APACHE1_MOD_CONF="11_${PN}"
APACHE1_MOD_DEFINE="AUTH_KERB"
-APACHE2_MOD_CONF="4.11-r1/11_${PN}"
+APACHE2_MOD_CONF="11_${PN}"
APACHE2_MOD_DEFINE="AUTH_KERB"
DOCFILES="INSTALL README"
need_apache
-S=${WORKDIR}/${PN}-${MY_PV}
+S="${WORKDIR}/${PN}-${MY_PV}"
src_compile() {
- if use apache2; then
- CFLAGS="" APXS="${APXS2}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
+ if use apache2 ; then
+ CFLAGS="" APXS="${APXS2}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
else
- CFLAGS="" APXS="${APXS}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
+ CFLAGS="" APXS="${APXS}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
fi
emake || die "make failed"
}