summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Keadle <mkeadle@gentoo.org>2003-06-20 20:14:16 +0000
committerMatt Keadle <mkeadle@gentoo.org>2003-06-20 20:14:16 +0000
commitbc685df1752341a7a473b39d31a9f44b4f0382be (patch)
treeeee90e450e7ba209f15d0b4b4f738337107e4ad2 /net-www/zoneminder
parentstable for alpha and x86; DEPEND on sed >= 4 (diff)
downloadgentoo-2-bc685df1752341a7a473b39d31a9f44b4f0382be.tar.gz
gentoo-2-bc685df1752341a7a473b39d31a9f44b4f0382be.tar.bz2
gentoo-2-bc685df1752341a7a473b39d31a9f44b4f0382be.zip
initial import. see changelog
Diffstat (limited to 'net-www/zoneminder')
-rw-r--r--net-www/zoneminder/ChangeLog14
-rw-r--r--net-www/zoneminder/Manifest3
-rw-r--r--net-www/zoneminder/files/digest-zoneminder-0.9.122
-rw-r--r--net-www/zoneminder/zoneminder-0.9.12.ebuild69
4 files changed, 88 insertions, 0 deletions
diff --git a/net-www/zoneminder/ChangeLog b/net-www/zoneminder/ChangeLog
new file mode 100644
index 000000000000..c8ca4a4e36b1
--- /dev/null
+++ b/net-www/zoneminder/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for net-www/zoneminder
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/zoneminder/ChangeLog,v 1.1 2003/06/20 20:14:08 mkeadle Exp $
+
+*zoneminder-0.9.12 (20 Jun 2003)
+
+ 20 Jun 2003; mkeadle <mkeadle@gentoo.org> zoneminder-0.9.12.ebuild:
+ initial import. very impressive program. much thanks go to MAL
+ <mal@komcept.com> for putting this all together very well in bug #22665. MALs
+ ebuild used its own internal vars to track where to install the web content. I
+ switched this over to the datadir format used by the apache ebuilds. This lets
+ zoneminder install to the same location apache was installed to without user
+ interaction, but still leaves the door open for customization.
+
diff --git a/net-www/zoneminder/Manifest b/net-www/zoneminder/Manifest
new file mode 100644
index 000000000000..50fc9316c467
--- /dev/null
+++ b/net-www/zoneminder/Manifest
@@ -0,0 +1,3 @@
+MD5 f2489a585f7e4cb6d2981e46019edc9a zoneminder-0.9.12.ebuild 1991
+MD5 d38cdf9f93233ca75dbe1ff1b550d575 ChangeLog 770
+MD5 cf91c423242d440d538cec3f4cd0940b files/digest-zoneminder-0.9.12 129
diff --git a/net-www/zoneminder/files/digest-zoneminder-0.9.12 b/net-www/zoneminder/files/digest-zoneminder-0.9.12
new file mode 100644
index 000000000000..3b04ceb8b888
--- /dev/null
+++ b/net-www/zoneminder/files/digest-zoneminder-0.9.12
@@ -0,0 +1,2 @@
+MD5 fad46ab149bced3c963e4060aa9a5654 zm-0.9.12.tar.gz 260203
+MD5 c29bebb8fa37655dd2a754fbfb9d4c43 zoneminder-gentoo.tar.bz2 3659
diff --git a/net-www/zoneminder/zoneminder-0.9.12.ebuild b/net-www/zoneminder/zoneminder-0.9.12.ebuild
new file mode 100644
index 000000000000..6e9c309c1d52
--- /dev/null
+++ b/net-www/zoneminder/zoneminder-0.9.12.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/zoneminder/zoneminder-0.9.12.ebuild,v 1.1 2003/06/20 20:14:08 mkeadle Exp $
+
+DESCRIPTION="ZoneMinder allows you to capture, analyse, record and monitor any cameras attached to your system."
+HOMEPAGE="http://www.zoneminder.com/"
+SRC_URI="http://www.zoneminder.com/fileadmin/downloads/zm-${PV}.tar.gz
+ http://mkeadle.org/distfiles/${PN}-gentoo.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mpeg"
+
+DEPEND="
+ >=dev-db/mysql-3*
+ >=media-libs/jpeg-6b
+ >=net-www/apache-1.3.27-r3
+ dev-lang/perl
+"
+RDEPEND="
+ mpeg? ( media-video/ffmpeg )
+ virtual/php
+ media-libs/netpbm
+"
+S=${WORKDIR}/zm-${PV}
+
+src_compile() {
+ cd ${S}
+ epatch ${WORKDIR}/${PN}-gentoo/zm-0.9.12-gentoo.patch
+
+ # Apache is flexible, so we should follow suit
+ local datadir=`grep ^apache: /etc/passwd | cut -d: -f6`
+ if [ -z "$datadir" ]
+ then
+ datadir="/home/httpd"
+ eerror ":: Cannot find the apache user on your system! ::"
+ eerror "If you would like to customize where ${PN} installs its web related"
+ eerror "files please create the apache user and set its home directory."
+ ewarn "Defaulting to \"/home/httpd\"."
+ else
+ einfo "$datadir is your Apache data directory ..."
+ fi
+
+ HTTPD_DOCROOT="${datadir}/htdocs"
+ HTTPD_CGIROOT="${datadir}/cgi-bin"
+ HTTPD_USER="apache"
+ HTTPD_GROUP="apache"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-mysql=/usr \
+ --with-webdir=${HTTPD_DOCROOT}/zoneminder \
+ --with-cgidir=${HTTPD_CGIROOT} \
+ --with-webuser=${HTTPD_USER} \
+ --with-webgroup=${HTTPD_GROUP} || die "./configure failed"
+
+ cp "${WORKDIR}/${PN}-gentoo/zmconfig-gentoo.txt" ${S}
+ cd ${S} && perl zmconfig.pl -f zmconfig-gentoo.txt -noi
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README README.html TODO
+}