summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2005-01-08 21:06:39 +0000
committerBenedikt Boehm <hollow@gentoo.org>2005-01-08 21:06:39 +0000
commit8e7248fa701c73c2e8a64a5da7eecb32eb709fc1 (patch)
tree6e3dfeeea931e867cc1869b76a51b0cb523d0854 /net-www/mod_bandwidth/mod_bandwidth-2.0.5-r1.ebuild
parentStable on alpha, bug 76665. (Manifest recommit) (diff)
downloadgentoo-2-8e7248fa701c73c2e8a64a5da7eecb32eb709fc1.tar.gz
gentoo-2-8e7248fa701c73c2e8a64a5da7eecb32eb709fc1.tar.bz2
gentoo-2-8e7248fa701c73c2e8a64a5da7eecb32eb709fc1.zip
Apache herd package refresh
Diffstat (limited to 'net-www/mod_bandwidth/mod_bandwidth-2.0.5-r1.ebuild')
-rw-r--r--net-www/mod_bandwidth/mod_bandwidth-2.0.5-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-www/mod_bandwidth/mod_bandwidth-2.0.5-r1.ebuild b/net-www/mod_bandwidth/mod_bandwidth-2.0.5-r1.ebuild
new file mode 100644
index 000000000000..15850e332e3d
--- /dev/null
+++ b/net-www/mod_bandwidth/mod_bandwidth-2.0.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_bandwidth/mod_bandwidth-2.0.5-r1.ebuild,v 1.1 2005/01/08 21:06:39 hollow Exp $
+
+inherit eutils apache-module
+
+DESCRIPTION="Bandwidth Management Module for Apache"
+HOMEPAGE="http://www.cohprog.com/v3/bandwidth/intro-en.html"
+SRC_URI="ftp://ftp.cohprog.com/pub/apache/module/1.3.0/mod_bandwidth.c"
+
+KEYWORDS="~x86 ~sparc ~ppc"
+DEPEND=""
+LICENSE="Apache-1.1"
+SLOT="0"
+IUSE=""
+
+APACHE1_MOD_CONF="10_${PN}"
+APACHE1_MOD_DEFINE="BANDWIDTH"
+
+need_apache1
+
+src_unpack() {
+ mkdir -p ${S} && cp ${DISTDIR}/${A} ${S} || die
+ cd ${S} || die
+ epatch ${FILESDIR}/${P}-register.patch || die
+ sed -i -e "s:define MOD_BANDWIDTH_VERSION_S.*:define MOD_BANDWIDTH_VERSION_S \"${PV}\":" mod_bandwidth.c || die "version fix failed"
+}
+
+pkg_postinst() {
+ # empty dirs
+ install -m0755 -o apache -g apache -d ${ROOT}/var/cache/mod_bandwidth/{link,master}
+ apache1_pkg_postinst
+}