summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2010-03-06 21:40:18 +0000
committerMark Loeser <halcy0n@gentoo.org>2010-03-06 21:40:18 +0000
commitf541741266b85476cf59c255b30fd84a22938804 (patch)
treeb4ef4352abff9bbf931dd59959c3428c4ded8112 /net-wireless
parentUpdate the official test instructions to disable NDB tests per upstream. (diff)
downloadgentoo-2-f541741266b85476cf59c255b30fd84a22938804.tar.gz
gentoo-2-f541741266b85476cf59c255b30fd84a22938804.tar.bz2
gentoo-2-f541741266b85476cf59c255b30fd84a22938804.zip
No files should be compressed in the tree
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/acx/ChangeLog13
-rw-r--r--net-wireless/acx/files/2.6.31+-mepis/01_addRequestInfo.dpatch90
-rw-r--r--net-wireless/acx/files/2.6.31+-mepis/01_addRequestInfo.dpatch.gzbin1215 -> 0 bytes
-rw-r--r--net-wireless/acx/files/2.6.31+-mepis/02_fix_irqreturn_t.dpatch19
-rw-r--r--net-wireless/acx/files/2.6.31+-mepis/02_fix_irqreturn_t.dpatch.gzbin493 -> 0 bytes
-rw-r--r--net-wireless/acx/files/2.6.31+-mepis/03_typo_fix.dpatch32
-rw-r--r--net-wireless/acx/files/2.6.31+-mepis/03_typo_fix.dpatch.gzbin587 -> 0 bytes
-rw-r--r--net-wireless/acx/files/2.6.31+-mepis/04_pci_and_usb.dpatch90
-rw-r--r--net-wireless/acx/files/2.6.31+-mepis/04_pci_and_usb.dpatch.gzbin1026 -> 0 bytes
9 files changed, 243 insertions, 1 deletions
diff --git a/net-wireless/acx/ChangeLog b/net-wireless/acx/ChangeLog
index 8540eeb29cb4..5f84b068c15a 100644
--- a/net-wireless/acx/ChangeLog
+++ b/net-wireless/acx/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-wireless/acx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/ChangeLog,v 1.16 2010/02/28 17:40:00 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/ChangeLog,v 1.17 2010/03/06 21:40:18 halcy0n Exp $
+
+ 06 Mar 2010; Mark Loeser <halcy0n@gentoo.org>
+ +files/2.6.31+-mepis/01_addRequestInfo.dpatch,
+ -files/2.6.31+-mepis/01_addRequestInfo.dpatch.gz,
+ +files/2.6.31+-mepis/02_fix_irqreturn_t.dpatch,
+ -files/2.6.31+-mepis/02_fix_irqreturn_t.dpatch.gz,
+ +files/2.6.31+-mepis/03_typo_fix.dpatch,
+ -files/2.6.31+-mepis/03_typo_fix.dpatch.gz,
+ +files/2.6.31+-mepis/04_pci_and_usb.dpatch,
+ -files/2.6.31+-mepis/04_pci_and_usb.dpatch.gz:
+ No files should be compressed in the tree
28 Feb 2010; Fabio Erculiani <lxnay@gentoo.org>
acx-0.3.37_p20080210.ebuild, +files/acx-2.6.33.patch:
diff --git a/net-wireless/acx/files/2.6.31+-mepis/01_addRequestInfo.dpatch b/net-wireless/acx/files/2.6.31+-mepis/01_addRequestInfo.dpatch
new file mode 100644
index 000000000000..e765dd8b152b
--- /dev/null
+++ b/net-wireless/acx/files/2.6.31+-mepis/01_addRequestInfo.dpatch
@@ -0,0 +1,90 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## addRequestInfo.dpatch by Stefano Canepa <sc@linux.it>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Let acx100 compile with new kernels
+
+@DPATCH@
+
+--- acx-20080210/ioctl.c 2008-02-10 14:06:42.000000000 -0600
++++ ioctl.c 2008-11-16 02:08:58.000000000 -0600
+@@ -488,6 +488,7 @@
+ /* helper. not sure whether it's really a _s_leeping fn */
+ static char*
+ acx_s_scan_add_station(
++ struct iw_request_info *info,
+ acx_device_t *adev,
+ char *ptr,
+ char *end_buf,
+@@ -503,14 +504,14 @@
+ iwe.u.ap_addr.sa_family = ARPHRD_ETHER;
+ MAC_COPY(iwe.u.ap_addr.sa_data, bss->bssid);
+ acxlog_mac(L_IOCTL, "scan, station address: ", bss->bssid, "\n");
+- ptr = iwe_stream_add_event(ptr, end_buf, &iwe, IW_EV_ADDR_LEN);
++ ptr = iwe_stream_add_event(info, ptr, end_buf, &iwe, IW_EV_ADDR_LEN);
+
+ /* Add ESSID */
+ iwe.cmd = SIOCGIWESSID;
+ iwe.u.data.length = bss->essid_len;
+ iwe.u.data.flags = 1;
+ log(L_IOCTL, "scan, essid: %s\n", bss->essid);
+- ptr = iwe_stream_add_point(ptr, end_buf, &iwe, bss->essid);
++ ptr = iwe_stream_add_point(info, ptr, end_buf, &iwe, bss->essid);
+
+ /* Add mode */
+ iwe.cmd = SIOCGIWMODE;
+@@ -520,7 +521,7 @@
+ else
+ iwe.u.mode = IW_MODE_ADHOC;
+ log(L_IOCTL, "scan, mode: %d\n", iwe.u.mode);
+- ptr = iwe_stream_add_event(ptr, end_buf, &iwe, IW_EV_UINT_LEN);
++ ptr = iwe_stream_add_event(info, ptr, end_buf, &iwe, IW_EV_UINT_LEN);
+ }
+
+ /* Add frequency */
+@@ -528,7 +529,7 @@
+ iwe.u.freq.m = acx_channel_freq[bss->channel - 1] * 100000;
+ iwe.u.freq.e = 1;
+ log(L_IOCTL, "scan, frequency: %d\n", iwe.u.freq.m);
+- ptr = iwe_stream_add_event(ptr, end_buf, &iwe, IW_EV_FREQ_LEN);
++ ptr = iwe_stream_add_event(info, ptr, end_buf, &iwe, IW_EV_FREQ_LEN);
+
+ /* Add link quality */
+ iwe.cmd = IWEVQUAL;
+@@ -546,7 +547,7 @@
+ iwe.u.qual.updated = 7;
+ log(L_IOCTL, "scan, link quality: %d/%d/%d\n",
+ iwe.u.qual.level, iwe.u.qual.noise, iwe.u.qual.qual);
+- ptr = iwe_stream_add_event(ptr, end_buf, &iwe, IW_EV_QUAL_LEN);
++ ptr = iwe_stream_add_event(info, ptr, end_buf, &iwe, IW_EV_QUAL_LEN);
+
+ /* Add encryption */
+ iwe.cmd = SIOCGIWENCODE;
+@@ -556,7 +557,7 @@
+ iwe.u.data.flags = IW_ENCODE_DISABLED;
+ iwe.u.data.length = 0;
+ log(L_IOCTL, "scan, encryption flags: %X\n", iwe.u.data.flags);
+- ptr = iwe_stream_add_point(ptr, end_buf, &iwe, bss->essid);
++ ptr = iwe_stream_add_point(info, ptr, end_buf, &iwe, bss->essid);
+
+ /* add rates */
+ iwe.cmd = SIOCGIWRATE;
+@@ -570,7 +571,7 @@
+ if (rate & 1) {
+ iwe.u.bitrate.value = *p * 500000; /* units of 500kb/s */
+ log(L_IOCTL, "scan, rate: %d\n", iwe.u.bitrate.value);
+- ptr_rate = iwe_stream_add_value(ptr, ptr_rate, end_buf,
++ ptr_rate = iwe_stream_add_value(info, ptr, ptr_rate, end_buf,
+ &iwe, IW_EV_PARAM_LEN);
+ }
+ rate >>= 1;
+@@ -625,7 +626,7 @@
+ for (i = 0; i < ARRAY_SIZE(adev->sta_list); i++) {
+ struct client *bss = &adev->sta_list[i];
+ if (!bss->used) continue;
+- ptr = acx_s_scan_add_station(adev, ptr,
++ ptr = acx_s_scan_add_station(info, adev, ptr,
+ extra + IW_SCAN_MAX_DATA, bss);
+ }
+ dwrq->length = ptr - extra;
+
diff --git a/net-wireless/acx/files/2.6.31+-mepis/01_addRequestInfo.dpatch.gz b/net-wireless/acx/files/2.6.31+-mepis/01_addRequestInfo.dpatch.gz
deleted file mode 100644
index 2b7df3828922..000000000000
--- a/net-wireless/acx/files/2.6.31+-mepis/01_addRequestInfo.dpatch.gz
+++ /dev/null
Binary files differ
diff --git a/net-wireless/acx/files/2.6.31+-mepis/02_fix_irqreturn_t.dpatch b/net-wireless/acx/files/2.6.31+-mepis/02_fix_irqreturn_t.dpatch
new file mode 100644
index 000000000000..68ac2fd524e5
--- /dev/null
+++ b/net-wireless/acx/files/2.6.31+-mepis/02_fix_irqreturn_t.dpatch
@@ -0,0 +1,19 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 02_fix_irqreturn_t.dpatch by Martijn van Brummelen <martijn@brumit.nl>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Fix for compiling the module (Closes: 545367)
+
+@DPATCH@
+diff -urNad acx100-20080210~/wlan_compat.h acx100-20080210/wlan_compat.h
+--- acx100-20080210~/wlan_compat.h 2008-02-10 21:06:42.000000000 +0100
++++ acx100-20080210/wlan_compat.h 2009-11-05 10:07:50.000000000 +0100
+@@ -218,7 +218,7 @@
+ #define WLAN_PACKED __attribute__ ((packed))
+
+ /* Interrupt handler backwards compatibility stuff */
+-#ifndef IRQ_NONE
++#if (! (defined(_LINUX_IRQRETURN_H) || defined(IRQ_NONE)))
+ #define IRQ_NONE
+ #define IRQ_HANDLED
+ typedef void irqreturn_t;
diff --git a/net-wireless/acx/files/2.6.31+-mepis/02_fix_irqreturn_t.dpatch.gz b/net-wireless/acx/files/2.6.31+-mepis/02_fix_irqreturn_t.dpatch.gz
deleted file mode 100644
index 6acdba527b97..000000000000
--- a/net-wireless/acx/files/2.6.31+-mepis/02_fix_irqreturn_t.dpatch.gz
+++ /dev/null
Binary files differ
diff --git a/net-wireless/acx/files/2.6.31+-mepis/03_typo_fix.dpatch b/net-wireless/acx/files/2.6.31+-mepis/03_typo_fix.dpatch
new file mode 100644
index 000000000000..8f4ea955a693
--- /dev/null
+++ b/net-wireless/acx/files/2.6.31+-mepis/03_typo_fix.dpatch
@@ -0,0 +1,32 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 03_typo_fix.dpatch by Martijn van Brummelen <martijn@brumit.nl>
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Fixes several small typo's (Closes: 498099)
+
+@DPATCH@
+diff -urNad acx100-20080210~/script/fetch_firmware.sh acx100-20080210/script/fetch_firmware.sh
+--- acx100-20080210~/script/fetch_firmware.sh 2008-02-10 21:06:42.000000000 +0100
++++ acx100-20080210/script/fetch_firmware.sh 2009-11-05 12:46:37.000000000 +0100
+@@ -15,8 +15,8 @@
+ find_driver_dir()
+ {
+ ACXDIR=`pwd`
+- [ -f $ACXDIR/scripts/start_nets.sh ] && return
+- if [ -f $ACXDIR/../scripts/start_net.sh ]; then
++ [ -f $ACXDIR/script/start_net.sh ] && return
++ if [ -f $ACXDIR/../script/start_net.sh ]; then
+ ACXDIR="$ACXDIR/.."
+ return
+ fi
+diff -urNad acx100-20080210~/script/inject_kernel_tree.sh acx100-20080210/script/inject_kernel_tree.sh
+--- acx100-20080210~/script/inject_kernel_tree.sh 2008-02-10 21:06:42.000000000 +0100
++++ acx100-20080210/script/inject_kernel_tree.sh 2009-11-05 12:47:55.000000000 +0100
+@@ -31,7 +31,7 @@
+ }
+
+ print "- Checking acx sources...\n";
+-my $kernel_help = "$from_dir/scripts/kernel_help";
++my $kernel_help = "$from_dir/script/kernel_help";
+ if (!-e "$from_dir/src") {
+ print "*** $from_dir/src doesn't exist!\n";
+ exit 1;
diff --git a/net-wireless/acx/files/2.6.31+-mepis/03_typo_fix.dpatch.gz b/net-wireless/acx/files/2.6.31+-mepis/03_typo_fix.dpatch.gz
deleted file mode 100644
index 3df3b964c635..000000000000
--- a/net-wireless/acx/files/2.6.31+-mepis/03_typo_fix.dpatch.gz
+++ /dev/null
Binary files differ
diff --git a/net-wireless/acx/files/2.6.31+-mepis/04_pci_and_usb.dpatch b/net-wireless/acx/files/2.6.31+-mepis/04_pci_and_usb.dpatch
new file mode 100644
index 000000000000..31688d8c98ad
--- /dev/null
+++ b/net-wireless/acx/files/2.6.31+-mepis/04_pci_and_usb.dpatch
@@ -0,0 +1,90 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## acx_kernel_update.dpatch by
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Let acx100 compile with 2.6.31 and 2.6.32 kernels
+
+@DPATCH@
+
+--- old_acx-20080210/pci.c 2009-11-09 13:48:14.000000000 +0200
++++ acx-20080210/pci.c 2009-11-09 13:53:34.000000000 +0200
+@@ -1437,6 +1437,17 @@
+
+ static void dummy_netdev_init(struct net_device *ndev) {}
+
++static const struct net_device_ops acx_net_device_ops =
++{
++ .ndo_open = acxpci_e_open,
++ .ndo_stop = acxpci_e_close,
++ .ndo_start_xmit = acx_i_start_xmit,
++ .ndo_get_stats = acx_e_get_stats,
++ .ndo_set_multicast_list = acxpci_i_set_multicast_list,
++ .ndo_tx_timeout = acxpci_i_tx_timeout,
++ .ndo_change_mtu = acx_e_change_mtu,
++};
++
+ #ifdef CONFIG_PCI
+ static int __devinit acxpci_e_probe(struct pci_dev *pdev, const struct pci_device_id *id)
+ {
+@@ -1547,17 +1558,11 @@
+ }
+
+ ether_setup(ndev);
+- ndev->open = &acxpci_e_open;
+- ndev->stop = &acxpci_e_close;
+- ndev->hard_start_xmit = &acx_i_start_xmit;
+- ndev->get_stats = &acx_e_get_stats;
++ ndev->netdev_ops = &acx_net_device_ops;
+ #if IW_HANDLER_VERSION <= 5
+ ndev->get_wireless_stats = &acx_e_get_wireless_stats;
+ #endif
+ ndev->wireless_handlers = (struct iw_handler_def *)&acx_ioctl_handler_def;
+- ndev->set_multicast_list = &acxpci_i_set_multicast_list;
+- ndev->tx_timeout = &acxpci_i_tx_timeout;
+- ndev->change_mtu = &acx_e_change_mtu;
+ ndev->watchdog_timeo = 4 * HZ;
+ ndev->irq = pdev->irq;
+ ndev->base_addr = pci_resource_start(pdev, 0);
+diff -Naur old_acx-20080210/usb.c acx-20080210/usb.c
+--- old_acx-20080210/usb.c 2009-11-09 13:48:14.000000000 +0200
++++ acx-20080210/usb.c 2009-11-09 13:55:26.000000000 +0200
+@@ -778,6 +778,17 @@
+ static void
+ dummy_netdev_init(struct net_device *ndev) {}
+
++static const struct net_device_ops acx_net_device_ops =
++{
++ .ndo_open = acxusb_e_open,
++ .ndo_stop = acxusb_e_close,
++ .ndo_start_xmit = acx_i_start_xmit,
++ .ndo_get_stats = acx_e_get_stats,
++ .ndo_set_multicast_list = acxusb_i_set_rx_mode,
++ .ndo_tx_timeout = acxusb_i_tx_timeout,
++ .ndo_change_mtu = acx_e_change_mtu,
++};
++
+ static int
+ acxusb_e_probe(struct usb_interface *intf, const struct usb_device_id *devID)
+ {
+@@ -845,20 +856,14 @@
+ /* Register the callbacks for the network device functions */
+
+ ether_setup(ndev);
+- ndev->open = &acxusb_e_open;
+- ndev->stop = &acxusb_e_close;
+- ndev->hard_start_xmit = (void *)&acx_i_start_xmit;
+- ndev->get_stats = (void *)&acx_e_get_stats;
++ ndev->netdev_ops = &acx_net_device_ops;
+ #if IW_HANDLER_VERSION <= 5
+ ndev->get_wireless_stats = (void *)&acx_e_get_wireless_stats;
+ #endif
+ ndev->wireless_handlers = (struct iw_handler_def *)&acx_ioctl_handler_def;
+- ndev->set_multicast_list = (void *)&acxusb_i_set_rx_mode;
+ #ifdef HAVE_TX_TIMEOUT
+- ndev->tx_timeout = &acxusb_i_tx_timeout;
+ ndev->watchdog_timeo = 4 * HZ;
+ #endif
+- ndev->change_mtu = &acx_e_change_mtu;
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24)) && defined(SET_MODULE_OWNER)
+ SET_MODULE_OWNER(ndev);
+ #endif
diff --git a/net-wireless/acx/files/2.6.31+-mepis/04_pci_and_usb.dpatch.gz b/net-wireless/acx/files/2.6.31+-mepis/04_pci_and_usb.dpatch.gz
deleted file mode 100644
index 18a856cebe0f..000000000000
--- a/net-wireless/acx/files/2.6.31+-mepis/04_pci_and_usb.dpatch.gz
+++ /dev/null
Binary files differ