summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-12-07 19:40:29 +0000
committerChristian Heim <phreak@gentoo.org>2006-12-07 19:40:29 +0000
commitf8679daf713a9eff42a582f4b246c12bd3c8c1c6 (patch)
tree9fb2736f270fd5209a3d881f4aff3924c7d28c0a /net-wireless/ieee80211
parentclean out old ebuilds (diff)
downloadgentoo-2-f8679daf713a9eff42a582f4b246c12bd3c8c1c6.tar.gz
gentoo-2-f8679daf713a9eff42a582f4b246c12bd3c8c1c6.tar.bz2
gentoo-2-f8679daf713a9eff42a582f4b246c12bd3c8c1c6.zip
Adding a patch for ieee80211-1.1.13 compilation against linux-2.6.19 (thanks to Scott Van Der Wall <svdw@udel.edu> for the patch and Stefan for bugging me about it).
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'net-wireless/ieee80211')
-rw-r--r--net-wireless/ieee80211/ChangeLog8
-rw-r--r--net-wireless/ieee80211/files/ieee80211-1.1.13-linux-2.6.19.patch101
-rw-r--r--net-wireless/ieee80211/ieee80211-1.1.13-r1.ebuild9
3 files changed, 114 insertions, 4 deletions
diff --git a/net-wireless/ieee80211/ChangeLog b/net-wireless/ieee80211/ChangeLog
index 42fe34d28b33..1a6bd3d4a5da 100644
--- a/net-wireless/ieee80211/ChangeLog
+++ b/net-wireless/ieee80211/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/ieee80211
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ieee80211/ChangeLog,v 1.41 2006/10/13 12:28:07 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ieee80211/ChangeLog,v 1.42 2006/12/07 19:40:29 phreak Exp $
+
+ 07 Dec 2006; Christian Heim <phreak@gentoo.org>
+ +files/ieee80211-1.1.13-linux-2.6.19.patch, ieee80211-1.1.13-r1.ebuild:
+ Adding a patch for ieee80211-1.1.13 compilation against linux-2.6.19 (thanks to
+ Scott Van Der Wall <svdw@udel.edu> for the patch and Stefan for bugging me
+ about it).
13 Oct 2006; Christian Heim <phreak@gentoo.org>
-files/ieee80211-1.1.14-smp-disconnect.patch, -ieee80211-1.1.14.ebuild,
diff --git a/net-wireless/ieee80211/files/ieee80211-1.1.13-linux-2.6.19.patch b/net-wireless/ieee80211/files/ieee80211-1.1.13-linux-2.6.19.patch
new file mode 100644
index 000000000000..e9e95601b7dd
--- /dev/null
+++ b/net-wireless/ieee80211/files/ieee80211-1.1.13-linux-2.6.19.patch
@@ -0,0 +1,101 @@
+Index: ieee80211-1.1.13/ieee80211_crypt_ccmp.c
+===================================================================
+--- ieee80211-1.1.13.orig/ieee80211_crypt_ccmp.c
++++ ieee80211-1.1.13/ieee80211_crypt_ccmp.c
+@@ -8,8 +8,9 @@
+ * published by the Free Software Foundation. See README and COPYING for
+ * more details.
+ */
+-
++#ifndef AUTOCONF_INCLUDED
+ #include <linux/config.h>
++#endif
+ #include <linux/module.h>
+ #include <linux/init.h>
+ #include <linux/slab.h>
+Index: ieee80211-1.1.13/ieee80211_crypt_tkip.c
+===================================================================
+--- ieee80211-1.1.13.orig/ieee80211_crypt_tkip.c
++++ ieee80211-1.1.13/ieee80211_crypt_tkip.c
+@@ -8,8 +8,9 @@
+ * published by the Free Software Foundation. See README and COPYING for
+ * more details.
+ */
+-
++#ifndef AUTOCONF_INCLUDED
+ #include <linux/config.h>
++#endif
+ #include <linux/module.h>
+ #include <linux/init.h>
+ #include <linux/slab.h>
+Index: ieee80211-1.1.13/ieee80211_crypt_wep.c
+===================================================================
+--- ieee80211-1.1.13.orig/ieee80211_crypt_wep.c
++++ ieee80211-1.1.13/ieee80211_crypt_wep.c
+@@ -8,8 +8,9 @@
+ * published by the Free Software Foundation. See README and COPYING for
+ * more details.
+ */
+-
++#ifndef AUTOCONF_INCLUDED
+ #include <linux/config.h>
++#endif
+ #include <linux/module.h>
+ #include <linux/init.h>
+ #include <linux/slab.h>
+Index: ieee80211-1.1.13/ieee80211_geo.c
+===================================================================
+--- ieee80211-1.1.13.orig/ieee80211_geo.c
++++ ieee80211-1.1.13/ieee80211_geo.c
+@@ -24,7 +24,9 @@
+
+ ******************************************************************************/
+ #include <linux/compiler.h>
++#ifndef AUTOCONF_INCLUDED
+ #include <linux/config.h>
++#endif
+ #include <linux/errno.h>
+ #include <linux/if_arp.h>
+ #include <linux/in6.h>
+Index: ieee80211-1.1.13/ieee80211_module.c
+===================================================================
+--- ieee80211-1.1.13.orig/ieee80211_module.c
++++ ieee80211-1.1.13/ieee80211_module.c
+@@ -31,7 +31,9 @@
+ *******************************************************************************/
+
+ #include <linux/compiler.h>
++#ifndef AUTOCONF_INCLUDED
+ #include <linux/config.h>
++#endif
+ #include <linux/errno.h>
+ #include <linux/if_arp.h>
+ #include <linux/in6.h>
+Index: ieee80211-1.1.13/ieee80211_rx.c
+===================================================================
+--- ieee80211-1.1.13.orig/ieee80211_rx.c
++++ ieee80211-1.1.13/ieee80211_rx.c
+@@ -14,7 +14,9 @@
+ */
+
+ #include <linux/compiler.h>
++#ifndef AUTOCONF_INCLUDED
+ #include <linux/config.h>
++#endif
+ #include <linux/errno.h>
+ #include <linux/if_arp.h>
+ #include <linux/in6.h>
+Index: ieee80211-1.1.13/ieee80211_tx.c
+===================================================================
+--- ieee80211-1.1.13.orig/ieee80211_tx.c
++++ ieee80211-1.1.13/ieee80211_tx.c
+@@ -24,7 +24,9 @@
+
+ ******************************************************************************/
+ #include <linux/compiler.h>
++#ifndef AUTOCONF_INCLUDED
+ #include <linux/config.h>
++#endif
+ #include <linux/errno.h>
+ #include <linux/if_arp.h>
+ #include <linux/in6.h>
diff --git a/net-wireless/ieee80211/ieee80211-1.1.13-r1.ebuild b/net-wireless/ieee80211/ieee80211-1.1.13-r1.ebuild
index da4dce9e4fac..ff65993df252 100644
--- a/net-wireless/ieee80211/ieee80211-1.1.13-r1.ebuild
+++ b/net-wireless/ieee80211/ieee80211-1.1.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ieee80211/ieee80211-1.1.13-r1.ebuild,v 1.3 2006/10/13 12:22:10 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ieee80211/ieee80211-1.1.13-r1.ebuild,v 1.4 2006/12/07 19:40:29 phreak Exp $
inherit eutils linux-mod
@@ -73,9 +73,12 @@ src_unpack() {
local debug="n"
unpack ${A}
-
cd "${S}"
- epatch "${FILESDIR}"/${P}-*.patch
+
+ epatch "${FILESDIR}/ieee80211-1.1.13-cflags.patch"
+ epatch "${FILESDIR}/ieee80211-1.1.13-tkip.patch"
+ # bug 157076 (ieee80211 doesn't compile against 2.6.19)
+ epatch "${FILESDIR}/ieee80211-1.1.13-linux-2.6.19.patch"
use debug && debug="y"
sed -i \