summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-11-19 21:33:29 +0000
committerMichał Górny <mgorny@gentoo.org>2012-11-19 21:33:29 +0000
commitedd25a945c041f8eb7e6367a167b2dbf40102221 (patch)
treecd2d41144ee760dc8491dda4e344a69e5b1a5300 /net-voip
parentarm stable, bug #438704 (diff)
downloadgentoo-2-edd25a945c041f8eb7e6367a167b2dbf40102221.tar.gz
gentoo-2-edd25a945c041f8eb7e6367a167b2dbf40102221.tar.bz2
gentoo-2-edd25a945c041f8eb7e6367a167b2dbf40102221.zip
Version bump wrt bug #397645. Thanks to Andrew Savchenko for his effort on linphone ebuilds.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/linphone/ChangeLog9
-rw-r--r--net-voip/linphone/files/linphone-3.5.2-nls.patch15
-rw-r--r--net-voip/linphone/linphone-3.5.2.ebuild95
-rw-r--r--net-voip/linphone/metadata.xml1
4 files changed, 119 insertions, 1 deletions
diff --git a/net-voip/linphone/ChangeLog b/net-voip/linphone/ChangeLog
index ffd2eca0f42f..9d58f15b39da 100644
--- a/net-voip/linphone/ChangeLog
+++ b/net-voip/linphone/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-voip/linphone
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/ChangeLog,v 1.67 2012/05/03 07:27:47 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/ChangeLog,v 1.68 2012/11/19 21:33:29 mgorny Exp $
+
+*linphone-3.5.2 (19 Nov 2012)
+
+ 19 Nov 2012; Michał Górny <mgorny@gentoo.org> +files/linphone-3.5.2-nls.patch,
+ +linphone-3.5.2.ebuild, metadata.xml:
+ Version bump wrt bug #397645. Thanks to Andrew Savchenko for his effort on
+ linphone ebuilds.
03 May 2012; Jeff Horelick <jdhore@gentoo.org> linphone-3.1.1.ebuild,
linphone-3.2.1-r2.ebuild, linphone-3.3.2.ebuild, linphone-3.4.3.ebuild,
diff --git a/net-voip/linphone/files/linphone-3.5.2-nls.patch b/net-voip/linphone/files/linphone-3.5.2-nls.patch
new file mode 100644
index 000000000000..b9624048edfe
--- /dev/null
+++ b/net-voip/linphone/files/linphone-3.5.2-nls.patch
@@ -0,0 +1,15 @@
+diff -r 5c0dde6115a0 -r 082bb23f04a9 configure.ac
+--- a/configure.ac Thu Mar 29 12:44:23 2012 +0400
++++ b/configure.ac Thu Mar 29 12:48:40 2012 +0400
+@@ -80,7 +80,10 @@
+ AC_SUBST(GUI_FLAGS)
+
+ dnl localization tools
+-IT_PROG_INTLTOOL([0.40], [no-xml])
++AM_NLS
++if test "$USE_NLS" != "no"; then
++ IT_PROG_INTLTOOL([0.40], [no-xml])
++fi
+
+ AM_CONDITIONAL(BUILD_TESTS,test x$build_tests != xno)
+ dnl Initialize libtool
diff --git a/net-voip/linphone/linphone-3.5.2.ebuild b/net-voip/linphone/linphone-3.5.2.ebuild
new file mode 100644
index 000000000000..996994e45f42
--- /dev/null
+++ b/net-voip/linphone/linphone-3.5.2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/linphone-3.5.2.ebuild,v 1.1 2012/11/19 21:33:29 mgorny Exp $
+
+EAPI="4"
+
+inherit autotools eutils multilib pax-utils versionator
+
+DESCRIPTION="Video softphone based on the SIP protocol"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="mirror://nongnu/${PN}/$(get_version_component_range 1-2).x/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# TODO: run-time test for ipv6: does it need mediastreamer[ipv6]?
+IUSE="doc gsm-nonstandard gtk ipv6 ncurses nls ssl video"
+
+RDEPEND=">=media-libs/mediastreamer-2.8.2[video?,ipv6?]
+ >=net-libs/libeXosip-3.0.2
+ >=net-libs/libosip-3.0.0
+ >=net-libs/libsoup-2.26
+ >=net-libs/ortp-0.20.0
+ gtk? ( dev-libs/glib:2
+ >=gnome-base/libglade-2.4.0:2.0
+ >=x11-libs/gtk+-2.4.0:2
+ x11-libs/libnotify )
+ gsm-nonstandard? ( >=media-libs/mediastreamer-2.8.2[gsm] )
+ ncurses? ( sys-libs/readline
+ sys-libs/ncurses )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/sgmltools-lite )
+ nls? ( dev-util/intltool
+ sys-devel/gettext )"
+
+IUSE_LINGUAS=" fr it de ja es pl cs nl sv pt_BR hu ru zh_CN"
+IUSE="${IUSE}${IUSE_LINGUAS// / linguas_}"
+
+pkg_setup() {
+ if ! use gtk && ! use ncurses ; then
+ ewarn "gtk and ncurses are disabled."
+ ewarn "At least one of these use flags are needed to get a front-end."
+ ewarn "Only liblinphone is going to be installed."
+ fi
+
+ strip-linguas ${IUSE_LINGUAS}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nls.patch
+ # remove speex check, avoid bug when mediastreamer[-speex]
+ sed -i -e '/SPEEX/d' configure.ac || die "patching configure.ac failed"
+
+ # fix path to use lib64
+ sed -i -e "s:lib\(/liblinphone\):$(get_libdir)\1:" configure.ac \
+ || die "patching configure.ac failed"
+
+ # removing bundled libs dir prevent them to be reconf
+ rm -rf mediastreamer2 oRTP || die "should not die"
+ sed -i -e "s:oRTP::;s:mediastreamer2::" Makefile.am \
+ || die "patching Makefile.am failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ # we don't want -Werror
+ --disable-strict
+ # don't bundle libs
+ --enable-external-ortp
+ --enable-external-mediastreamer
+ # seems not used, TODO: ask in ml
+ --disable-truespeech
+ --disable-zrtp
+ $(use_enable doc manual)
+ $(use_enable gsm-nonstandard nonstandard-gsm)
+ $(use_enable gtk gtk_ui)
+ $(use_enable ipv6)
+ $(use_enable ncurses console_ui)
+ $(use_enable nls)
+ $(use_enable video)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdocdir="/usr/share/doc/${PF}" install # 415161
+ dodoc AUTHORS BUGS ChangeLog NEWS README README.arm TODO
+ pax-mark m "${ED}usr/bin/linphone"
+}
diff --git a/net-voip/linphone/metadata.xml b/net-voip/linphone/metadata.xml
index dd9857835ac7..ca525c23a92a 100644
--- a/net-voip/linphone/metadata.xml
+++ b/net-voip/linphone/metadata.xml
@@ -8,6 +8,7 @@
<description>Assign to herd and CC me</description>
</maintainer>
<use>
+ <flag name='gsm-nonstandard'>Support non-standard GSM frequencies</flag>
<flag name='video'>Enable video support (display/capture)</flag>
</use>
</pkgmetadata>