summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-12-29 17:35:31 +0000
committerJeroen Roovers <jer@gentoo.org>2011-12-29 17:35:31 +0000
commit7ef0899367825dc8d65dec30ff57373515be9445 (patch)
treecc0aa31a96cac12da289de4516b404cef2f1871f /net-proxy
parentamd64 stable, bug 393007 (diff)
downloadgentoo-2-7ef0899367825dc8d65dec30ff57373515be9445.tar.gz
gentoo-2-7ef0899367825dc8d65dec30ff57373515be9445.tar.bz2
gentoo-2-7ef0899367825dc8d65dec30ff57373515be9445.zip
Apply upstream patch by Adam Carter (bug #396163).
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/squid/ChangeLog6
-rw-r--r--net-proxy/squid/files/squid-3.1.18-ecap.patch50
-rw-r--r--net-proxy/squid/squid-3.1.18.ebuild5
3 files changed, 58 insertions, 3 deletions
diff --git a/net-proxy/squid/ChangeLog b/net-proxy/squid/ChangeLog
index edbacb9e3b09..d514803ae6c0 100644
--- a/net-proxy/squid/ChangeLog
+++ b/net-proxy/squid/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-proxy/squid
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/ChangeLog,v 1.336 2011/12/24 10:33:20 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/ChangeLog,v 1.337 2011/12/29 17:35:31 jer Exp $
+
+ 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> squid-3.1.18.ebuild,
+ +files/squid-3.1.18-ecap.patch:
+ Apply upstream patch by Adam Carter (bug #396163).
*squid-3.1.18 (24 Dec 2011)
diff --git a/net-proxy/squid/files/squid-3.1.18-ecap.patch b/net-proxy/squid/files/squid-3.1.18-ecap.patch
new file mode 100644
index 000000000000..41f716a4fe5d
--- /dev/null
+++ b/net-proxy/squid/files/squid-3.1.18-ecap.patch
@@ -0,0 +1,50 @@
+------------------------------------------------------------
+revno: 10415
+revision-id: squid3@treenet.co.nz-20111206123135-sm3zauds1twjh9ls
+parent: squid3@treenet.co.nz-20111203061825-aslncq2igkzd88hy
+fixes bug(s): http://bugs.squid-cache.org/show_bug.cgi?id=3440
+author: Joshua Root <josh+squid@root.id.au>
+committer: Amos Jeffries <squid3@treenet.co.nz>
+branch nick: SQUID_3_1
+timestamp: Tue 2011-12-06 05:31:35 -0700
+message:
+ Bug 3440: compile error in Adaptation
+------------------------------------------------------------
+# Bazaar merge directive format 2 (Bazaar 0.90)
+# revision_id: squid3@treenet.co.nz-20111206123135-sm3zauds1twjh9ls
+# target_branch: http://bzr.squid-cache.org/bzr/squid3/branches\
+# /SQUID_3_1/
+# testament_sha1: 42421665894427e4edfaa3f8bfcee9a9a3ce9dab
+# timestamp: 2011-12-06 12:33:05 +0000
+# source_branch: http://bzr.squid-cache.org/bzr/squid3/branches\
+# /SQUID_3_1
+# base_revision_id: squid3@treenet.co.nz-20111203061825-\
+# aslncq2igkzd88hy
+#
+# Begin patch
+=== modified file 'src/Store.h'
+--- a/src/Store.h 2011-12-02 12:17:07 +0000
++++ b/src/Store.h 2011-12-06 12:31:35 +0000
+@@ -191,7 +191,7 @@
+
+ #if USE_ADAPTATION
+ /// call back producer when more buffer space is available
+- void deferProducer(const AsyncCall::Pointer &producer);
++ void deferProducer(AsyncCall::Pointer &producer);
+ /// calls back producer registered with deferProducer
+ void kickProducer();
+ #endif
+
+=== modified file 'src/store.cc'
+--- a/src/store.cc 2011-12-02 12:17:07 +0000
++++ b/src/store.cc 2011-12-06 12:31:35 +0000
+@@ -368,7 +368,7 @@
+
+ #if USE_ADAPTATION
+ void
+-StoreEntry::deferProducer(const AsyncCall::Pointer &producer)
++StoreEntry::deferProducer(AsyncCall::Pointer &producer)
+ {
+ if (!deferredProducer)
+ deferredProducer = producer;
+
diff --git a/net-proxy/squid/squid-3.1.18.ebuild b/net-proxy/squid/squid-3.1.18.ebuild
index ed382f75ed56..8860c7bff5a7 100644
--- a/net-proxy/squid/squid-3.1.18.ebuild
+++ b/net-proxy/squid/squid-3.1.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/squid-3.1.18.ebuild,v 1.1 2011/12/24 10:33:20 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/squid-3.1.18.ebuild,v 1.2 2011/12/29 17:35:31 jer Exp $
EAPI=4
@@ -66,7 +66,8 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.1.15-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-3.1.15-gentoo.patch \
+ "${FILESDIR}"/${PN}-3.1.18-ecap.patch
eautoreconf
}