summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-04-20 01:17:12 +0000
committerAlin Năstac <mrness@gentoo.org>2008-04-20 01:17:12 +0000
commiteacad5cc5fc7df9e941371224c4a497a81c6f03a (patch)
tree1ab8690b6e5128bbe309843b22f1fa59ae418545 /net-proxy/havp
parentwhitespace (diff)
downloadgentoo-2-eacad5cc5fc7df9e941371224c4a497a81c6f03a.tar.gz
gentoo-2-eacad5cc5fc7df9e941371224c4a497a81c6f03a.tar.bz2
gentoo-2-eacad5cc5fc7df9e941371224c4a497a81c6f03a.zip
Version bump (#218087). New version supports clamav-0.93 (#218374).
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-proxy/havp')
-rw-r--r--net-proxy/havp/ChangeLog7
-rw-r--r--net-proxy/havp/havp-0.88.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/net-proxy/havp/ChangeLog b/net-proxy/havp/ChangeLog
index 6b23103f7a5d..8d55193d073c 100644
--- a/net-proxy/havp/ChangeLog
+++ b/net-proxy/havp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-proxy/havp
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/havp/ChangeLog,v 1.23 2008/01/29 10:54:25 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/havp/ChangeLog,v 1.24 2008/04/20 01:17:12 mrness Exp $
+
+*havp-0.88 (20 Apr 2008)
+
+ 20 Apr 2008; Alin Năstac <mrness@gentoo.org> +havp-0.88.ebuild:
+ Version bump (#218087). New version supports clamav-0.93 (#218374).
*havp-0.87 (29 Jan 2008)
diff --git a/net-proxy/havp/havp-0.88.ebuild b/net-proxy/havp/havp-0.88.ebuild
new file mode 100644
index 000000000000..c7256ded462c
--- /dev/null
+++ b/net-proxy/havp/havp-0.88.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/havp/havp-0.88.ebuild,v 1.1 2008/04/20 01:17:12 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="HTTP AntiVirus Proxy"
+HOMEPAGE="http://www.server-side.de/"
+SRC_URI="http://www.server-side.de/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="clamav ssl"
+
+DEPEND="clamav? ( app-antivirus/clamav )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup havp
+ enewuser havp -1 -1 /etc/havp havp
+}
+
+src_compile() {
+ econf --localstatedir=/var \
+ $(use_enable clamav) \
+ $(use_enable ssl ssl-tunnel) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ exeinto /usr/sbin
+ doexe havp/havp
+
+ newinitd "${FILESDIR}/havp.initd" havp
+ insinto /etc
+ doins -r etc/havp
+
+ diropts -m 0700 -o havp -g havp
+ keepdir /var/log/havp
+
+ diropts -m 0750
+ dodir /var/run/havp /var/tmp/havp
+
+ dodoc ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "/var/tmp/havp must be on a filesystem with mandatory locks!"
+ ewarn "You should add \"mand\" to the mount options on the relevant line in /etc/fstab."
+
+ if use ssl; then
+ echo
+ ewarn "Note: ssl USE flag only enable SSL pass-through, which means that"
+ ewarn " HTTPS pages will not be scanned for viruses!"
+ ewarn " It is impossible to decrypt data sent through SSL connections without knowing"
+ ewarn " the private key of the used certificate."
+ fi
+
+ if use clamav; then
+ echo
+ ewarn "If you plan to use clamav daemon, you should make sure clamav user can read"
+ ewarn "/var/tmp/havp content. This can be accomplished by enabling AllowSupplementaryGroups"
+ ewarn "in /etc/clamd.conf and adding clamav user to the havp group."
+ fi
+}