summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-06-07 19:45:32 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-06-07 19:45:32 +0000
commit50cd130735df3fa6dd36c9406b6c450bdf18ff0a (patch)
tree390fb76c27b118e6846b271655b72edbddc072f0 /net-print
parentUpdate libpcre and libsepol deps to include MULTILIB_USEDEP (diff)
downloadgentoo-2-50cd130735df3fa6dd36c9406b6c450bdf18ff0a.tar.gz
gentoo-2-50cd130735df3fa6dd36c9406b6c450bdf18ff0a.tar.bz2
gentoo-2-50cd130735df3fa6dd36c9406b6c450bdf18ff0a.zip
Bump to latest snapshot, adds some new models support and some fixes. Also fetch cms tarball from my devspace
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/splix/ChangeLog11
-rw-r--r--net-print/splix/splix-2.0.0_p20130826.ebuild63
2 files changed, 72 insertions, 2 deletions
diff --git a/net-print/splix/ChangeLog b/net-print/splix/ChangeLog
index d3eddb4673a2..4cf9f5433c39 100644
--- a/net-print/splix/ChangeLog
+++ b/net-print/splix/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-print/splix
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/splix/ChangeLog,v 1.28 2013/08/16 09:30:33 mrueg Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/splix/ChangeLog,v 1.29 2014/06/07 19:45:32 voyageur Exp $
+
+*splix-2.0.0_p20130826 (07 Jun 2014)
+
+ 07 Jun 2014; Bernard Cafarelli <voyageur@gentoo.org>
+ +splix-2.0.0_p20130826.ebuild:
+ Bump to latest snapshot, adds some new models support and some fixes. Also
+ fetch cms tarball from my devspace
16 Aug 2013; Manuel Rüger <mrueg@gentoo.org> -splix-2.0.0_p20110219-r1.ebuild:
Cleanup.
diff --git a/net-print/splix/splix-2.0.0_p20130826.ebuild b/net-print/splix/splix-2.0.0_p20130826.ebuild
new file mode 100644
index 000000000000..0f62299253e1
--- /dev/null
+++ b/net-print/splix/splix-2.0.0_p20130826.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/splix/splix-2.0.0_p20130826.ebuild,v 1.1 2014/06/07 19:45:32 voyageur Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A set of CUPS printer drivers for SPL (Samsung Printer Language) printers"
+HOMEPAGE="http://splix.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.bz2
+ http://dev.gentoo.org/~voyageur/samsung-cms-20120312.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+jbig"
+
+DEPEND=">=app-text/ghostscript-gpl-9.02
+ >=net-print/cups-1.4.0
+ jbig? ( media-libs/jbigkit )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Move to correct place
+ mv *.ppd ppd/ || die "ppd files move failed"
+ # Honor LDFLAGS
+ sed -e "/[a-z]_LDFLAGS/s/:=.*/:= $\{LDFLAGS\}/" -i module.mk \
+ || die "module.mk sed failed"
+ # Correct link comand
+ sed -e "s/g++/$\{LINKER\}/" -i rules.mk \
+ || die "rules.mk sed failed"
+}
+
+src_compile() {
+ local options="MODE=optimized"
+ use jbig || options="${options} DISABLE_JBIG=1"
+ emake ${options} PSTORASTER=gstoraster CXX="$(tc-getCXX)" \
+ OPTIM_CFLAGS="${CFLAGS}" OPTIM_CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ gzip "${ED}"/$(cups-config --datadir)/model/*/*.ppd || die "ppd gzip failed"
+
+ emake DESTDIR="${D}" CMSDIR="${WORKDIR}"/cms MANUFACTURER=samsung installcms
+ # Add symlinks for xerox and dell models (installed in samsung)
+ dosym $(cups-config --datadir)/profiles/samsung $(cups-config --datadir)/profiles/xerox
+ dosym $(cups-config --datadir)/profiles/samsung $(cups-config --datadir)/profiles/dell
+}
+
+pkg_postinst() {
+ ewarn "You *MUST* make sure that the PPD files that CUPS is using"
+ ewarn "for actually installed printers are updated if you upgraded"
+ ewarn "from a previous version of splix!"
+ ewarn "Otherwise you will be unable to print (your printer might"
+ ewarn "spit out blank pages etc.)."
+ ewarn "To do that, simply delete the corresponding PPD file in"
+ ewarn "/etc/cups/ppd/, click on 'Modify Printer' belonging to the"
+ ewarn "corresponding printer in the CUPS webinterface (usually"
+ ewarn "reachable via http://localhost:631/) and choose the correct"
+ ewarn "printer make and model, for example:"
+ ewarn "'Samsung' -> 'Samsung ML-1610, 1.0 (en)'"
+}