summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-06-07 21:37:13 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-06-07 21:37:13 +0000
commit323248228a728ad51476d54789a0c9ee8d330297 (patch)
tree55d9e7d878c9be30b114d0beb7b6353d48eb17ca /net-print
parentMarking ferm-2.1 ppc for bug 419619 (diff)
downloadgentoo-2-323248228a728ad51476d54789a0c9ee8d330297.tar.gz
gentoo-2-323248228a728ad51476d54789a0c9ee8d330297.tar.bz2
gentoo-2-323248228a728ad51476d54789a0c9ee8d330297.zip
Started with live ebuild, does not link yet
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups-filters/ChangeLog9
-rw-r--r--net-print/cups-filters/cups-filters-9999.ebuild59
-rw-r--r--net-print/cups-filters/files/cups-filters-9999-beta.patch202
-rw-r--r--net-print/cups-filters/files/cups-filters-9999-lib.patch19
-rw-r--r--net-print/cups-filters/files/cups-filters-9999-warnings.patch14
5 files changed, 302 insertions, 1 deletions
diff --git a/net-print/cups-filters/ChangeLog b/net-print/cups-filters/ChangeLog
index 9c3fc4981949..9edb98c5c0b8 100644
--- a/net-print/cups-filters/ChangeLog
+++ b/net-print/cups-filters/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-print/cups-filters
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/ChangeLog,v 1.5 2012/06/02 19:47:16 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/ChangeLog,v 1.6 2012/06/07 21:37:12 dilfridge Exp $
+
+*cups-filters-9999 (07 Jun 2012)
+
+ 07 Jun 2012; Andreas K. Huettel <dilfridge@gentoo.org>
+ +cups-filters-9999.ebuild, +files/cups-filters-9999-beta.patch,
+ +files/cups-filters-9999-lib.patch, +files/cups-filters-9999-warnings.patch:
+ Started with live ebuild, does not link yet
*cups-filters-1.0.18 (02 Jun 2012)
diff --git a/net-print/cups-filters/cups-filters-9999.ebuild b/net-print/cups-filters/cups-filters-9999.ebuild
new file mode 100644
index 000000000000..1620404e6dd1
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/cups-filters-9999.ebuild,v 1.1 2012/06/07 21:37:12 dilfridge Exp $
+
+EAPI=4
+
+DESCRIPTION="Cups PDF filters"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdfasstandardprintjobformat"
+
+if [[ "${PV}"=="9999" ]] ; then
+ inherit base autotools bzr
+ EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
+ KEYWORDS=""
+else
+ SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.gz"
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="jpeg lcms png tiff"
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ app-text/poppler[jpeg?,lcms?]
+ media-libs/fontconfig
+ media-libs/freetype:2
+ >net-print/cups-1.5.9999
+ sys-libs/zlib
+ jpeg? ( virtual/jpeg )
+ lcms? ( media-libs/lcms:2 )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-beta.patch"
+ "${FILESDIR}/${P}-warnings.patch"
+ "${FILESDIR}/${P}-lib.patch"
+)
+
+src_prepare() {
+ base_src_prepare
+ if [[ "${PV}"=="9999" ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --with-fontdir=fonts/conf.d \
+ --enable-imagefilters \
+ $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with tiff) \
+ $(use_with lcms cms) \
+ --without-php
+}
diff --git a/net-print/cups-filters/files/cups-filters-9999-beta.patch b/net-print/cups-filters/files/cups-filters-9999-beta.patch
new file mode 100644
index 000000000000..043fe39e79ae
--- /dev/null
+++ b/net-print/cups-filters/files/cups-filters-9999-beta.patch
@@ -0,0 +1,202 @@
+=== modified file 'configure.ac'
+--- configure.ac 2012-06-07 20:49:23 +0000
++++ configure.ac 2012-06-07 21:00:52 +0000
+@@ -16,6 +16,7 @@
+ AC_INIT([cups-filters],[cups_filters_version])
+ AC_CONFIG_MACRO_DIR([m4])
+ m4_include([m4/ac_define_dir.m4])
++m4_include([m4/ax_compare_version.m4])
+ AM_INIT_AUTOMAKE([1.11 gnu dist-xz dist-bzip2])
+ AM_SILENT_RULES([yes])
+ AC_LANG([C++])
+@@ -104,7 +105,7 @@
+ AC_DEFINE_UNQUOTED(CUPS_SERVERBIN, "$CUPS_SERVERBIN", [Path to CUPS binaries dir])
+ AC_SUBST(CUPS_SERVERBIN)
+
+-AS_IF([test `echo $CUPS_VERSION | cut -d '.' -f 2` -ge "4"], [
++AX_COMPARE_VERSION([$CUPS_VERSION],[gt],[1.4], [
+ AC_DEFINE(CUPS_1_4, 1, [CUPS Version is 1.4 or newer])
+ ])
+ AC_DEFINE(PDFTOPDF, [], [Needed for pdftopdf filter compilation])
+
+=== added file 'm4/ax_compare_version.m4'
+--- m4/ax_compare_version.m4 1970-01-01 00:00:00 +0000
++++ m4/ax_compare_version.m4 2012-06-07 20:58:03 +0000
+@@ -0,0 +1,177 @@
++# ===========================================================================
++# http://www.gnu.org/software/autoconf-archive/ax_compare_version.html
++# ===========================================================================
++#
++# SYNOPSIS
++#
++# AX_COMPARE_VERSION(VERSION_A, OP, VERSION_B, [ACTION-IF-TRUE], [ACTION-IF-FALSE])
++#
++# DESCRIPTION
++#
++# This macro compares two version strings. Due to the various number of
++# minor-version numbers that can exist, and the fact that string
++# comparisons are not compatible with numeric comparisons, this is not
++# necessarily trivial to do in a autoconf script. This macro makes doing
++# these comparisons easy.
++#
++# The six basic comparisons are available, as well as checking equality
++# limited to a certain number of minor-version levels.
++#
++# The operator OP determines what type of comparison to do, and can be one
++# of:
++#
++# eq - equal (test A == B)
++# ne - not equal (test A != B)
++# le - less than or equal (test A <= B)
++# ge - greater than or equal (test A >= B)
++# lt - less than (test A < B)
++# gt - greater than (test A > B)
++#
++# Additionally, the eq and ne operator can have a number after it to limit
++# the test to that number of minor versions.
++#
++# eq0 - equal up to the length of the shorter version
++# ne0 - not equal up to the length of the shorter version
++# eqN - equal up to N sub-version levels
++# neN - not equal up to N sub-version levels
++#
++# When the condition is true, shell commands ACTION-IF-TRUE are run,
++# otherwise shell commands ACTION-IF-FALSE are run. The environment
++# variable 'ax_compare_version' is always set to either 'true' or 'false'
++# as well.
++#
++# Examples:
++#
++# AX_COMPARE_VERSION([3.15.7],[lt],[3.15.8])
++# AX_COMPARE_VERSION([3.15],[lt],[3.15.8])
++#
++# would both be true.
++#
++# AX_COMPARE_VERSION([3.15.7],[eq],[3.15.8])
++# AX_COMPARE_VERSION([3.15],[gt],[3.15.8])
++#
++# would both be false.
++#
++# AX_COMPARE_VERSION([3.15.7],[eq2],[3.15.8])
++#
++# would be true because it is only comparing two minor versions.
++#
++# AX_COMPARE_VERSION([3.15.7],[eq0],[3.15])
++#
++# would be true because it is only comparing the lesser number of minor
++# versions of the two values.
++#
++# Note: The characters that separate the version numbers do not matter. An
++# empty string is the same as version 0. OP is evaluated by autoconf, not
++# configure, so must be a string, not a variable.
++#
++# The author would like to acknowledge Guido Draheim whose advice about
++# the m4_case and m4_ifvaln functions make this macro only include the
++# portions necessary to perform the specific comparison specified by the
++# OP argument in the final configure script.
++#
++# LICENSE
++#
++# Copyright (c) 2008 Tim Toolan <toolan@ele.uri.edu>
++#
++# Copying and distribution of this file, with or without modification, are
++# permitted in any medium without royalty provided the copyright notice
++# and this notice are preserved. This file is offered as-is, without any
++# warranty.
++
++#serial 11
++
++dnl #########################################################################
++AC_DEFUN([AX_COMPARE_VERSION], [
++ AC_REQUIRE([AC_PROG_AWK])
++
++ # Used to indicate true or false condition
++ ax_compare_version=false
++
++ # Convert the two version strings to be compared into a format that
++ # allows a simple string comparison. The end result is that a version
++ # string of the form 1.12.5-r617 will be converted to the form
++ # 0001001200050617. In other words, each number is zero padded to four
++ # digits, and non digits are removed.
++ AS_VAR_PUSHDEF([A],[ax_compare_version_A])
++ A=`echo "$1" | sed -e 's/\([[0-9]]*\)/Z\1Z/g' \
++ -e 's/Z\([[0-9]]\)Z/Z0\1Z/g' \
++ -e 's/Z\([[0-9]][[0-9]]\)Z/Z0\1Z/g' \
++ -e 's/Z\([[0-9]][[0-9]][[0-9]]\)Z/Z0\1Z/g' \
++ -e 's/[[^0-9]]//g'`
++
++ AS_VAR_PUSHDEF([B],[ax_compare_version_B])
++ B=`echo "$3" | sed -e 's/\([[0-9]]*\)/Z\1Z/g' \
++ -e 's/Z\([[0-9]]\)Z/Z0\1Z/g' \
++ -e 's/Z\([[0-9]][[0-9]]\)Z/Z0\1Z/g' \
++ -e 's/Z\([[0-9]][[0-9]][[0-9]]\)Z/Z0\1Z/g' \
++ -e 's/[[^0-9]]//g'`
++
++ dnl # In the case of le, ge, lt, and gt, the strings are sorted as necessary
++ dnl # then the first line is used to determine if the condition is true.
++ dnl # The sed right after the echo is to remove any indented white space.
++ m4_case(m4_tolower($2),
++ [lt],[
++ ax_compare_version=`echo "x$A
++x$B" | sed 's/^ *//' | sort -r | sed "s/x${A}/false/;s/x${B}/true/;1q"`
++ ],
++ [gt],[
++ ax_compare_version=`echo "x$A
++x$B" | sed 's/^ *//' | sort | sed "s/x${A}/false/;s/x${B}/true/;1q"`
++ ],
++ [le],[
++ ax_compare_version=`echo "x$A
++x$B" | sed 's/^ *//' | sort | sed "s/x${A}/true/;s/x${B}/false/;1q"`
++ ],
++ [ge],[
++ ax_compare_version=`echo "x$A
++x$B" | sed 's/^ *//' | sort -r | sed "s/x${A}/true/;s/x${B}/false/;1q"`
++ ],[
++ dnl Split the operator from the subversion count if present.
++ m4_bmatch(m4_substr($2,2),
++ [0],[
++ # A count of zero means use the length of the shorter version.
++ # Determine the number of characters in A and B.
++ ax_compare_version_len_A=`echo "$A" | $AWK '{print(length)}'`
++ ax_compare_version_len_B=`echo "$B" | $AWK '{print(length)}'`
++
++ # Set A to no more than B's length and B to no more than A's length.
++ A=`echo "$A" | sed "s/\(.\{$ax_compare_version_len_B\}\).*/\1/"`
++ B=`echo "$B" | sed "s/\(.\{$ax_compare_version_len_A\}\).*/\1/"`
++ ],
++ [[0-9]+],[
++ # A count greater than zero means use only that many subversions
++ A=`echo "$A" | sed "s/\(\([[0-9]]\{4\}\)\{m4_substr($2,2)\}\).*/\1/"`
++ B=`echo "$B" | sed "s/\(\([[0-9]]\{4\}\)\{m4_substr($2,2)\}\).*/\1/"`
++ ],
++ [.+],[
++ AC_WARNING(
++ [illegal OP numeric parameter: $2])
++ ],[])
++
++ # Pad zeros at end of numbers to make same length.
++ ax_compare_version_tmp_A="$A`echo $B | sed 's/./0/g'`"
++ B="$B`echo $A | sed 's/./0/g'`"
++ A="$ax_compare_version_tmp_A"
++
++ # Check for equality or inequality as necessary.
++ m4_case(m4_tolower(m4_substr($2,0,2)),
++ [eq],[
++ test "x$A" = "x$B" && ax_compare_version=true
++ ],
++ [ne],[
++ test "x$A" != "x$B" && ax_compare_version=true
++ ],[
++ AC_WARNING([illegal OP parameter: $2])
++ ])
++ ])
++
++ AS_VAR_POPDEF([A])dnl
++ AS_VAR_POPDEF([B])dnl
++
++ dnl # Execute ACTION-IF-TRUE / ACTION-IF-FALSE.
++ if test "$ax_compare_version" = "true" ; then
++ m4_ifvaln([$4],[$4],[:])dnl
++ m4_ifvaln([$5],[else $5])dnl
++ fi
++]) dnl AX_COMPARE_VERSION
diff --git a/net-print/cups-filters/files/cups-filters-9999-lib.patch b/net-print/cups-filters/files/cups-filters-9999-lib.patch
new file mode 100644
index 000000000000..cfc5ecd252b6
--- /dev/null
+++ b/net-print/cups-filters/files/cups-filters-9999-lib.patch
@@ -0,0 +1,19 @@
+diff -ruN cups-filters-9999.orig/Makefile.am cups-filters-9999/Makefile.am
+--- cups-filters-9999.orig/Makefile.am 2012-06-07 23:26:16.984452000 +0200
++++ cups-filters-9999/Makefile.am 2012-06-07 23:27:48.749653904 +0200
+@@ -513,6 +513,7 @@
+ $(TIFF_CFLAGS)
+ pdftoraster_CXXFLAGS = $(pdftoraster_CFLAGS)
+ pdftoraster_LDADD = \
++ libcupsfilters.la
+ $(CUPS_LIBS) \
+ $(LCMS_LIBS) \
+ $(LIBJPEG_LIBS) \
+@@ -529,6 +530,7 @@
+ -I$(srcdir)/cupsfilters/
+ rastertoescpx_LDADD = \
+ $(CUPS_LIBS) \
++ $(PNG_LIBS) \
+ libcupsfilters.la
+
+ rastertopclx_SOURCES = \
diff --git a/net-print/cups-filters/files/cups-filters-9999-warnings.patch b/net-print/cups-filters/files/cups-filters-9999-warnings.patch
new file mode 100644
index 000000000000..9449ececee21
--- /dev/null
+++ b/net-print/cups-filters/files/cups-filters-9999-warnings.patch
@@ -0,0 +1,14 @@
+diff -ruN cups-filters-9999.orig/configure.ac cups-filters-9999/configure.ac
+--- cups-filters-9999.orig/configure.ac 2012-06-07 23:05:15.965578244 +0200
++++ cups-filters-9999/configure.ac 2012-06-07 23:17:14.788618345 +0200
+@@ -382,8 +382,8 @@
+ ])
+ AS_IF([test x"$GCC" = "xyes"], [
+ # Be tough with warnings and produce less careless code
+- CFLAGS="$CFLAGS -Wall -pedantic -std=gnu99"
+- CXXFLAGS="$CXXFLAGS -Wall -pedantic -Weffc++"
++ CFLAGS="$CFLAGS -pedantic -std=gnu99"
++ CXXFLAGS="$CXXFLAGS -pedantic"
+ ])
+ CFLAGS="$CFLAGS -D_GNU_SOURCE"
+ CXXFLAGS="$CXXFLAGS -D_GNU_SOURCE"