summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-17 19:32:28 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-17 19:32:28 +0000
commit2454289e7612844f4992d33eb3b8498319701413 (patch)
treec2abfead34b58adde3cd3a9ce0eab9a98250790e /net-print
parentoops (diff)
downloadgentoo-2-2454289e7612844f4992d33eb3b8498319701413.tar.gz
gentoo-2-2454289e7612844f4992d33eb3b8498319701413.tar.bz2
gentoo-2-2454289e7612844f4992d33eb3b8498319701413.zip
New ebuild. This is the groundwork for a new and better Gentoo printing
system.
Diffstat (limited to 'net-print')
-rw-r--r--net-print/foomatic/ChangeLog10
-rw-r--r--net-print/foomatic/files/digest-foomatic-2.0.01
-rw-r--r--net-print/foomatic/files/perl-module.diff18
-rw-r--r--net-print/foomatic/foomatic-2.0.0.ebuild55
4 files changed, 84 insertions, 0 deletions
diff --git a/net-print/foomatic/ChangeLog b/net-print/foomatic/ChangeLog
new file mode 100644
index 000000000000..95aff5dbda77
--- /dev/null
+++ b/net-print/foomatic/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-print/foomatic
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic/ChangeLog,v 1.1 2002/10/17 19:32:28 raker Exp $
+
+*foomatic-2.0.0 (17 Oct 2002)
+
+ 17 Oct 2002; Nick Hadaway <raker@gentoo.org> foomatic-2.0.0.ebuild,
+ files/digest-foomatic-2.0.0, files/perl-module.diff :
+ New build. This is the groundwork for a more automated printing
+ setup.
diff --git a/net-print/foomatic/files/digest-foomatic-2.0.0 b/net-print/foomatic/files/digest-foomatic-2.0.0
new file mode 100644
index 000000000000..426c650019ba
--- /dev/null
+++ b/net-print/foomatic/files/digest-foomatic-2.0.0
@@ -0,0 +1 @@
+MD5 410aaa40afcb748f549dc5059ef2e98e foomatic-2.0.0.tar.gz 599253
diff --git a/net-print/foomatic/files/perl-module.diff b/net-print/foomatic/files/perl-module.diff
new file mode 100644
index 000000000000..1b7bd49dee8d
--- /dev/null
+++ b/net-print/foomatic/files/perl-module.diff
@@ -0,0 +1,18 @@
+diff -urN foomatic-2.0.0/Makefile.in foomatic-2.0.0-modified/Makefile.in
+--- foomatic-2.0.0/Makefile.in 2002-07-19 16:18:47.000000000 -0500
++++ foomatic-2.0.0-modified/Makefile.in 2002-10-17 13:58:09.000000000 -0500
+@@ -157,10 +157,10 @@
+ install-bin: check-config lib/Makefile
+ # This is the only way to get the Perl-generated Makefile using
+ # $(DESTDIR) properly
+- ( cd lib && \
+- $(MAKE) PREFIX=$(DESTDIR)$(PERLPREFIX) && \
+- $(MAKE) PREFIX=$(DESTDIR)$(PERLPREFIX) pure_install \
+- )
++# ( cd lib && \
++# $(MAKE) PREFIX=$(DESTDIR)$(PERLPREFIX) && \
++# $(MAKE) PREFIX=$(DESTDIR)$(PERLPREFIX) pure_install \
++# )
+ install -d $(DESTDIR)$(BINDIR)
+ install -d $(DESTDIR)$(SBINDIR)
+ install -d $(DESTDIR)$(ETCDIR)
diff --git a/net-print/foomatic/foomatic-2.0.0.ebuild b/net-print/foomatic/foomatic-2.0.0.ebuild
new file mode 100644
index 000000000000..c44000da5766
--- /dev/null
+++ b/net-print/foomatic/foomatic-2.0.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic/foomatic-2.0.0.ebuild,v 1.1 2002/10/17 19:32:28 raker Exp $
+
+inherit perl-module
+
+S="${WORKDIR}/${P}"
+
+IUSE=""
+
+DESCRIPTION="Generates printer conifgs automagically"
+HOMEPAGE="http://www.linuxprinting.org/foomatic"
+SRC_URI="http://www.linuxprinting.org/download/foomatic/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ dev-libs/libxml2
+ net-misc/wget
+ net-ftp/curl
+ samba? ( net-fs/samba )
+ cups? ( net-print/cups )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/perl-module.diff || die "patch failed"
+
+}
+
+src_compile() {
+
+ econf || die "configure failed"
+
+ emake || die "parallel make failed"
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die "make install failed"
+
+ # install perl modules
+ cd ${S}/lib
+ perl-module_src_prep
+ perl-module_src_compile
+ perl-module_src_test
+ perl-module_src_install
+
+}