summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-16 13:57:40 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-16 13:57:40 +0000
commitf8bb5a19109726f1cc64060e4a04c8cd69567c80 (patch)
tree4c93c59f7b11470033370d31c964f6f03bc1983d /net-p2p
parentuse libmpg123 for mp3 decoding and remove internal mp3lib, bug #384849 by Sam... (diff)
downloadgentoo-2-f8bb5a19109726f1cc64060e4a04c8cd69567c80.tar.gz
gentoo-2-f8bb5a19109726f1cc64060e4a04c8cd69567c80.tar.bz2
gentoo-2-f8bb5a19109726f1cc64060e4a04c8cd69567c80.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gtk-gnutella/ChangeLog7
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-0.98.1.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/net-p2p/gtk-gnutella/ChangeLog b/net-p2p/gtk-gnutella/ChangeLog
index bbe5815560eb..d3f3f936815d 100644
--- a/net-p2p/gtk-gnutella/ChangeLog
+++ b/net-p2p/gtk-gnutella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/gtk-gnutella
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.124 2011/12/12 08:34:09 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.125 2011/12/16 13:57:40 graaff Exp $
+
+*gtk-gnutella-0.98.1 (16 Dec 2011)
+
+ 16 Dec 2011; Hans de Graaff <graaff@gentoo.org> +gtk-gnutella-0.98.1.ebuild:
+ Version bump.
12 Dec 2011; Hans de Graaff <graaff@gentoo.org> +gtk-gnutella-0.98.ebuild:
Version bump.
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-0.98.1.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-0.98.1.ebuild
new file mode 100644
index 000000000000..ce5c53313469
--- /dev/null
+++ b/net-p2p/gtk-gnutella/gtk-gnutella-0.98.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/gtk-gnutella-0.98.1.ebuild,v 1.1 2011/12/16 13:57:40 graaff Exp $
+
+EAPI="2"
+
+inherit eutils
+
+IUSE="nls dbus ssl +gtk"
+
+DESCRIPTION="A GTK+ Gnutella client"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ gtk? ( >=x11-libs/gtk+-2.2.1:2 )
+ dbus? ( >=sys-apps/dbus-0.35.2 )
+ ssl? ( >=net-libs/gnutls-2.2.5 )
+ nls? ( >=sys-devel/gettext-0.11.5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ # There is no option to turn off optimization through the build.sh
+ # script.
+ sed -i -e "s/Configure -Oder/Configure -Oder -Doptimize=none/" build.sh || die
+
+ # The build script does not support the equivalent --enable
+ # options so we must construct the configuration by hand.
+
+ local myconf
+
+ if ! use nls; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if ! use dbus; then
+ myconf="${myconf} --disable-dbus"
+ fi
+
+ if ! use ssl; then
+ myconf="${myconf} --disable-gnutls"
+ fi
+
+ if use gtk; then
+ myconf="${myconf} --gtk2"
+ else
+ myconf="${myconf} --topless"
+ fi
+
+ ./build.sh \
+ --configure-only \
+ --prefix="/usr" \
+ --cc=$(tc-getCC) \
+ ${myconf}
+}
+
+src_install() {
+ dodir /usr/bin
+ emake INSTALL_PREFIX="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog README TODO
+
+ # Touch the symbols file into the future to avoid warnings from
+ # gtk-gnutella later on, since we will most likely strip the binary.
+ touch --date="next minute" "${D}/usr/lib/gtk-gnutella/gtk-gnutella.nm" || die
+}