summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-01-13 10:24:13 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-01-13 10:24:13 +0000
commitf88e70afc606ab1cd8b23b36ef09b9d0175d67c1 (patch)
tree542e07c71a3bf579ccf41153817c7011a6355828 /net-p2p
parentAdded missing qt4 in IUSE (diff)
downloadgentoo-2-f88e70afc606ab1cd8b23b36ef09b9d0175d67c1.tar.gz
gentoo-2-f88e70afc606ab1cd8b23b36ef09b9d0175d67c1.tar.bz2
gentoo-2-f88e70afc606ab1cd8b23b36ef09b9d0175d67c1.zip
Version bump
(Portage version: 2.1.6.4/cvs/Linux 2.6.26-gentoo-r2 ia64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/ChangeLog8
-rw-r--r--net-p2p/deluge/deluge-1.1.0.ebuild (renamed from net-p2p/deluge/deluge-1.1.0_rc3.ebuild)20
-rw-r--r--net-p2p/deluge/deluge-1.1.0_rc1.ebuild66
-rw-r--r--net-p2p/deluge/deluge-1.1.0_rc2.ebuild66
4 files changed, 13 insertions, 147 deletions
diff --git a/net-p2p/deluge/ChangeLog b/net-p2p/deluge/ChangeLog
index 8649dfb03fbe..f1fda28dbf64 100644
--- a/net-p2p/deluge/ChangeLog
+++ b/net-p2p/deluge/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/deluge
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.107 2009/01/06 16:11:13 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.108 2009/01/13 10:24:13 armin76 Exp $
+
+*deluge-1.1.0 (13 Jan 2009)
+
+ 13 Jan 2009; Raúl Porcel <armin76@gentoo.org> -deluge-1.1.0_rc1.ebuild,
+ -deluge-1.1.0_rc2.ebuild, -deluge-1.1.0_rc3.ebuild, +deluge-1.1.0.ebuild:
+ Version bump
*deluge-1.1.0_rc3 (06 Jan 2009)
diff --git a/net-p2p/deluge/deluge-1.1.0_rc3.ebuild b/net-p2p/deluge/deluge-1.1.0.ebuild
index d5dda957770b..e9a8c934c5c5 100644
--- a/net-p2p/deluge/deluge-1.1.0_rc3.ebuild
+++ b/net-p2p/deluge/deluge-1.1.0.ebuild
@@ -1,15 +1,14 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.1.0_rc3.ebuild,v 1.1 2009/01/06 16:11:13 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.1.0.ebuild,v 1.1 2009/01/13 10:24:13 armin76 Exp $
-inherit eutils distutils flag-o-matic
+EAPI="2"
-MY_PV="${PV/rc/RC}"
-MY_P="${PN}-${MY_PV}"
+inherit eutils distutils flag-o-matic
DESCRIPTION="BitTorrent client with a client/server model."
HOMEPAGE="http://deluge-torrent.org/"
-SRC_URI="http://download.deluge-torrent.org/source/${MY_PV}/${MY_P}.tar.bz2"
+SRC_URI="http://download.deluge-torrent.org/source/${PV}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -17,8 +16,8 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE="gtk"
DEPEND=">=dev-lang/python-2.4
- dev-libs/boost
- dev-python/setuptools"
+ dev-python/setuptools
+ || ( >=dev-libs/boost-1.34 =dev-libs/boost-1.33*[threads] )"
RDEPEND="${DEPEND}
dev-python/pyxdg
dev-python/pygobject
@@ -29,14 +28,7 @@ RDEPEND="${DEPEND}
gnome-base/librsvg
)"
-S="${WORKDIR}/${MY_P}"
-
pkg_setup() {
- if ! built_with_use --missing true "dev-libs/boost" threads; then
- eerror "dev-libs/boost has to be built with threads USE-flag."
- die "Missing threads USE-flag for dev-libs/boost"
- fi
-
filter-ldflags -Wl,--as-needed
}
diff --git a/net-p2p/deluge/deluge-1.1.0_rc1.ebuild b/net-p2p/deluge/deluge-1.1.0_rc1.ebuild
deleted file mode 100644
index f4f22e69aece..000000000000
--- a/net-p2p/deluge/deluge-1.1.0_rc1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.1.0_rc1.ebuild,v 1.2 2008/12/26 17:21:37 armin76 Exp $
-
-inherit eutils distutils flag-o-matic
-
-MY_PV="${PV/rc/RC}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="BitTorrent client with a client/server model."
-HOMEPAGE="http://deluge-torrent.org/"
-SRC_URI="http://download.deluge-torrent.org/source/${MY_PV}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="gtk"
-
-DEPEND=">=dev-lang/python-2.4
- dev-libs/boost
- dev-python/setuptools"
-RDEPEND="${DEPEND}
- dev-python/pyxdg
- dev-python/pygobject
- gtk? (
- >=dev-python/pygtk-2
- dev-python/pyxdg
- dev-python/dbus-python
- gnome-base/librsvg
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if ! built_with_use --missing true "dev-libs/boost" threads; then
- eerror "dev-libs/boost has to be built with threads USE-flag."
- die "Missing threads USE-flag for dev-libs/boost"
- fi
-
- filter-ldflags -Wl,--as-needed
-}
-
-src_install() {
- distutils_src_install
- newinitd "${FILESDIR}"/deluged.init deluged
- newconfd "${FILESDIR}"/deluged.conf deluged
-}
-
-pkg_postinst() {
- elog
- elog "If after upgrading it doesn't work, please remove the"
- elog "'~/.config/deluge' directory and try again, but make a backup"
- elog "first!"
- elog
- einfo "Please note that Deluge is still in it's early stages"
- einfo "of development. Use it carefully and feel free to submit bugs"
- einfo "in upstream page."
- elog
- elog "To start the daemon either run 'deluged' as user"
- elog "or modify /etc/conf.d/deluged and run"
- elog "/etc/init.d/deluged start as root"
- elog "You can still use deluge the old way"
- elog
- elog "For more information look at http://dev.deluge-torrent.org/wiki/Faq"
- elog
-}
diff --git a/net-p2p/deluge/deluge-1.1.0_rc2.ebuild b/net-p2p/deluge/deluge-1.1.0_rc2.ebuild
deleted file mode 100644
index c7ad03aedb09..000000000000
--- a/net-p2p/deluge/deluge-1.1.0_rc2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.1.0_rc2.ebuild,v 1.1 2008/12/30 12:31:04 armin76 Exp $
-
-inherit eutils distutils flag-o-matic
-
-MY_PV="${PV/rc/RC}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="BitTorrent client with a client/server model."
-HOMEPAGE="http://deluge-torrent.org/"
-SRC_URI="http://download.deluge-torrent.org/source/${MY_PV}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="gtk"
-
-DEPEND=">=dev-lang/python-2.4
- dev-libs/boost
- dev-python/setuptools"
-RDEPEND="${DEPEND}
- dev-python/pyxdg
- dev-python/pygobject
- gtk? (
- >=dev-python/pygtk-2
- dev-python/pyxdg
- dev-python/dbus-python
- gnome-base/librsvg
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if ! built_with_use --missing true "dev-libs/boost" threads; then
- eerror "dev-libs/boost has to be built with threads USE-flag."
- die "Missing threads USE-flag for dev-libs/boost"
- fi
-
- filter-ldflags -Wl,--as-needed
-}
-
-src_install() {
- distutils_src_install
- newinitd "${FILESDIR}"/deluged.init deluged
- newconfd "${FILESDIR}"/deluged.conf deluged
-}
-
-pkg_postinst() {
- elog
- elog "If after upgrading it doesn't work, please remove the"
- elog "'~/.config/deluge' directory and try again, but make a backup"
- elog "first!"
- elog
- einfo "Please note that Deluge is still in it's early stages"
- einfo "of development. Use it carefully and feel free to submit bugs"
- einfo "in upstream page."
- elog
- elog "To start the daemon either run 'deluged' as user"
- elog "or modify /etc/conf.d/deluged and run"
- elog "/etc/init.d/deluged start as root"
- elog "You can still use deluge the old way"
- elog
- elog "For more information look at http://dev.deluge-torrent.org/wiki/Faq"
- elog
-}