summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-01 13:19:29 +0000
committerIan Delaney <idella4@gentoo.org>2015-08-01 13:19:29 +0000
commitec6fb994c76a030b923df2859fbc014bbf56d49c (patch)
tree7ea5a6a94aa3d6c322b16f7af849a49c84ecb190 /net-p2p
parentAdd py3.4 hugs (diff)
downloadgentoo-2-ec6fb994c76a030b923df2859fbc014bbf56d49c.tar.gz
gentoo-2-ec6fb994c76a030b923df2859fbc014bbf56d49c.tar.bz2
gentoo-2-ec6fb994c76a030b923df2859fbc014bbf56d49c.zip
bump; a snapshot of a post release to address a version update of library miniupnpc wrt bugs #555724 & #555560. SRC_URI adjusted accordingly, also improvements to syntax and style
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/classified-ads/ChangeLog10
-rw-r--r--net-p2p/classified-ads/classified-ads-0.07_p20150728.ebuild82
2 files changed, 91 insertions, 1 deletions
diff --git a/net-p2p/classified-ads/ChangeLog b/net-p2p/classified-ads/ChangeLog
index 7bf5fd9b5805..4a848dbf2d4e 100644
--- a/net-p2p/classified-ads/ChangeLog
+++ b/net-p2p/classified-ads/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/classified-ads
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/classified-ads/ChangeLog,v 1.2 2015/07/13 06:56:29 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/classified-ads/ChangeLog,v 1.3 2015/08/01 13:19:29 idella4 Exp $
+
+*classified-ads-0.07_p20150728 (01 Aug 2015)
+
+ 01 Aug 2015; Ian Delaney <idella4@gentoo.org>
+ +classified-ads-0.07_p20150728.ebuild:
+ bump; a snapshot of a post release to address a version update of library
+ miniupnpc wrt bugs #555724 & #555560. SRC_URI adjusted accordingly, also
+ improvements to syntax and style
13 Jul 2015; Ian Delaney <idella4@gentoo.org> classified-ads-0.07.ebuild:
remove keyword arm for now due to lack of required pre-testing
diff --git a/net-p2p/classified-ads/classified-ads-0.07_p20150728.ebuild b/net-p2p/classified-ads/classified-ads-0.07_p20150728.ebuild
new file mode 100644
index 000000000000..e12131d3faad
--- /dev/null
+++ b/net-p2p/classified-ads/classified-ads-0.07_p20150728.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/classified-ads/classified-ads-0.07_p20150728.ebuild,v 1.1 2015/08/01 13:19:29 idella4 Exp $
+
+EAPI=5
+PLOCALES="en fi sv"
+PLOCALE_BACKUP="en"
+inherit qt4-r2 vcs-snapshot
+
+COMMIT_ID="dd2017f3be9d5d68d5fb85af2d626424b3e712e0"
+DESCRIPTION="Program for displaying classified advertisement items"
+HOMEPAGE="http://katiska.org/classified-ads/"
+SRC_URI="https://github.com/operatornormal/classified-ads/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz \
+ https://github.com/operatornormal/classified-ads/blob/graphics/preprocessed.tar.gz?raw=true \
+ -> classified-ads-graphics-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug doc test"
+
+RDEPEND="dev-libs/openssl:0
+ dev-libs/qjson
+ >=net-libs/libnatpmp-20130911
+ <=net-libs/libnatpmp-20140401-r1
+ >=net-libs/miniupnpc-1.8
+ sys-apps/file
+ dev-qt/qtgui:4[debug?]"
+
+DEPEND="${RDEPEND}
+ dev-qt/qttest:4
+ sys-devel/gdb:0
+ doc? ( app-doc/doxygen[dot] )
+ test? ( dev-libs/libgcrypt:0 )
+ "
+
+src_prepare() {
+ # preprocessed graphics are unpacked into wrong directory
+ # so lets move them into correct location:
+ mv ../classified-ads-graphics-${PV}/* ui/ || die
+ # then just run qmake
+ qt4-r2_src_prepare
+}
+
+src_compile() {
+ qt4-r2_src_compile
+ if use doc; then
+ cd doc || die
+ doxygen || die
+ fi
+}
+
+src_test() {
+ cd test || die "test suite missing"
+ qmake || die "test suite configure failed"
+ emake
+
+ if [ -e $HOME/.classified_ads/sqlite_db ]; then
+ mv $HOME/.classified_ads/sqlite_db $HOME/.classified_ads/sqlite_db.backup \
+ || die "datafile backup failed"
+ fi
+ ./testca
+ result=$?
+ rm $HOME/.classified_ads/sqlite_db || true
+
+ if [ -e $HOME/.classified_ads/sqlite_db.backup ]; then
+ mv $HOME/.classified_ads/sqlite_db.backup $HOME/.classified_ads/sqlite_db \
+ || die "datafile restore failed"
+ fi
+
+ if [ $result != "0" ]; then
+ die "test failed with code $result"
+ fi
+
+ return $result
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+ use doc && dodoc -r doc/doxygen.generated/html/
+}