summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-09-04 10:29:12 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-09-04 10:29:12 +0000
commitc96f9a15452ca0662245293f64e9e95dc68674e9 (patch)
treefd930399fef445f603c133e7aefd1da639d48272 /net-p2p
parentVersion bump, drop old (diff)
downloadgentoo-2-c96f9a15452ca0662245293f64e9e95dc68674e9.tar.gz
gentoo-2-c96f9a15452ca0662245293f64e9e95dc68674e9.tar.bz2
gentoo-2-c96f9a15452ca0662245293f64e9e95dc68674e9.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/tribler/ChangeLog9
-rw-r--r--net-p2p/tribler/tribler-6.3.1.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/net-p2p/tribler/ChangeLog b/net-p2p/tribler/ChangeLog
index 2f452a2b3ffa..726b49e55996 100644
--- a/net-p2p/tribler/ChangeLog
+++ b/net-p2p/tribler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/tribler
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/tribler/ChangeLog,v 1.49 2013/08/11 22:59:17 aballier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/tribler/ChangeLog,v 1.50 2014/09/04 10:29:12 blueness Exp $
+
+*tribler-6.3.1 (04 Sep 2014)
+
+ 04 Sep 2014; Anthony G. Basile <blueness@gentoo.org> +tribler-6.3.1.ebuild:
+ Version bump
11 Aug 2013; Alexis Ballier <aballier@gentoo.org> tribler-6.0.3.ebuild,
tribler-6.1.0.ebuild, tribler-6.2.0.ebuild:
diff --git a/net-p2p/tribler/tribler-6.3.1.ebuild b/net-p2p/tribler/tribler-6.3.1.ebuild
new file mode 100644
index 000000000000..63f83b21e0a9
--- /dev/null
+++ b/net-p2p/tribler/tribler-6.3.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/tribler/tribler-6.3.1.ebuild,v 1.1 2014/09/04 10:29:12 blueness Exp $
+
+EAPI="5"
+
+inherit eutils unpacker
+
+DESCRIPTION="Bittorrent client that does not require a website to discover content"
+HOMEPAGE="http://www.tribler.org/"
+SRC_URI="
+ https://github.com/Tribler/tribler/releases/download/v6.3.1/tribler_6.3.1_all.deb
+ x86? ( https://github.com/Tribler/tribler/releases/download/v6.3.1/tribler-swift_6.3.1_i386.deb )
+ amd64? ( https://github.com/Tribler/tribler/releases/download/v6.3.1/tribler-swift_6.3.1_amd64.deb )"
+
+LICENSE="GPL-2 LGPL-2.1+ PSF-2.4 openssl wxWinLL-3.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vlc"
+
+RDEPEND="
+ dev-lang/python:2.7[sqlite]
+ dev-python/apsw
+ dev-python/feedparser
+ dev-python/m2crypto
+ dev-python/netifaces
+ dev-libs/openssl
+ dev-python/wxpython
+ net-libs/rb_libtorrent
+ vlc? (
+ media-video/vlc
+ media-video/ffmpeg:0
+ )"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/usr/lib/tribler/swift"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-log2homedir.patch"
+ epatch "${FILESDIR}/${PN}-6.2.0-fix-desktop.patch"
+}
+
+src_compile() { :; }
+
+src_install() {
+ #Remove the licenses scattered throughout
+ rm usr/share/doc/${PN}-swift/copyright # LGPL-2.1+
+ rm usr/share/doc/${PN}/copyright # LGPL-2.1+
+ rm usr/share/${PN}/Tribler/binary-LICENSE-postfix.txt # GPL-2 LGPL-2.1+ PSF-2.4 openssl wxWinLL-3.1
+
+ #Rename the doc dir properly
+ mv usr/share/doc/${PN}-swift usr/share/doc/${PN}
+ mv usr/share/doc/${PN} usr/share/doc/${P}
+
+ #Move the readme to the doc dir
+ mv usr/share/${PN}/Tribler/readme.txt usr/share/doc/${P}
+
+ #Copy the rest over
+ cp -pPR usr/ "${ED}"/
+}