summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-08-22 13:55:58 +0000
committerMichael Weber <xmw@gentoo.org>2013-08-22 13:55:58 +0000
commit5ff23d1107d1099c1826b64a3b36010e2480f52e (patch)
treede970661ed7951241665be72c7a3f84809deb2c9 /net-p2p
parentConvert to multilib, bug #463942 by Michał Górny and further modifications... (diff)
downloadgentoo-2-5ff23d1107d1099c1826b64a3b36010e2480f52e.tar.gz
gentoo-2-5ff23d1107d1099c1826b64a3b36010e2480f52e.tar.bz2
gentoo-2-5ff23d1107d1099c1826b64a3b36010e2480f52e.zip
Revbump by lorem_ipsum.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission-remote-cli/ChangeLog8
-rw-r--r--net-p2p/transmission-remote-cli/transmission-remote-cli-1.6.2-r1.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/net-p2p/transmission-remote-cli/ChangeLog b/net-p2p/transmission-remote-cli/ChangeLog
index 47c887f113ea..8c5d017522ec 100644
--- a/net-p2p/transmission-remote-cli/ChangeLog
+++ b/net-p2p/transmission-remote-cli/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/transmission-remote-cli
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission-remote-cli/ChangeLog,v 1.8 2013/08/10 10:47:17 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission-remote-cli/ChangeLog,v 1.9 2013/08/22 13:55:58 xmw Exp $
+
+*transmission-remote-cli-1.6.2-r1 (22 Aug 2013)
+
+ 22 Aug 2013; Michael Weber <xmw@gentoo.org>
+ +transmission-remote-cli-1.6.2-r1.ebuild:
+ Revbump by lorem_ipsum.
10 Aug 2013; Michael Weber <xmw@gentoo.org>
-transmission-remote-cli-1.4.7-r1.ebuild,
diff --git a/net-p2p/transmission-remote-cli/transmission-remote-cli-1.6.2-r1.ebuild b/net-p2p/transmission-remote-cli/transmission-remote-cli-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..c5bd46977ea3
--- /dev/null
+++ b/net-p2p/transmission-remote-cli/transmission-remote-cli-1.6.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission-remote-cli/transmission-remote-cli-1.6.2-r1.ebuild,v 1.1 2013/08/22 13:55:58 xmw Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+PYTHON_REQ_USE="ncurses"
+inherit bash-completion-r1 python-r1
+
+DESCRIPTION="Ncurses interface for the Transmission BitTorrent client"
+HOMEPAGE="https://github.com/fagga/transmission-remote-cli/"
+SRC_URI="https://github.com/fagga/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="geoip rdns"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep dev-python/simplejson[$(python_gen_usedep python2_5)] python2_5)
+ geoip? ( dev-python/geoip-python[$PYTHON_USEDEP] )
+ rdns? ( dev-python/adns-python[$PYTHON_USEDEP] )"
+
+src_install() {
+ python_foreach_impl python_doscript transmission-remote-cli
+ newbashcomp completion/bash/transmission-remote-cli-bash-completion.sh \
+ transmission-remote-cli
+ doman transmission-remote-cli.1
+ dodoc NEWS README.md
+}