summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-07-11 15:07:52 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-07-11 15:07:52 +0000
commit5a2ed5bc9f90d182c39a24e05389dc7bd2a00a0e (patch)
tree5765255b9161f3a00166d349458aafe941505dbc /net-p2p
parentKeyworded on alpha, bug 525246 (diff)
downloadgentoo-2-5a2ed5bc9f90d182c39a24e05389dc7bd2a00a0e.tar.gz
gentoo-2-5a2ed5bc9f90d182c39a24e05389dc7bd2a00a0e.tar.bz2
gentoo-2-5a2ed5bc9f90d182c39a24e05389dc7bd2a00a0e.zip
Version bump. Bug #554176.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/litecoin-qt/ChangeLog9
-rw-r--r--net-p2p/litecoin-qt/files/0.9.0-sys_leveldb.patch34
-rw-r--r--net-p2p/litecoin-qt/litecoin-qt-0.10.2.2.ebuild (renamed from net-p2p/litecoin-qt/litecoin-qt-0.8.7.1.ebuild)83
-rw-r--r--net-p2p/litecoin-qt/litecoin-qt-0.8.7.2.ebuild143
4 files changed, 83 insertions, 186 deletions
diff --git a/net-p2p/litecoin-qt/ChangeLog b/net-p2p/litecoin-qt/ChangeLog
index 002fa7088eb3..ed70905205fe 100644
--- a/net-p2p/litecoin-qt/ChangeLog
+++ b/net-p2p/litecoin-qt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/litecoin-qt
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/litecoin-qt/ChangeLog,v 1.6 2015/01/07 17:55:57 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/litecoin-qt/ChangeLog,v 1.7 2015/07/11 15:07:52 blueness Exp $
+
+*litecoin-qt-0.10.2.2 (11 Jul 2015)
+
+ 11 Jul 2015; Anthony G. Basile <blueness@gentoo.org>
+ +files/0.9.0-sys_leveldb.patch, +litecoin-qt-0.10.2.2.ebuild,
+ -litecoin-qt-0.8.7.1.ebuild, -litecoin-qt-0.8.7.2.ebuild:
+ Version bump. Bug #554176.
*litecoin-qt-0.8.7.4 (07 Jan 2015)
diff --git a/net-p2p/litecoin-qt/files/0.9.0-sys_leveldb.patch b/net-p2p/litecoin-qt/files/0.9.0-sys_leveldb.patch
new file mode 100644
index 000000000000..60e9f2b20941
--- /dev/null
+++ b/net-p2p/litecoin-qt/files/0.9.0-sys_leveldb.patch
@@ -0,0 +1,34 @@
+commit c38e0af3e021eb0b2aba846c77b06ca71de06b11 (personal-github/sys_leveldb, sys_leveldb)
+Author: Luke Dashjr <luke-jr+git@utopios.org>
+Date: Mon Sep 9 03:06:17 2013 +0000
+
+ configure: Add unsupported --with-system-leveldb configure flag
+
+diff --git a/configure.ac b/configure.ac
+index 3ed4549..5a5852d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -332,10 +332,22 @@ AC_TRY_COMPILE([#include <sys/socket.h>],
+ [ AC_MSG_RESULT(no)]
+ )
+
++dnl Check for leveldb, only if explicitly requested
+ LEVELDB_CPPFLAGS=
+ LIBLEVELDB=
+ LIBMEMENV=
+-AM_CONDITIONAL([EMBEDDED_LEVELDB],[true])
++AC_ARG_WITH([system-leveldb],
++ [AS_HELP_STRING([--with-system-leveldb],
++ [Build with system LevelDB (default is no; DANGEROUS; NOT SUPPORTED)])],
++ [system_leveldb=$withval],
++ [system_leveldb=no]
++)
++if test x$system_leveldb != xno; then
++ LEVELDB_CPPFLAGS=
++ LIBLEVELDB=-lleveldb
++ LIBMEMENV=-lmemenv
++fi
++AM_CONDITIONAL([EMBEDDED_LEVELDB],[test x$system_leveldb = xno])
+ AC_SUBST(LEVELDB_CPPFLAGS)
+ AC_SUBST(LIBLEVELDB)
+ AC_SUBST(LIBMEMENV)
diff --git a/net-p2p/litecoin-qt/litecoin-qt-0.8.7.1.ebuild b/net-p2p/litecoin-qt/litecoin-qt-0.10.2.2.ebuild
index e5b55050517d..970cb7dace70 100644
--- a/net-p2p/litecoin-qt/litecoin-qt-0.8.7.1.ebuild
+++ b/net-p2p/litecoin-qt/litecoin-qt-0.10.2.2.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/litecoin-qt/litecoin-qt-0.8.7.1.ebuild,v 1.2 2014/08/10 20:37:19 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/litecoin-qt/litecoin-qt-0.10.2.2.ebuild,v 1.1 2015/07/11 15:07:52 blueness Exp $
EAPI=5
DB_VER="4.8"
-LANGS="af_ZA ar bg bs ca ca_ES cs cy da de el_GR en eo es es_CL et eu_ES fa fa_IR fi fr fr_CA gu_IN he hi_IN hr hu it ja la lt lv_LV nb nl pl pt_BR pt_PT ro_RO ru sk sr sv th_TH tr uk zh_CN zh_TW"
-inherit db-use eutils fdo-mime gnome2-utils kde4-functions qt4-r2
+LANGS="ach af_ZA ar be_BY bg bs ca_ES ca ca@valencia cmn cs cy da de el_GR en eo es_CL es_DO es_MX es es_UY et eu_ES fa_IR fa fi fr_CA fr gl gu_IN he hi_IN hr hu id_ID it ja ka kk_KZ ko_KR ky la lt lv_LV mn ms_MY nb nl pam pl pt_BR pt_PT ro_RO ru sah sk sl_SI sq sr sv th_TH tr uk ur_PK uz@Cyrl vi vi_VN zh_CN zh_HK zh_TW"
+
+inherit autotools db-use eutils fdo-mime gnome2-utils kde4-functions qt4-r2
MyPV="${PV/_/-}"
MyPN="litecoin"
@@ -20,7 +21,7 @@ SRC_URI="https://github.com/${MyPN}-project/${MyPN}/archive/v${MyPV}.tar.gz -> $
LICENSE="MIT ISC GPL-3 LGPL-2.1 public-domain || ( CC-BY-SA-3.0 LGPL-2.1 )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="dbus ipv6 kde +qrcode upnp"
+IUSE="dbus kde +qrcode qt5 upnp"
RDEPEND="
dev-libs/boost[threads(+)]
@@ -32,10 +33,18 @@ RDEPEND="
net-libs/miniupnpc
)
sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
- <=dev-libs/leveldb-1.12.0[-snappy]
- dev-qt/qtgui:4
- dbus? (
- dev-qt/qtdbus:4
+ virtual/bitcoin-leveldb
+ !qt5? (
+ dev-qt/qtgui:4
+ dbus? (
+ dev-qt/qtdbus:4
+ )
+ )
+ qt5? (
+ dev-qt/qtgui:5
+ dbus? (
+ dev-qt/qtdbus:5
+ )
)
"
DEPEND="${RDEPEND}
@@ -47,8 +56,9 @@ DOCS="doc/README.md doc/release-notes.md"
S="${WORKDIR}/${MyP}"
src_prepare() {
- epatch "${FILESDIR}"/${MyPN}-sys_leveldb.patch
- rm -r src/leveldb
+ epatch "${FILESDIR}/0.9.0-sys_leveldb.patch"
+ eautoreconf
+ rm -r src/leveldb
cd src || die
@@ -66,7 +76,7 @@ src_prepare() {
x="${x/.ts/}"
if ! use "linguas_$x"; then
nolang="$nolang $x"
- rm "$ts"
+ #rm "$ts"
filt="$filt\\|$x"
else
yeslang="$yeslang $x"
@@ -74,46 +84,35 @@ src_prepare() {
done
filt="bitcoin_\\(${filt:2}\\)\\.\(qm\|ts\)"
- sed "/${filt}/d" -i 'qt/bitcoin.qrc'
+ sed "/${filt}/d" -i 'qt/bitcoin_locale.qrc'
einfo "Languages -- Enabled:$yeslang -- Disabled:$nolang"
}
src_configure() {
- OPTS=()
-
- use dbus && OPTS+=("USE_DBUS=1")
+ local my_econf=
if use upnp; then
- OPTS+=("USE_UPNP=1")
+ my_econf="${my_econf} --with-miniupnpc --enable-upnp-default"
else
- OPTS+=("USE_UPNP=-")
- fi
-
- use qrcode && OPTS+=("USE_QRCODE=1")
- use ipv6 || OPTS+=("USE_IPV6=-")
-
- OPTS+=("USE_SYSTEM_LEVELDB=1")
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- if has_version '>=dev-libs/boost-1.52'; then
- OPTS+=("LIBS+=-lboost_chrono\$\$BOOST_LIB_SUFFIX")
+ my_econf="${my_econf} --without-miniupnpc --disable-upnp-default"
fi
-
- #The litecoin codebase is mostly taken from bitcoin-qt
- eqmake4 bitcoin-qt.pro "${OPTS[@]}"
+ econf \
+ --enable-wallet \
+ --disable-ccache \
+ --disable-static \
+ --disable-tests \
+ --with-system-leveldb \
+ --with-system-libsecp256k1 \
+ --without-libs \
+ --without-utils \
+ --without-daemon \
+ --with-gui=$(usex qt5 qt5 qt4) \
+ $(use_with dbus qtdbus) \
+ $(use_with qrcode qrencode) \
+ ${my_econf}
}
-#Tests are broken with and without our litecoin-sys_leveldb.patch
-#src_test() {
-# cd src || die
-# emake -f makefile.unix "${OPTS[@]}" test_litecoin
-# ./test_litecoin || die 'Tests failed'
-#}
-
src_install() {
- qt4-r2_src_install
-
- dobin ${PN}
+ default
insinto /usr/share/pixmaps
newins "share/pixmaps/bitcoin.ico" "${PN}.ico"
diff --git a/net-p2p/litecoin-qt/litecoin-qt-0.8.7.2.ebuild b/net-p2p/litecoin-qt/litecoin-qt-0.8.7.2.ebuild
deleted file mode 100644
index df73b8794eba..000000000000
--- a/net-p2p/litecoin-qt/litecoin-qt-0.8.7.2.ebuild
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/litecoin-qt/litecoin-qt-0.8.7.2.ebuild,v 1.1 2014/08/28 23:08:58 blueness Exp $
-
-EAPI=5
-
-DB_VER="4.8"
-
-LANGS="af_ZA ar bg bs ca ca_ES cs cy da de el_GR en eo es es_CL et eu_ES fa fa_IR fi fr fr_CA gu_IN he hi_IN hr hu it ja la lt lv_LV nb nl pl pt_BR pt_PT ro_RO ru sk sr sv th_TH tr uk zh_CN zh_TW"
-inherit db-use eutils fdo-mime gnome2-utils kde4-functions qt4-r2
-
-MyPV="${PV/_/-}"
-MyPN="litecoin"
-MyP="${MyPN}-${MyPV}"
-
-DESCRIPTION="P2P Internet currency based on Bitcoin but easier to mine"
-HOMEPAGE="https://litecoin.org/"
-SRC_URI="https://github.com/${MyPN}-project/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyP}.tar.gz"
-
-LICENSE="MIT ISC GPL-3 LGPL-2.1 public-domain || ( CC-BY-SA-3.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="dbus ipv6 kde +qrcode upnp"
-
-RDEPEND="
- dev-libs/boost[threads(+)]
- dev-libs/openssl:0[-bindist]
- qrcode? (
- media-gfx/qrencode
- )
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
- <=dev-libs/leveldb-1.12.0[-snappy]
- dev-qt/qtgui:4
- dbus? (
- dev-qt/qtdbus:4
- )
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
-"
-
-DOCS="doc/README.md doc/release-notes.md"
-
-S="${WORKDIR}/${MyP}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${MyPN}-sys_leveldb.patch
- rm -r src/leveldb
-
- cd src || die
-
- local filt= yeslang= nolang=
-
- for lan in $LANGS; do
- if [ ! -e qt/locale/bitcoin_$lan.ts ]; then
- ewarn "Language '$lan' no longer supported. Ebuild needs update."
- fi
- done
-
- for ts in $(ls qt/locale/*.ts)
- do
- x="${ts/*bitcoin_/}"
- x="${x/.ts/}"
- if ! use "linguas_$x"; then
- nolang="$nolang $x"
- rm "$ts"
- filt="$filt\\|$x"
- else
- yeslang="$yeslang $x"
- fi
- done
-
- filt="bitcoin_\\(${filt:2}\\)\\.\(qm\|ts\)"
- sed "/${filt}/d" -i 'qt/bitcoin.qrc'
- einfo "Languages -- Enabled:$yeslang -- Disabled:$nolang"
-}
-
-src_configure() {
- OPTS=()
-
- use dbus && OPTS+=("USE_DBUS=1")
- if use upnp; then
- OPTS+=("USE_UPNP=1")
- else
- OPTS+=("USE_UPNP=-")
- fi
-
- use qrcode && OPTS+=("USE_QRCODE=1")
- use ipv6 || OPTS+=("USE_IPV6=-")
-
- OPTS+=("USE_SYSTEM_LEVELDB=1")
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- if has_version '>=dev-libs/boost-1.52'; then
- OPTS+=("LIBS+=-lboost_chrono\$\$BOOST_LIB_SUFFIX")
- fi
-
- #The litecoin codebase is mostly taken from bitcoin-qt
- eqmake4 bitcoin-qt.pro "${OPTS[@]}"
-}
-
-#Tests are broken with and without our litecoin-sys_leveldb.patch
-#src_test() {
-# cd src || die
-# emake -f makefile.unix "${OPTS[@]}" test_litecoin
-# ./test_litecoin || die 'Tests failed'
-#}
-
-src_install() {
- qt4-r2_src_install
-
- dobin ${PN}
-
- insinto /usr/share/pixmaps
- newins "share/pixmaps/bitcoin.ico" "${PN}.ico"
-
- make_desktop_entry "${PN} %u" "Litecoin-Qt" "/usr/share/pixmaps/${PN}.ico" "Qt;Network;P2P;Office;Finance;" "MimeType=x-scheme-handler/litecoin;\nTerminal=false"
-
- newman contrib/debian/manpages/bitcoin-qt.1 ${PN}.1
-
- if use kde; then
- insinto /usr/share/kde4/services
- newins contrib/debian/bitcoin-qt.protocol ${PN}.protocol
- fi
-}
-
-update_caches() {
- gnome2_icon_cache_update
- fdo-mime_desktop_database_update
- buildsycoca
-}
-
-pkg_postinst() {
- update_caches
-}
-
-pkg_postrm() {
- update_caches
-}