summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-07-01 19:52:14 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-07-01 19:52:14 +0000
commit41191968ff54a979abac96dbc315e0f4a6b23084 (patch)
tree0deb5933f94262deffa2f548b77420c4b099ed79 /net-p2p
parentstable x86, bug 268001 (diff)
downloadgentoo-2-41191968ff54a979abac96dbc315e0f4a6b23084.tar.gz
gentoo-2-41191968ff54a979abac96dbc315e0f4a6b23084.tar.bz2
gentoo-2-41191968ff54a979abac96dbc315e0f4a6b23084.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/nicotine+/ChangeLog9
-rw-r--r--net-p2p/nicotine+/files/nicotine+-1.2.9-locale-handling.patch70
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.10_pre705.ebuild44
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.12.ebuild31
4 files changed, 39 insertions, 115 deletions
diff --git a/net-p2p/nicotine+/ChangeLog b/net-p2p/nicotine+/ChangeLog
index 6403ded4f8d0..e1c39ca6c566 100644
--- a/net-p2p/nicotine+/ChangeLog
+++ b/net-p2p/nicotine+/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/nicotine+
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.31 2009/02/21 16:39:28 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.32 2009/07/01 19:52:13 dirtyepic Exp $
+
+*nicotine+-1.2.12 (01 Jul 2009)
+
+ 01 Jul 2009; Ryan Hill <dirtyepic@gentoo.org>
+ -files/nicotine+-1.2.9-locale-handling.patch,
+ -nicotine+-1.2.10_pre705.ebuild, +nicotine+-1.2.12.ebuild:
+ Version bump.
*nicotine+-1.2.10 (21 Feb 2009)
diff --git a/net-p2p/nicotine+/files/nicotine+-1.2.9-locale-handling.patch b/net-p2p/nicotine+/files/nicotine+-1.2.9-locale-handling.patch
deleted file mode 100644
index 2777b1eec861..000000000000
--- a/net-p2p/nicotine+/files/nicotine+-1.2.9-locale-handling.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-diff -ur nicotine+-1.2.9.orig/pynicotine/gtkgui/frame.py nicotine+-1.2.9/pynicotine/gtkgui/frame.py
---- nicotine+-1.2.9.orig/pynicotine/gtkgui/frame.py 2007-12-04 10:33:57.000000000 +0100
-+++ nicotine+-1.2.9/pynicotine/gtkgui/frame.py 2007-12-04 10:40:31.000000000 +0100
-@@ -947,20 +947,8 @@
-
- for widget in self.BuddiesComboEntries:
- gobject.idle_add(widget.Fill)
--
-- def getTabPosition(self, string):
-- if string == "top":
-- position = gtk.POS_TOP
-- elif string == "bottom":
-- position = gtk.POS_BOTTOM
-- elif string == "left":
-- position = gtk.POS_LEFT
-- elif string == "right":
-- position = gtk.POS_RIGHT
-- else:
-- position = gtk.POS_TOP
-- return position
--
-+
-+
- def OnAutoAway(self):
- if not self.away:
- self.autoaway = True
-@@ -1675,7 +1663,20 @@
- message = message.replace(word, filler * len(word))
-
- return message
--
-+
-+ def getTabPosition(self, string):
-+ if string in ("Top", "top", _("Top")):
-+ position = gtk.POS_TOP
-+ elif string in ("Bottom", "bottom", _("Bottom")):
-+ position = gtk.POS_BOTTOM
-+ elif string in ("Left", "left", _("Left")):
-+ position = gtk.POS_LEFT
-+ elif string in ("Right", "right", _("Right")):
-+ position = gtk.POS_RIGHT
-+ else:
-+ position = gtk.POS_TOP
-+ return position
-+
- def SetTabPositions(self):
- ui = self.np.config.sections["ui"]
- self.ChatNotebook.set_tab_pos(self.getTabPosition(ui["tabrooms"]))
-diff -ur nicotine+-1.2.9.orig/pynicotine/gtkgui/settingswindow.py nicotine+-1.2.9/pynicotine/gtkgui/settingswindow.py
---- nicotine+-1.2.9.orig/pynicotine/gtkgui/settingswindow.py 2007-12-04 10:33:57.000000000 +0100
-+++ nicotine+-1.2.9/pynicotine/gtkgui/settingswindow.py 2007-12-04 10:37:06.000000000 +0100
-@@ -1206,12 +1206,12 @@
- def GetSettings(self):
- return {
- "ui": {
-- "tabmain": self.MainPosition.get_active_text().lower(),
-- "tabrooms": self.ChatRoomsPosition.get_active_text().lower(),
-- "tabprivate": self.PrivateChatPosition.get_active_text().lower(),
-- "tabinfo": self.UserInfoPosition.get_active_text().lower(),
-- "tabbrowse": self.UserBrowsePosition.get_active_text().lower(),
-- "tabsearch": self.SearchPosition.get_active_text().lower(),
-+ "tabmain": self.MainPosition.get_active_text(),
-+ "tabrooms": self.ChatRoomsPosition.get_active_text(),
-+ "tabprivate": self.PrivateChatPosition.get_active_text(),
-+ "tabinfo": self.UserInfoPosition.get_active_text(),
-+ "tabbrowse": self.UserBrowsePosition.get_active_text(),
-+ "tabsearch": self.SearchPosition.get_active_text(),
- "labelmain": self.MainAngleSpin.get_value_as_int(),
- "labelrooms": self.ChatRoomsAngleSpin.get_value_as_int(),
- "labelprivate": self.PrivateChatAngleSpin.get_value_as_int(),
diff --git a/net-p2p/nicotine+/nicotine+-1.2.10_pre705.ebuild b/net-p2p/nicotine+/nicotine+-1.2.10_pre705.ebuild
deleted file mode 100644
index 5c2008e5bbe0..000000000000
--- a/net-p2p/nicotine+/nicotine+-1.2.10_pre705.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.10_pre705.ebuild,v 1.1 2008/06/28 22:31:59 coldwind Exp $
-
-inherit distutils multilib toolchain-funcs
-
-DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
-HOMEPAGE="http://nicotine-plus.sourceforge.net"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-3 LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="geoip spell vorbis"
-
-RDEPEND="virtual/python
- >=dev-python/pygtk-2
- vorbis? ( >=dev-python/pyvorbis-1.4-r1
- >=dev-python/pyogg-1 )
- geoip? ( >=dev-python/geoip-python-0.2.0
- >=dev-libs/geoip-1.2.1 )
- spell? ( dev-python/sexy-python )
- !net-p2p/nicotine"
-
-DEPEND="${RDEPEND}"
-
-src_compile() {
- distutils_src_compile
-
- cd "${S}"/trayicon/
- sed -i -e "s:/lib/:/$(get_libdir)/:" \
- Makefile.in || die "sed failed"
- ./autogen.py
- emake CC="$(tc-getCC)" || die "emake failed"
-}
-
-src_install() {
- distutils_python_version
- distutils_src_install --install-lib \
- /usr/$(get_libdir)/python${PYVER}/site-packages
-
- cd "${S}"/trayicon/
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/net-p2p/nicotine+/nicotine+-1.2.12.ebuild b/net-p2p/nicotine+/nicotine+-1.2.12.ebuild
new file mode 100644
index 000000000000..ca16eca05adf
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-1.2.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.12.ebuild,v 1.1 2009/07/01 19:52:13 dirtyepic Exp $
+
+inherit distutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="http://nicotine-plus.sourceforge.net"
+SRC_URI="http://www.nicotine-plus.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="geoip spell"
+
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2.10
+ media-libs/mutagen
+ geoip? ( >=dev-python/geoip-python-0.2.0
+ >=dev-libs/geoip-1.2.1 )
+ spell? ( dev-python/sexy-python )
+ !net-p2p/nicotine"
+
+DEPEND="${RDEPEND}"
+
+src_install() {
+ distutils_python_version
+ distutils_src_install \
+ --install-lib /usr/$(get_libdir)/python${PYVER}/site-packages
+ dosym nicotine.py /usr/bin/nicotine
+}