summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-03-04 00:04:51 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-03-04 00:04:51 +0000
commit3fc1063fc641e4358e14021b9f710f9c2777b4d0 (patch)
treed54db9817ab35f0e605dc9e3fecd0de346261d53 /net-p2p
parentFixed -jit builds and re-added use flag to firefox-36, bug 541770 (diff)
downloadgentoo-2-3fc1063fc641e4358e14021b9f710f9c2777b4d0.tar.gz
gentoo-2-3fc1063fc641e4358e14021b9f710f9c2777b4d0.tar.bz2
gentoo-2-3fc1063fc641e4358e14021b9f710f9c2777b4d0.zip
Dependency on leveldb and libsecp256k1 is now handled by the eclass.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin-qt/ChangeLog9
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.10.0-r1.ebuild (renamed from net-p2p/bitcoin-qt/bitcoin-qt-0.10.0.ebuild)6
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-9999.ebuild6
3 files changed, 14 insertions, 7 deletions
diff --git a/net-p2p/bitcoin-qt/ChangeLog b/net-p2p/bitcoin-qt/ChangeLog
index bbddaf1a8453..7f432f0b60f7 100644
--- a/net-p2p/bitcoin-qt/ChangeLog
+++ b/net-p2p/bitcoin-qt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/bitcoin-qt
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/ChangeLog,v 1.99 2015/03/01 12:11:05 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/ChangeLog,v 1.100 2015/03/04 00:04:51 blueness Exp $
+
+*bitcoin-qt-0.10.0-r1 (04 Mar 2015)
+
+ 04 Mar 2015; Anthony G. Basile <blueness@gentoo.org>
+ +bitcoin-qt-0.10.0-r1.ebuild, -bitcoin-qt-0.10.0.ebuild,
+ bitcoin-qt-9999.ebuild:
+ Dependency on leveldb and libsecp256k1 is now handled by the eclass.
01 Mar 2015; Andreas K. Huettel <dilfridge@gentoo.org>
bitcoin-qt-0.10.0.ebuild:
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.10.0.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.10.0-r1.ebuild
index 4d8c87b8aa92..c8f4ef41669b 100644
--- a/net-p2p/bitcoin-qt/bitcoin-qt-0.10.0.ebuild
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.10.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 2010-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.10.0.ebuild,v 1.5 2015/03/01 12:11:05 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.10.0-r1.ebuild,v 1.1 2015/03/04 00:04:51 blueness Exp $
EAPI=5
@@ -9,6 +9,8 @@ BITCOINCORE_LJR_DATE="20150220"
BITCOINCORE_IUSE="1stclassmsg dbus kde ljr +qrcode qt4 qt5 test upnp +wallet xt zeromq"
BITCOINCORE_POLICY_PATCHES="cpfp dcmp rbf spamfilter"
LANGS="ach af_ZA ar be_BY bg bs ca ca@valencia ca_ES cmn cs cy da de el_GR en eo es es_CL es_DO es_MX es_UY et eu_ES fa fa_IR fi fr fr_CA gl gu_IN he hi_IN hr hu id_ID it ja ka kk_KZ ko_KR ky la lt lv_LV mn ms_MY nb nl pam pl pt_BR pt_PT ro_RO ru sah sk sl_SI sq sr sv th_TH tr uk ur_PK uz@Cyrl vi vi_VN zh_HK zh_CN zh_TW"
+BITCOINCORE_NEED_LEVELDB=1
+BITCOINCORE_NEED_LIBSECP256K1=1
inherit bitcoincore eutils fdo-mime gnome2-utils kde4-functions qt4-r2
DESCRIPTION="An end-user Qt GUI for the Bitcoin crypto-currency"
@@ -17,9 +19,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
RDEPEND="
- virtual/bitcoin-leveldb
dev-libs/protobuf
- dev-libs/libsecp256k1
qrcode? (
media-gfx/qrencode
)
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-9999.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-9999.ebuild
index bd34abe257ae..3a8a09aeb01f 100644
--- a/net-p2p/bitcoin-qt/bitcoin-qt-9999.ebuild
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-9999.ebuild
@@ -1,11 +1,13 @@
# Copyright 2010-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-9999.ebuild,v 1.5 2015/02/24 00:44:42 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-9999.ebuild,v 1.6 2015/03/04 00:04:51 blueness Exp $
EAPI=5
LANGS="ach af_ZA ar be_BY bg bs ca ca@valencia ca_ES cmn cs cy da de el_GR en eo es es_CL es_DO es_MX es_UY et eu_ES fa fa_IR fi fr fr_CA gl gu_IN he hi_IN hr hu id_ID it ja ka kk_KZ ko_KR ky la lt lv_LV mn ms_MY nb nl pam pl pt_BR pt_PT ro_RO ru sah sk sl_SI sq sr sv th_TH tr uk ur_PK uz@Cyrl vi vi_VN zh_HK zh_CN zh_TW"
BITCOINCORE_IUSE="dbus kde +qrcode test upnp +wallet"
+BITCOINCORE_NEED_LEVELDB=1
+BITCOINCORE_NEED_LIBSECP256K1=1
inherit bitcoincore eutils fdo-mime gnome2-utils kde4-functions qt4-r2 git-2
DESCRIPTION="An end-user Qt GUI for the Bitcoin crypto-currency"
@@ -14,9 +16,7 @@ SLOT="0"
KEYWORDS=""
RDEPEND="
- virtual/bitcoin-leveldb
dev-libs/protobuf
- dev-libs/libsecp256k1
qrcode? (
media-gfx/qrencode
)