summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2007-03-29 18:04:31 +0000
committerWilliam Thomson <wltjr@gentoo.org>2007-03-29 18:04:31 +0000
commit3dac4c4b917262ea9a41c6aa620afa3409772b97 (patch)
tree9a0de1101c7614ce8759db672f732bec4b35a54c /net-p2p
parentsync up keywords that were dropped accidentally; stable for x86; clean out ol... (diff)
downloadgentoo-2-3dac4c4b917262ea9a41c6aa620afa3409772b97.tar.gz
gentoo-2-3dac4c4b917262ea9a41c6aa620afa3409772b97.tar.bz2
gentoo-2-3dac4c4b917262ea9a41c6aa620afa3409772b97.zip
Added patch for changes in bcprov due to revision bump per bug #172657
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/azureus/ChangeLog9
-rw-r--r--net-p2p/azureus/azureus-2.5.0.4-r1.ebuild133
-rw-r--r--net-p2p/azureus/files/digest-azureus-2.5.0.4-r13
-rw-r--r--net-p2p/azureus/files/fedora-2.5.0.4/azureus-bcprov-1.35.patch20
4 files changed, 164 insertions, 1 deletions
diff --git a/net-p2p/azureus/ChangeLog b/net-p2p/azureus/ChangeLog
index 00d3e5219c35..0209ceccda2f 100644
--- a/net-p2p/azureus/ChangeLog
+++ b/net-p2p/azureus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/azureus
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.43 2007/03/15 17:18:25 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.44 2007/03/29 18:04:31 wltjr Exp $
+
+*azureus-2.5.0.4-r1 (29 Mar 2007)
+
+ 29 Mar 2007; William L. Thomson Jr. <wltjr@gentoo.org>
+ +files/fedora-2.5.0.4/azureus-bcprov-1.35.patch,
+ +azureus-2.5.0.4-r1.ebuild:
+ Added patch for changes in bcprov due to revision bump per bug #172657
15 Mar 2007; Simon Stelling <blubb@gentoo.org> azureus-2.5.0.4.ebuild:
stable on amd64; bug 170955
diff --git a/net-p2p/azureus/azureus-2.5.0.4-r1.ebuild b/net-p2p/azureus/azureus-2.5.0.4-r1.ebuild
new file mode 100644
index 000000000000..af7c9b7e0dab
--- /dev/null
+++ b/net-p2p/azureus/azureus-2.5.0.4-r1.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/azureus-2.5.0.4-r1.ebuild,v 1.1 2007/03/29 18:04:31 wltjr Exp $
+
+inherit eutils fdo-mime java-pkg-2 java-ant-2
+
+DESCRIPTION="Azureus - Java BitTorrent Client"
+HOMEPAGE="http://azureus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/azureus/azureus_${PV}_source.zip"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+IUSE="source"
+
+# >=swt-3.2 for bug
+# https://bugs.gentoo.org/show_bug.cgi?id=135835
+
+RDEPEND="
+ >=virtual/jre-1.5
+ >=dev-java/swt-3.2-r1
+ >=dev-java/log4j-1.2.8
+ >=dev-java/commons-cli-1.0
+ >=dev-java/bcprov-1.35
+ !net-p2p/azureus-bin"
+DEPEND="${RDEPEND}
+ >=virtual/jdk-1.5
+ dev-util/desktop-file-utils
+ >=dev-java/ant-core-1.6.2
+ || ( =dev-java/eclipse-ecj-3.2* =dev-java/eclipse-ecj-3.1* )
+ source? ( app-arch/zip )
+ >=app-arch/unzip-5.0"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+
+ # patches from 2.5.0.0 still work here
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" \
+ epatch ${FILESDIR}/fedora-${PV}/
+
+ #removing osx files and entries
+ rm -fr org/gudy/azureus2/ui/swt/osx org/gudy/azureus2/platform/macosx
+ #removing windows files
+ rm -fr org/gudy/azureus2/ui/swt/win32 org/gudy/azureus2/platform/win32
+ #removing test files
+ rm -fr org/gudy/azureus2/ui/swt/test
+ rm -f org/gudy/azureus2/ui/console/multiuser/TestUserManager.java
+ #removing bouncycastle
+ rm -fr org/bouncycastle
+
+ mkdir -p build/libs
+ cd build/libs
+ java-pkg_jar-from log4j
+ java-pkg_jar-from commons-cli-1
+ java-pkg_jar-from swt-3
+ java-pkg_jar-from bcprov
+}
+
+src_compile() {
+ # javac likes to run out of memory during build... use ecj instead
+ java-pkg_force-compiler ecj-3.2 ecj-3.1
+
+ eant ${ant_extra_opts} jar
+}
+
+src_install() {
+ java-pkg_dojar dist/Azureus2.jar || die "dojar failed"
+
+
+ java-pkg_dolauncher ${PN} \
+ --main org.gudy.azureus2.ui.common.Main \
+ -pre ${FILESDIR}/${PN}-2.5.0.0-pre \
+ --pkg_args '--ui=${UI}' \
+ --java_args '-Dazureus.install.path=${HOME}/.azureus/ ${JAVA_OPTIONS}'
+
+ doicon "${FILESDIR}/azureus.png"
+ domenu "${FILESDIR}/azureus.desktop"
+ use source && java-pkg_dosrc ${S}/{com,org}
+}
+
+pkg_postinst() {
+ echo
+ elog "Due to the nature of the portage system, we recommend"
+ elog "that users check portage for new versions of Azureus"
+ elog "instead of attempting to use the auto-update feature."
+ elog "We also set azureus.install.path to ~/.azureus so auto"
+ elog "update probably does not even work."
+ elog ""
+ elog "You can disable auto-update in"
+ elog "Tools->Options...->Interface->Start"
+ echo
+ elog "After running azureus for the first time, configuration"
+ elog "options will be placed in ~/.azureus/gentoo.config"
+ elog "It is recommended that you modify this file rather than"
+ elog "the azureus startup script directly."
+ echo
+ elog "As of this version, the new ui type 'console' is supported,"
+ elog "and this may be set in ~/.azureus/gentoo.config."
+ echo
+ elog "If you have problems starting azureus, try starting it"
+ elog "from the command line to look at debugging output."
+ echo
+ ewarn "If you are upgrading, and the menu in azureus has entries like"
+ ewarn "\"!MainWindow.menu.transfers!\" then you have a stray"
+ ewarn "MessageBundle.properties file,"
+ ewarn "and you may safely delete ~/.azureus/MessagesBundle.properties"
+ echo
+ elog "It's recommended to use Sun's Java version 1.5 or later."
+ elog "If you're experiencing problems running azureus and you've"
+ elog "using an older version of Java, try to upgrading to a new version. "
+ echo
+ elog "New in 2.5.0.0-r3:"
+ ewarn 'azureus.install.path was changed to ${HOME}/.azureus/. Before'
+ ewarn 'the Azureus plugin dir was created to the current working directory.'
+ ewarn 'This means that you probably have a useless plugins directory in'
+ ewarn 'your home directory.'
+ ewarn 'See http://bugs.gentoo.org/show_bug.cgi?id=145908'
+ ewarn 'for more information. Also you probably need to move the user'
+ ewarn 'installed plugins to the new plugin directory.'
+ echo
+ ewarn "Please, do not run azureus as root!"
+ ewarn "Azureus has not been developed for multi-user environments!"
+
+ fdo-mime_desktop_database_update
+}
+
+pkg_prerm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/net-p2p/azureus/files/digest-azureus-2.5.0.4-r1 b/net-p2p/azureus/files/digest-azureus-2.5.0.4-r1
new file mode 100644
index 000000000000..880298a6f162
--- /dev/null
+++ b/net-p2p/azureus/files/digest-azureus-2.5.0.4-r1
@@ -0,0 +1,3 @@
+MD5 032c42578b455599a00714781438afa7 azureus_2.5.0.4_source.zip 6482560
+RMD160 c4f245abf19a963e077b354fccd6a04547c741b1 azureus_2.5.0.4_source.zip 6482560
+SHA256 9ae32cbf88baf04b0e17456e92bc2634dd54e890dbece7211a83318b96d1b081 azureus_2.5.0.4_source.zip 6482560
diff --git a/net-p2p/azureus/files/fedora-2.5.0.4/azureus-bcprov-1.35.patch b/net-p2p/azureus/files/fedora-2.5.0.4/azureus-bcprov-1.35.patch
new file mode 100644
index 000000000000..4e96230baf1d
--- /dev/null
+++ b/net-p2p/azureus/files/fedora-2.5.0.4/azureus-bcprov-1.35.patch
@@ -0,0 +1,20 @@
+--- azureus/com/aelitis/azureus/core/clientmessageservice/secure/impl/SecureMessageServiceClientHelper.java.orig 2007-01-20 18:23:49.000000000 +0100
++++ azureus/com/aelitis/azureus/core/clientmessageservice/secure/impl/SecureMessageServiceClientHelper.java 2007-01-20 18:25:29.000000000 +0100
+@@ -36,7 +36,7 @@
+ import org.bouncycastle.crypto.encodings.PKCS1Encoding;
+ import org.bouncycastle.crypto.engines.RSAEngine;
+ import org.bouncycastle.crypto.params.ParametersWithRandom;
+-import org.bouncycastle.jce.provider.RSAUtil;
++import org.bouncycastle.jce.provider.DSAUtil;
+ import org.gudy.azureus2.core3.util.Debug;
+ import org.gudy.azureus2.plugins.utils.StaticUtilities;
+
+@@ -97,7 +97,7 @@
+
+ PKCS1Encoding padded_eng = new PKCS1Encoding( eng );
+
+- CipherParameters param = RSAUtil.generatePublicKeyParameter(public_key);
++ CipherParameters param = DSAUtil.generatePublicKeyParameter(public_key);
+
+ param = new ParametersWithRandom(param, new SecureRandom());
+