summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-05-26 21:24:06 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-05-26 21:24:06 +0000
commit38f89886e5c7f1b8cbf6489ba1d236f4432b368e (patch)
tree0afd55a98f424c68b8f00fc19ba75ace53af943f /net-p2p
parentFix dependencies to allow sys-power/upower-pm-utils. (diff)
downloadgentoo-2-38f89886e5c7f1b8cbf6489ba1d236f4432b368e.tar.gz
gentoo-2-38f89886e5c7f1b8cbf6489ba1d236f4432b368e.tar.bz2
gentoo-2-38f89886e5c7f1b8cbf6489ba1d236f4432b368e.zip
Version bump, bug #509428
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/multibit/ChangeLog7
-rw-r--r--net-p2p/multibit/multibit-0.5.18.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/net-p2p/multibit/ChangeLog b/net-p2p/multibit/ChangeLog
index 73081afba20a..8a2c4e43d58d 100644
--- a/net-p2p/multibit/ChangeLog
+++ b/net-p2p/multibit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/multibit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/multibit/ChangeLog,v 1.3 2014/04/14 11:13:27 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/multibit/ChangeLog,v 1.4 2014/05/26 21:24:06 blueness Exp $
+
+*multibit-0.5.18 (26 May 2014)
+
+ 26 May 2014; Anthony G. Basile <blueness@gentoo.org> +multibit-0.5.18.ebuild:
+ Version bump, bug #509428
*multibit-0.5.17 (14 Apr 2014)
diff --git a/net-p2p/multibit/multibit-0.5.18.ebuild b/net-p2p/multibit/multibit-0.5.18.ebuild
new file mode 100644
index 000000000000..792474f9c66c
--- /dev/null
+++ b/net-p2p/multibit/multibit-0.5.18.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/multibit/multibit-0.5.18.ebuild,v 1.1 2014/05/26 21:24:06 blueness Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="MultiBit is a secure, lightweight, international Bitcoin wallet written in Java"
+HOMEPAGE="https://multibit.org/"
+SRC_URI="https://multibit.org/releases/${P}/${P}-linux.jar"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=virtual/jre-1.6"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+:
+}
+
+src_prepare() {
+ cp "${FILESDIR}"/auto-install.xml "${WORKDIR}"
+ sed -i "s:ED:${ED}:" auto-install.xml
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe "${FILESDIR}"/${PN}
+
+ make_desktop_entry "${PN}" "Multibit" "/opt/MultiBit/multibit48.png" "GNOME;Network;P2P;Office;Finance;" "MimeType=x-scheme-handler/multibit;\nTerminal=false"
+
+ java -jar "${DISTDIR}"/${P}-linux.jar auto-install.xml >/dev/null 2>&1
+}