summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-16 12:26:48 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-16 12:26:48 +0000
commit1b8b0b78580510b158b9e52624f54318317e2529 (patch)
treec3c654d29894891ff3ce984048a1ee8d6e54294d /net-p2p
parentRevision bump adds upstream patch to fix crashes in kmail caused by nepomuk c... (diff)
downloadgentoo-2-1b8b0b78580510b158b9e52624f54318317e2529.tar.gz
gentoo-2-1b8b0b78580510b158b9e52624f54318317e2529.tar.bz2
gentoo-2-1b8b0b78580510b158b9e52624f54318317e2529.zip
Don't call g++ directly, fixes bug #408481
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoind/ChangeLog5
-rw-r--r--net-p2p/bitcoind/bitcoind-0.5.3.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index b3be71ed60f7..73e2bec76437 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-p2p/bitcoind
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.13 2012/03/16 09:45:29 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.14 2012/03/16 12:26:48 blueness Exp $
+
+ 16 Mar 2012; Anthony G. Basile <blueness@gentoo.org> bitcoind-0.5.3.ebuild:
+ Don't call g++ directly, fixes bug #408481
16 Mar 2012; Agostino Sarubbo <ago@gentoo.org> bitcoind-0.5.3.ebuild:
Stable for amd64, wrt bug #407793
diff --git a/net-p2p/bitcoind/bitcoind-0.5.3.ebuild b/net-p2p/bitcoind/bitcoind-0.5.3.ebuild
index 5926d82c4a40..6448e5a98560 100644
--- a/net-p2p/bitcoind/bitcoind-0.5.3.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.5.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.5.3.ebuild,v 1.2 2012/03/16 09:45:29 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.5.3.ebuild,v 1.3 2012/03/16 12:26:48 blueness Exp $
-EAPI=4
+EAPI="4"
DB_VER="4.8"
-inherit db-use eutils versionator
+inherit db-use eutils versionator toolchain-funcs
DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
HOMEPAGE="http://bitcoin.org/"
@@ -69,7 +69,7 @@ src_compile() {
fi
cd src || die
- emake -f makefile.unix "${OPTS[@]}" ${PN}
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
}
src_install() {