summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-29 12:24:25 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-29 12:24:25 +0000
commit464b720a6ed7656fa4484fc54b5d8ebf8965506f (patch)
tree684879e55a12bace078416fd40b78b793114f8d7 /net-p2p/mktorrent
parentclean up (diff)
downloadgentoo-2-464b720a6ed7656fa4484fc54b5d8ebf8965506f.tar.gz
gentoo-2-464b720a6ed7656fa4484fc54b5d8ebf8965506f.tar.bz2
gentoo-2-464b720a6ed7656fa4484fc54b5d8ebf8965506f.zip
Link to libcrypto instead of libssl for required symbols. Keyword ~amd64 wrt #207845.
(Portage version: 2.1.4)
Diffstat (limited to 'net-p2p/mktorrent')
-rw-r--r--net-p2p/mktorrent/ChangeLog6
-rw-r--r--net-p2p/mktorrent/mktorrent-0.4.ebuild18
2 files changed, 16 insertions, 8 deletions
diff --git a/net-p2p/mktorrent/ChangeLog b/net-p2p/mktorrent/ChangeLog
index 95197d2e8995..e76f4aae5d83 100644
--- a/net-p2p/mktorrent/ChangeLog
+++ b/net-p2p/mktorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/mktorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/ChangeLog,v 1.4 2008/01/28 10:55:42 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/ChangeLog,v 1.5 2008/01/29 12:24:25 drac Exp $
+
+ 29 Jan 2008; Samuli Suominen <drac@gentoo.org> mktorrent-0.4.ebuild:
+ Link to libcrypto instead of libssl for required symbols. Keyword ~amd64 wrt
+ #207845.
28 Jan 2008; Dawid Węgliński <cla@gentoo.org> mktorrent-0.4.ebuild:
Stable on x86 (bug #207845)
diff --git a/net-p2p/mktorrent/mktorrent-0.4.ebuild b/net-p2p/mktorrent/mktorrent-0.4.ebuild
index e202777269b2..190b6637ae10 100644
--- a/net-p2p/mktorrent/mktorrent-0.4.ebuild
+++ b/net-p2p/mktorrent/mktorrent-0.4.ebuild
@@ -1,27 +1,31 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/mktorrent-0.4.ebuild,v 1.2 2008/01/28 10:55:42 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/mktorrent-0.4.ebuild,v 1.3 2008/01/29 12:24:25 drac Exp $
inherit toolchain-funcs
DESCRIPTION="Simple command line utility to create BitTorrent metainfo files"
-HOMEPAGE="http://mktorrent.sourceforge.net/"
-SRC_URI="mirror://sourceforge/mktorrent/mktorrent-${PV}.tar.gz"
+HOMEPAGE="http://mktorrent.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="~amd64 x86"
IUSE=""
RDEPEND="dev-libs/openssl"
src_unpack() {
unpack ${A}
- sed -i -e 's/^#DONT_STRIP/DONT_STRIP/' \
- -e "s/CC\t?= cc/CC = $(tc-getCC)/g" "${S}"/Makefile
+ sed -i -e 's:-lssl:-lcrypto:' "${S}"/Makefile
+}
+
+src_compile() {
+ tc-export CC
+ emake DONT_STRIP=1 || die "emake failed."
}
src_install() {
- dobin mktorrent || die "dobin failed"
+ dobin ${PN}
dodoc README
}