summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-05-31 21:05:41 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-05-31 21:05:41 +0000
commitbfe3b9a739173dcc6d64e6d9b815b33a5df600fe (patch)
tree709fffda2c28994425ad9965ff59225277144fa0 /net-p2p/leechcraft-eiskaltdcpp
parentBump LeechCraft to 0.5.70 "Hessian Blade" (diff)
downloadgentoo-2-bfe3b9a739173dcc6d64e6d9b815b33a5df600fe.tar.gz
gentoo-2-bfe3b9a739173dcc6d64e6d9b815b33a5df600fe.tar.bz2
gentoo-2-bfe3b9a739173dcc6d64e6d9b815b33a5df600fe.zip
Bump LeechCraft to 0.5.70 "Hessian Blade"
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/leechcraft-eiskaltdcpp')
-rw-r--r--net-p2p/leechcraft-eiskaltdcpp/ChangeLog8
-rw-r--r--net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.5.70.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/net-p2p/leechcraft-eiskaltdcpp/ChangeLog b/net-p2p/leechcraft-eiskaltdcpp/ChangeLog
index 07b90f71b48d..b4ef0f30bbe2 100644
--- a/net-p2p/leechcraft-eiskaltdcpp/ChangeLog
+++ b/net-p2p/leechcraft-eiskaltdcpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/leechcraft-eiskaltdcpp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-eiskaltdcpp/ChangeLog,v 1.10 2012/05/04 06:33:34 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-eiskaltdcpp/ChangeLog,v 1.11 2012/05/31 21:05:41 maksbotan Exp $
+
+*leechcraft-eiskaltdcpp-0.5.70 (31 May 2012)
+
+ 31 May 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +leechcraft-eiskaltdcpp-0.5.70.ebuild:
+ Bump LeechCraft to 0.5.70 "Hessian Blade"
04 May 2012; Jeff Horelick <jdhore@gentoo.org>
leechcraft-eiskaltdcpp-0.4.99.ebuild, leechcraft-eiskaltdcpp-0.5.0.ebuild,
diff --git a/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.5.70.ebuild b/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.5.70.ebuild
new file mode 100644
index 000000000000..8253d24ebe60
--- /dev/null
+++ b/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.5.70.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.5.70.ebuild,v 1.1 2012/05/31 21:05:41 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="EiskaltDC++ ported to LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +emoticons examples javascript lua pcre spell sqlite upnp"
+
+RDEPEND="~net-misc/leechcraft-core-${PV}
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/openssl-0.9.8
+ virtual/libiconv
+ sys-devel/gettext
+ lua? ( >=dev-lang/lua-5.1 )
+ upnp? ( net-libs/miniupnpc )
+ javascript? (
+ x11-libs/qt-script
+ x11-libs/qtscriptgenerator
+ )
+ spell? ( app-text/aspell )
+ sqlite? ( x11-libs/qt-sql:4[sqlite] )
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ virtual/leechcraft-task-show
+ !!net-p2p/eiskaltdcpp"
+DEPEND="~net-misc/leechcraft-core-${PV}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use lua LUA_SCRIPT)"
+ "$(cmake-utils_use lua WITH_LUASCRIPTS)"
+ "$(cmake-utils_use javascript USE_JS)"
+ "$(cmake-utils_use spell USE_ASPELL)"
+ "$(cmake-utils_use sqlite USE_QT_SQLITE)"
+ "$(cmake-utils_use upnp USE_MINIUPNP)"
+ -DLOCAL_MINIUPNP="0"
+ "$(cmake-utils_use emoticons WITH_EMOTICONS)"
+ "$(cmake-utils_use examples WITH_EXAMPLES)"
+ "$(cmake-utils_use pcre PERL_REGEX)"
+ )
+
+ cmake-utils_src_configure
+}