summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-12-21 20:27:51 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-12-21 20:27:51 +0000
commitdaa240927481828e94ae25c15d9e7ba7a1385ce1 (patch)
treef0c7bc7cd36dd469c2ef7e2182e5e4108e2d4b33 /net-p2p/deluge
parentVersion bump, drop old (diff)
downloadgentoo-2-daa240927481828e94ae25c15d9e7ba7a1385ce1.tar.gz
gentoo-2-daa240927481828e94ae25c15d9e7ba7a1385ce1.tar.bz2
gentoo-2-daa240927481828e94ae25c15d9e7ba7a1385ce1.zip
Prevent deluge from downloading rb_libtorrent from svn if the system one is broken. Thanks to Arfrever
(Portage version: 2.1.11.37/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'net-p2p/deluge')
-rw-r--r--net-p2p/deluge/ChangeLog8
-rw-r--r--net-p2p/deluge/deluge-1.3.5-r2.ebuild4
-rw-r--r--net-p2p/deluge/deluge-9999.ebuild3
-rw-r--r--net-p2p/deluge/files/deluge-1.3.5-disable_libtorrent_internal_copy.patch42
4 files changed, 54 insertions, 3 deletions
diff --git a/net-p2p/deluge/ChangeLog b/net-p2p/deluge/ChangeLog
index fb63d02afdfb..093e0319c5c7 100644
--- a/net-p2p/deluge/ChangeLog
+++ b/net-p2p/deluge/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/deluge
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.180 2012/12/20 22:23:05 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.181 2012/12/21 20:27:51 hwoarang Exp $
+
+ 21 Dec 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/deluge-1.3.5-disable_libtorrent_internal_copy.patch,
+ deluge-1.3.5-r2.ebuild, deluge-9999.ebuild:
+ Prevent deluge from downloading rb_libtorrent from svn if the system one is
+ broken. Thanks to Arfrever
*deluge-1.3.5-r2 (20 Dec 2012)
diff --git a/net-p2p/deluge/deluge-1.3.5-r2.ebuild b/net-p2p/deluge/deluge-1.3.5-r2.ebuild
index d12c4f487204..1ece04fc9127 100644
--- a/net-p2p/deluge/deluge-1.3.5-r2.ebuild
+++ b/net-p2p/deluge/deluge-1.3.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.3.5-r2.ebuild,v 1.1 2012/12/20 22:23:05 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.3.5-r2.ebuild,v 1.2 2012/12/21 20:27:51 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
@@ -47,6 +47,8 @@ src_prepare() {
distutils_src_prepare
python_convert_shebangs -r 2 .
epatch "${FILESDIR}/${P}-rb_libtorrent-disable-python-bindings"
+ epatch "${FILESDIR}/${P}-disable_libtorrent_internal_copy.patch"
+
}
src_install() {
diff --git a/net-p2p/deluge/deluge-9999.ebuild b/net-p2p/deluge/deluge-9999.ebuild
index 61b6c6555655..19ff341fed59 100644
--- a/net-p2p/deluge/deluge-9999.ebuild
+++ b/net-p2p/deluge/deluge-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-9999.ebuild,v 1.31 2012/12/20 22:23:05 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-9999.ebuild,v 1.32 2012/12/21 20:27:51 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
@@ -48,6 +48,7 @@ pkg_setup() {
src_prepare() {
distutils_src_prepare
python_convert_shebangs -r 2 .
+ epatch "${FILESDIR}/${PN}-1.3.5-disable_libtorrent_internal_copy.patch"
}
src_install() {
diff --git a/net-p2p/deluge/files/deluge-1.3.5-disable_libtorrent_internal_copy.patch b/net-p2p/deluge/files/deluge-1.3.5-disable_libtorrent_internal_copy.patch
new file mode 100644
index 000000000000..235b7f7c2438
--- /dev/null
+++ b/net-p2p/deluge/files/deluge-1.3.5-disable_libtorrent_internal_copy.patch
@@ -0,0 +1,42 @@
+--- setup.py
++++ setup.py
+@@ -205,38 +205,7 @@
+
+ _ext_modules = []
+
+-# Check for a system libtorrent and if found, then do not build the libtorrent extension
+-build_libtorrent = True
+-try:
+- from deluge._libtorrent import lt
+-except ImportError:
+- build_libtorrent = True
+-else:
+- build_libtorrent = False
+-
+-if build_libtorrent:
+- got_libtorrent = False
+- if not os.path.exists("libtorrent"):
+- import subprocess
+- if subprocess.call(['./get_libtorrent.sh']) > 0:
+- got_libtorrent = False
+- else:
+- got_libtorrent = True
+- else:
+- got_libtorrent = True
+-
+- if got_libtorrent:
+- # There isn't a system libtorrent library, so let's build the one included with deluge
+- libtorrent = Extension(
+- 'libtorrent',
+- extra_compile_args = _extra_compile_args,
+- include_dirs = _include_dirs,
+- libraries = _libraries,
+- library_dirs = _library_dirs,
+- sources = _sources
+- )
+-
+- _ext_modules = [libtorrent]
++import deluge._libtorrent
+
+ desktop_data = 'deluge/data/share/applications/deluge.desktop'
+