summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-01-22 20:04:29 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-01-22 20:04:29 +0000
commitba7192239a444b753c0e03ef0e3cd69356a1d948 (patch)
treebbaf04bddf540997405259878cf01c3a4133e5a7 /net-p2p/dctc/dctc-0.85.9.ebuild
parentbump duali for bug 67252 and bug 110441 (diff)
downloadgentoo-2-ba7192239a444b753c0e03ef0e3cd69356a1d948.tar.gz
gentoo-2-ba7192239a444b753c0e03ef0e3cd69356a1d948.tar.bz2
gentoo-2-ba7192239a444b753c0e03ef0e3cd69356a1d948.zip
Fix again db-4.2 issue, bug 135320
(Portage version: 2.1.2-r2)
Diffstat (limited to 'net-p2p/dctc/dctc-0.85.9.ebuild')
-rw-r--r--net-p2p/dctc/dctc-0.85.9.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/net-p2p/dctc/dctc-0.85.9.ebuild b/net-p2p/dctc/dctc-0.85.9.ebuild
index 85e70191e992..5ea7cad7c024 100644
--- a/net-p2p/dctc/dctc-0.85.9.ebuild
+++ b/net-p2p/dctc/dctc-0.85.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dctc/dctc-0.85.9.ebuild,v 1.16 2007/01/11 19:50:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dctc/dctc-0.85.9.ebuild,v 1.17 2007/01/22 20:04:29 armin76 Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -32,16 +32,17 @@ src_unpack() {
eautoreconf
-
- # fix for #26708 (db4 support)
- local dbfunc="`grep '^#define.*db_env_create' /usr/include/db.h | awk '{print $NF}'`"
- if [ "${dbfunc}" != "db_env_create" ] ; then
- sed -i "s:db_env_create:${dbfunc}:g" configure
+ # This fix fails with db-4.3
+ if has_version "=sys-libs/db-4.2*" && ! has_version ">=sys-libs/db-4.3*"; then
+ local dbfunc="`grep '^#define.*db_env_create' /usr/include/db.h | awk '{print $NF}'`"
+ if [ "${dbfunc}" != "db_env_create" ] ; then
+ sed -i "s:db_env_create:${dbfunc}:g" configure
+ fi
fi
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc Documentation/Documentation/* Documentation/Documentation/DCextensions/*
- dodoc AUTHORS COPYING ChangeLog INSTALL KNOWN_BUGS NEWS README TODO
+ dodoc AUTHORS ChangeLog KNOWN_BUGS NEWS README TODO
}