summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-02-25 14:41:11 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-02-25 14:41:11 +0000
commit36fa8d4a9d63f6c2a18656464d97b2bb5b741ea6 (patch)
tree54786eb8182e6bfd4a62d65b411c615c4610f56a /net-p2p/dbhub
parentStable x86, amd64. (diff)
downloadgentoo-2-36fa8d4a9d63f6c2a18656464d97b2bb5b741ea6.tar.gz
gentoo-2-36fa8d4a9d63f6c2a18656464d97b2bb5b741ea6.tar.bz2
gentoo-2-36fa8d4a9d63f6c2a18656464d97b2bb5b741ea6.zip
Version bump, add switch_user USE-flag
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-p2p/dbhub')
-rw-r--r--net-p2p/dbhub/ChangeLog10
-rw-r--r--net-p2p/dbhub/dbhub-0.450.ebuild35
-rw-r--r--net-p2p/dbhub/dbhub-0.451.ebuild38
-rw-r--r--net-p2p/dbhub/files/dbhub-gentoo.patch28
4 files changed, 52 insertions, 59 deletions
diff --git a/net-p2p/dbhub/ChangeLog b/net-p2p/dbhub/ChangeLog
index bcdbe15f47b8..7a3231d4a314 100644
--- a/net-p2p/dbhub/ChangeLog
+++ b/net-p2p/dbhub/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/dbhub
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dbhub/ChangeLog,v 1.26 2007/10/25 12:58:40 armin76 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dbhub/ChangeLog,v 1.27 2008/02/25 14:41:10 armin76 Exp $
+
+*dbhub-0.451 (25 Feb 2008)
+
+ 25 Feb 2008; Raúl Porcel <armin76@gentoo.org> files/dbhub-gentoo.patch,
+ -dbhub-0.450.ebuild, +dbhub-0.451.ebuild:
+ Version bump, add switch_user USE-flag
*dbhub-0.450 (25 Oct 2007)
diff --git a/net-p2p/dbhub/dbhub-0.450.ebuild b/net-p2p/dbhub/dbhub-0.450.ebuild
deleted file mode 100644
index 5b192237306b..000000000000
--- a/net-p2p/dbhub/dbhub-0.450.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dbhub/dbhub-0.450.ebuild,v 1.1 2007/10/25 12:58:40 armin76 Exp $
-
-inherit eutils
-
-DESCRIPTION="Hub software for Direct Connect, fork of opendchub"
-HOMEPAGE="http://dbhub.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="perl nls"
-
-DEPEND="perl? ( dev-lang/perl )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch ${FILESDIR}/dbhub-gentoo.patch
-}
-
-src_compile() {
- econf \
- $(use_enable nls lang) \
- $(use_enable perl) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/net-p2p/dbhub/dbhub-0.451.ebuild b/net-p2p/dbhub/dbhub-0.451.ebuild
new file mode 100644
index 000000000000..623cb1dae555
--- /dev/null
+++ b/net-p2p/dbhub/dbhub-0.451.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dbhub/dbhub-0.451.ebuild,v 1.1 2008/02/25 14:41:10 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="Hub software for Direct Connect, fork of opendchub"
+HOMEPAGE="http://www.dbhub.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="debug perl nls switch_user"
+
+DEPEND="perl? ( dev-lang/perl )
+ switch_user? ( sys-libs/libcap )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-gentoo.patch
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable perl) \
+ $(use_enable switch_user) \
+ $(use_enable debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/net-p2p/dbhub/files/dbhub-gentoo.patch b/net-p2p/dbhub/files/dbhub-gentoo.patch
index 1cb37fa9df74..3ac532ffef6b 100644
--- a/net-p2p/dbhub/files/dbhub-gentoo.patch
+++ b/net-p2p/dbhub/files/dbhub-gentoo.patch
@@ -1,31 +1,15 @@
---- configure.old 2007-10-25 14:53:10.000000000 +0200
-+++ configure 2007-10-25 14:54:06.000000000 +0200
-@@ -7564,12 +7564,6 @@
- fi
+--- configure.orig 2008-02-25 15:28:29.000000000 +0100
++++ configure 2008-02-25 15:28:52.000000000 +0100
+@@ -4926,12 +4926,6 @@
fi
+
-if test ! -d $HOME/.dbhub; then
- echo "creating config directory: $HOME/.dbhub"
- mkdir $HOME/.dbhub
- chmod 700 $HOME/.dbhub;
-fi
-
- # Check whether --enable-lang was given.
- if test "${enable_lang+set}" = set; then
- enableval=$enable_lang; if test "$enableval" = "no"; then
-@@ -7650,15 +7644,6 @@
- perl_flags=`perl -MExtUtils::Embed -e ccopts`
+ ac_config_files="$ac_config_files Makefile src/Makefile"
- perl_libs=`perl -MExtUtils::Embed -e ldopts`
--
-- if test ! -d $HOME/.dbhub/scripts; then
-- echo "creating script directory: $HOME/.dbhub/scripts"
-- mkdir $HOME/.dbhub/scripts
-- chmod 700 $HOME/.dbhub/scripts;
-- for i in Samplescripts/*; do
-- cp $i $HOME/.dbhub/scripts;
-- done
-- fi
- fi
- else
- echo "Perl script support is disabled."
+ cat >confcache <<\_ACEOF