summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2011-05-08 18:24:23 +0000
committerRaúl Porcel <armin76@gentoo.org>2011-05-08 18:24:23 +0000
commitca17fe9c3cd86a1ccffd24dc9addb28e944cf53d (patch)
tree5bc348faa58653953519d897b69d06540ff84fb5 /net-p2p/amule
parentAdd ~arm (diff)
downloadgentoo-2-ca17fe9c3cd86a1ccffd24dc9addb28e944cf53d.tar.gz
gentoo-2-ca17fe9c3cd86a1ccffd24dc9addb28e944cf53d.tar.bz2
gentoo-2-ca17fe9c3cd86a1ccffd24dc9addb28e944cf53d.zip
Add patch to fix compilation failure on gcc-4.5, bug #328769
(Portage version: 2.1.9.47/cvs/Linux ia64)
Diffstat (limited to 'net-p2p/amule')
-rw-r--r--net-p2p/amule/ChangeLog6
-rw-r--r--net-p2p/amule/amule-2.2.6.ebuild3
-rw-r--r--net-p2p/amule/files/amule-2.2.6-gcc45.patch22
3 files changed, 29 insertions, 2 deletions
diff --git a/net-p2p/amule/ChangeLog b/net-p2p/amule/ChangeLog
index d85febcfe872..faf6b0ad7237 100644
--- a/net-p2p/amule/ChangeLog
+++ b/net-p2p/amule/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/amule
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.156 2011/01/10 14:24:03 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.157 2011/05/08 18:24:23 armin76 Exp $
+
+ 08 May 2011; Raúl Porcel <armin76@gentoo.org> amule-2.2.6.ebuild,
+ +files/amule-2.2.6-gcc45.patch:
+ Add patch to fix compilation failure on gcc-4.5, bug #328769
10 Jan 2011; Patrick Lauer <patrick@gentoo.org> amule-2.2.6.ebuild:
Relaxing crypto++ dep as the issues have been fixed
diff --git a/net-p2p/amule/amule-2.2.6.ebuild b/net-p2p/amule/amule-2.2.6.ebuild
index f24ef55cdf9b..62e6e1cd2792 100644
--- a/net-p2p/amule/amule-2.2.6.ebuild
+++ b/net-p2p/amule/amule-2.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.6.ebuild,v 1.12 2011/02/27 13:53:27 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.6.ebuild,v 1.13 2011/05/08 18:24:23 armin76 Exp $
EAPI="2"
@@ -52,6 +52,7 @@ pkg_preinst() {
src_prepare() {
epatch "${FILESDIR}"/${P}-fallocate.diff
+ epatch "${FILESDIR}"/${P}-gcc45.patch
}
src_configure() {
diff --git a/net-p2p/amule/files/amule-2.2.6-gcc45.patch b/net-p2p/amule/files/amule-2.2.6-gcc45.patch
new file mode 100644
index 000000000000..e120ef23b76f
--- /dev/null
+++ b/net-p2p/amule/files/amule-2.2.6-gcc45.patch
@@ -0,0 +1,22 @@
+# Subject: Fix FTBFS on gcc 4.5 (new in ubuntu natty)
+# Origin: other, http://bugs.amule.org/view.php?id=1624
+# Bug-ubuntu: https://bugs.launchpad.net/ubuntu/+source/amule/+bug/685584
+# Forwarded: upstream claims it's in their current svn code
+Index: amule-2.2.6+debian0/src/utils/wxCas/src/wxcasframe.cpp
+===================================================================
+--- amule-2.2.6+debian0.orig/src/utils/wxCas/src/wxcasframe.cpp 2010-12-15 16:46:18.435693002 +0000
++++ amule-2.2.6+debian0/src/utils/wxCas/src/wxcasframe.cpp 2010-12-15 16:47:07.151693001 +0000
+@@ -285,11 +285,11 @@
+ #ifdef __WXMSW__
+
+ memdc.
+- SetFont ( wxFont::wxFont ( 6, wxSWISS, wxNORMAL, wxBOLD ) );
++ SetFont ( wxFont ( 6, wxSWISS, wxNORMAL, wxBOLD ) );
+ #else
+
+ memdc.
+- SetFont ( wxFont::wxFont ( 8, wxSWISS, wxNORMAL, wxBOLD ) );
++ SetFont ( wxFont ( 8, wxSWISS, wxNORMAL, wxBOLD ) );
+ #endif
+
+ memdc.