summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-05-13 13:29:04 +0000
committerSven Wegener <swegener@gentoo.org>2005-05-13 13:29:04 +0000
commit9f746a643df194bf6a761746f3e22bcce29b5ce5 (patch)
tree666d9a794548e37933372d4cf073d01dd1fd5571 /net-nntp/klibido
parentStable on sparc wrt #91817 (diff)
downloadgentoo-2-9f746a643df194bf6a761746f3e22bcce29b5ce5.tar.gz
gentoo-2-9f746a643df194bf6a761746f3e22bcce29b5ce5.tar.bz2
gentoo-2-9f746a643df194bf6a761746f3e22bcce29b5ce5.zip
Version bump, bug #92204.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'net-nntp/klibido')
-rw-r--r--net-nntp/klibido/ChangeLog4
-rw-r--r--net-nntp/klibido/Manifest12
-rw-r--r--net-nntp/klibido/files/digest-klibido-0.2.31
-rw-r--r--net-nntp/klibido/klibido-0.2.3.ebuild32
4 files changed, 37 insertions, 12 deletions
diff --git a/net-nntp/klibido/ChangeLog b/net-nntp/klibido/ChangeLog
index a68496ab809e..779a5003605f 100644
--- a/net-nntp/klibido/ChangeLog
+++ b/net-nntp/klibido/ChangeLog
@@ -1,12 +1,12 @@
# ChangeLog for net-nntp/klibido
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/klibido/ChangeLog,v 1.9 2005/03/19 00:41:22 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/klibido/ChangeLog,v 1.10 2005/05/13 13:29:04 swegener Exp $
*klibido-0.2.2.2 (19 Mar 2005)
19 Mar 2005; Sven Wegener <swegener@gentoo.org> -klibido-0.2.2.1.ebuild,
+klibido-0.2.2.2.ebuild:
- Version bump.
+ Version bump, bug 92204.
*klibido-0.2.2.1 (16 Mar 2005)
diff --git a/net-nntp/klibido/Manifest b/net-nntp/klibido/Manifest
index d78d2a42aacd..09ba8520c37a 100644
--- a/net-nntp/klibido/Manifest
+++ b/net-nntp/klibido/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 d008fff0da3178375a4bcae114b7b018 klibido-0.2.2.2.ebuild 772
+MD5 d008fff0da3178375a4bcae114b7b018 klibido-0.2.3.ebuild 772
MD5 c379b9b0346c6965a74166c115e16a83 ChangeLog 1598
MD5 d4764f5c17f5e0b416f7ddf271c77d71 metadata.xml 161
+MD5 b9341c26322876dabb2e10261c976076 files/digest-klibido-0.2.3 65
MD5 3f7c9baf0f3530a98fd6c08a8ebc4aab files/digest-klibido-0.2.2.2 67
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCO3U8I1lqEGTUzyQRAiAOAKDLYONrTBVjKe5AgbxhikuK1nfAeQCgibrY
-X+MUNLQ1jO9PGXjYAswrRF4=
-=D3/3
------END PGP SIGNATURE-----
diff --git a/net-nntp/klibido/files/digest-klibido-0.2.3 b/net-nntp/klibido/files/digest-klibido-0.2.3
new file mode 100644
index 000000000000..d1761e10eed2
--- /dev/null
+++ b/net-nntp/klibido/files/digest-klibido-0.2.3
@@ -0,0 +1 @@
+MD5 adffc4df2df4f339794a49d5e06248b3 klibido-0.2.3.tar.gz 718043
diff --git a/net-nntp/klibido/klibido-0.2.3.ebuild b/net-nntp/klibido/klibido-0.2.3.ebuild
new file mode 100644
index 000000000000..14cd5c385586
--- /dev/null
+++ b/net-nntp/klibido/klibido-0.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/klibido/klibido-0.2.3.ebuild,v 1.1 2005/05/13 13:29:04 swegener Exp $
+
+inherit kde versionator
+
+DESCRIPTION="KDE Linux Binaries Downloader"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://klibido.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE="debug"
+
+DEPEND="dev-libs/uulib
+ >=sys-libs/db-4.1"
+
+need-kde 3
+
+src_compile() {
+ local libdbver="$(best_version sys-libs/db)"
+ libdbver="${libdbver/sys-libs\/db-/}"
+ libdbver="$(get_version_component_range 1-2 ${libdbver})"
+
+ myconf="${myconf}
+ --datadir=${D}/usr/share
+ --with-extra-includes=/usr/include/db${libdbver}/
+ $(use_enable debug)
+ "
+ kde_src_compile
+}