summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-07-23 22:51:21 +0000
committerSven Wegener <swegener@gentoo.org>2004-07-23 22:51:21 +0000
commitaa6de0cbf309d757621b614441337d21c157456f (patch)
treee7076fd59b65aad0dbaee2536fc4fadd5f75267f /net-news/xrn/xrn-9.02.ebuild
parentneeds >=dev-libs/libsigc++-1.2.5 (bug #58077) (Manifest recommit) (diff)
downloadgentoo-2-aa6de0cbf309d757621b614441337d21c157456f.tar.gz
gentoo-2-aa6de0cbf309d757621b614441337d21c157456f.tar.bz2
gentoo-2-aa6de0cbf309d757621b614441337d21c157456f.zip
Initial import, ebuild submitted by Alastair Murray <alastairmurray@hotmail.com> in bug #56345.
Diffstat (limited to 'net-news/xrn/xrn-9.02.ebuild')
-rw-r--r--net-news/xrn/xrn-9.02.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-news/xrn/xrn-9.02.ebuild b/net-news/xrn/xrn-9.02.ebuild
new file mode 100644
index 000000000000..1098b67789fc
--- /dev/null
+++ b/net-news/xrn/xrn-9.02.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/xrn/xrn-9.02.ebuild,v 1.1 2004/07/23 22:51:21 swegener Exp $
+
+DESCRIPTION="A small and fast news reader for X."
+HOMEPAGE="http://www.mit.edu/people/jik/software/xrn.html"
+SRC_URI="ftp://sipb.mit.edu/pub/${PN}/${P}.tgz"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="virtual/x11"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_compile() {
+ # English is the default language, but french and german are also
+ # supported, however only one language may be supported at a time:
+ for lingua in ${LINGUAS} en ; do
+ case "$lingua" in
+ en*)
+ MY_LANG="english"
+ break # Breaks the for loop.
+ ;;
+ fr*)
+ MY_LANG="french"
+ break # Breaks the for loop.
+ ;;
+ de*)
+ MY_LANG="german"
+ break # Breaks the for loop.
+ ;;
+ esac
+ done
+
+ # Bugs to Gentoo bugzilla:
+ sed -i \
+ -e "s,bug-xrn@kamens.brookline.ma.us,http://bugs.gentoo.org/," \
+ -e "s,\(#ifndef CONFIG_H_IS_OK\),#define CONFIG_H_IS_OK\n\1," \
+ config.h
+
+ # Generate Makefile:
+ xmkmf || die "xmkmf failed"
+
+ # Use our own CFLAGS and our desired language:
+ emake CDEBUGFLAGS="${CFLAGS}" LANGUAGE="${MY_LANG}" || die "emake failed"
+}
+
+src_install() {
+ dobin xrn || die "dobin failed"
+ dodoc README README.Linux TODO CREDITS COMMON-PROBLMS || die "dodoc failed"
+
+ # Default settings:
+ insinto /etc/X11/app-defaults
+ newins XRn.ad XRn
+
+ newman xrn.man xrn.1
+}