summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-01-11 16:20:20 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-01-11 16:20:20 +0000
commit119af6d7ec96061679784537c966581d4137da58 (patch)
tree8c580b1169b16baf3cc9579c1e92257b3f54d7ce /net-news/liferea
parentStable on ppc64; bug #161558 (diff)
downloadgentoo-2-119af6d7ec96061679784537c966581d4137da58.tar.gz
gentoo-2-119af6d7ec96061679784537c966581d4137da58.tar.bz2
gentoo-2-119af6d7ec96061679784537c966581d4137da58.zip
Bump to 1.2.3
* HTML view respects GTK theme colors now. * Fixes negative new count values in the mainwindow status bar. * Fixes incorrect unread count of parent folder when removing subscriptions with unread items. * Fixes node info updating when marking read with middle mouse button in the feed list. * Fixes a bug that caused item loss in news bins. * Adds Arabic translation from Khaled Hosny. (Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'net-news/liferea')
-rw-r--r--net-news/liferea/ChangeLog13
-rw-r--r--net-news/liferea/files/digest-liferea-1.2.33
-rw-r--r--net-news/liferea/liferea-1.2.3.ebuild81
3 files changed, 96 insertions, 1 deletions
diff --git a/net-news/liferea/ChangeLog b/net-news/liferea/ChangeLog
index 9458d29565cc..24061adf08fd 100644
--- a/net-news/liferea/ChangeLog
+++ b/net-news/liferea/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-news/liferea
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/ChangeLog,v 1.79 2007/01/09 07:58:05 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/ChangeLog,v 1.80 2007/01/11 16:20:20 dang Exp $
+
+ 11 Jan 2007; Daniel Gryniewicz <dang@gentoo.org> ChangeLog:
+ Bump to 1.2.3
+ * HTML view respects GTK theme colors now.
+ * Fixes negative new count values in the mainwindow status bar.
+ * Fixes incorrect unread count of parent folder when removing
+ subscriptions with unread items.
+ * Fixes node info updating when marking read with middle
+ mouse button in the feed list.
+ * Fixes a bug that caused item loss in news bins.
+ * Adds Arabic translation from Khaled Hosny.
09 Jan 2007; Markus Rothe <corsair@gentoo.org> liferea-1.0.24.ebuild:
Stable on ppc64; bug #159802
diff --git a/net-news/liferea/files/digest-liferea-1.2.3 b/net-news/liferea/files/digest-liferea-1.2.3
new file mode 100644
index 000000000000..128ae3fd6544
--- /dev/null
+++ b/net-news/liferea/files/digest-liferea-1.2.3
@@ -0,0 +1,3 @@
+MD5 7fe28cef315a145eeaff3ac973fb1841 liferea-1.2.3.tar.gz 1329115
+RMD160 254f1b03e4611f8976c66ac9600e67bc5ffdc5b6 liferea-1.2.3.tar.gz 1329115
+SHA256 8ff75b965ee853a5f8250a08869fbe0dcd332502e55e05e28d9c708b2c908d5b liferea-1.2.3.tar.gz 1329115
diff --git a/net-news/liferea/liferea-1.2.3.ebuild b/net-news/liferea/liferea-1.2.3.ebuild
new file mode 100644
index 000000000000..b34fb32784ad
--- /dev/null
+++ b/net-news/liferea/liferea-1.2.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/liferea-1.2.3.ebuild,v 1.1 2007/01/11 16:20:20 dang Exp $
+
+WANT_AUTOMAKE=1.7
+WANT_AUTOCONF=latest
+inherit gnome2 flag-o-matic eutils autotools
+
+DESCRIPTION="News Aggregator for RDF/RSS/CDF/Atom/Echo/etc feeds"
+HOMEPAGE="http://liferea.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="dbus firefox gtkhtml seamonkey libnotify gnutls xulrunner"
+
+RDEPEND=">=x11-libs/gtk+-2.8
+ x11-libs/pango
+ >=gnome-base/gconf-2
+ >=dev-libs/libxml2-2.5.10
+ dev-libs/libxslt
+ >=dev-libs/glib-2
+ xulrunner? ( net-libs/xulrunner )
+ !xulrunner? ( firefox? ( www-client/mozilla-firefox ) )
+ !xulrunner? ( !firefox? ( seamonkey? ( www-client/seamonkey ) ) )
+ !xulrunner? ( !firefox? ( !seamonkey? ( =gnome-extra/gtkhtml-2* ) ) )
+ gtkhtml? ( =gnome-extra/gtkhtml-2* )
+ dbus? ( || ( >=dev-libs/dbus-glib-0.71
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.36 ) )
+ )
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )
+ gnutls? ( net-libs/gnutls )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ epatch "${FILESDIR}/${PN}-1.1.0-libnotify.patch"
+
+ eautoreconf || die "Autoreconf failed"
+}
+
+pkg_setup() {
+ # if you don't choose a gecko to use, we will automatically
+ # use gtkhtml2 as the backend.
+ if ! use seamonkey && ! use firefox || use gtkhtml ; then
+ G2CONF="${G2CONF} --enable-gtkhtml2"
+ else
+ G2CONF="${G2CONF} --disable-gtkhtml2"
+ fi
+
+ # we prefer xulrunner over firefox over seamonkey
+ if use xulrunner ; then
+ G2CONF="${G2CONF} --enable-gecko=xulrunner"
+ elif use firefox ; then
+ G2CONF="${G2CONF} --enable-gecko=firefox"
+ elif use seamonkey ; then
+ G2CONF="${G2CONF} --enable-gecko=seamonkey"
+ else
+ G2CONF="${G2CONF} --disable-gecko"
+ fi
+
+ G2CONF="${G2CONF} \
+ $(use_enable dbus) \
+ $(use_enable gnutls) \
+ $(use_enable libnotify)"
+}
+
+src_install() {
+ gnome2_src_install
+ rm -f ${D}/usr/bin/${PN}
+ mv ${D}/usr/bin/${PN}-bin ${D}/usr/bin/${PN}
+}