summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-05-02 21:21:46 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-05-02 21:21:46 +0000
commite04af3f54aa65e1ba4f248cbcdcd609d4999ce94 (patch)
treed58f0c56603fab442ee81d9e45273a2b50167874 /net-misc
parentnew rsync with bug fixums (diff)
downloadgentoo-2-e04af3f54aa65e1ba4f248cbcdcd609d4999ce94.tar.gz
gentoo-2-e04af3f54aa65e1ba4f248cbcdcd609d4999ce94.tar.bz2
gentoo-2-e04af3f54aa65e1ba4f248cbcdcd609d4999ce94.zip
oop
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rsync/rsync-2.5.5.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-misc/rsync/rsync-2.5.5.ebuild b/net-misc/rsync/rsync-2.5.5.ebuild
new file mode 100644
index 000000000000..f7d36472e164
--- /dev/null
+++ b/net-misc/rsync/rsync-2.5.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.5.5.ebuild,v 1.1 2002/05/02 21:21:46 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="File transfer program to keep remote files into sync"
+SRC_URI="http://rsync.samba.org/ftp/rsync/${P}.tar.gz"
+HOMEPAGE="http://rsync.samba.org"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # change confdir to /etc/rsync rather than just /etc (the --sysconfdir
+ # configure option doesn't work
+ cp rsync.h rsync.h.orig
+ sed -e 's:RSYNCD_CONF "/etc/rsyncd.conf":RSYNCD_CONF "/etc/rsync/rsyncd.conf":g' rsync.h.orig > rsync.h
+
+ # yes, updating the man page is very important.
+ cp rsyncd.conf.5 rsyncd.conf.5.orig
+ sed -e 's:/etc/rsyncd:/etc/rsync/rsyncd:g' rsyncd.conf.5.orig > rsyncd.conf.5
+}
+
+src_compile() {
+ ./configure --prefix=/usr --host=${CHOST} || die
+ if [ "`use static`" ] ; then
+ emake LDFLAGS="-static" || die
+ else
+ emake || die
+ fi
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ install || die
+ if [ -z "`use build`" ]
+ then
+ dodir /etc/rsync
+ dodoc COPYING NEWS OLDNEWS README TODO tech_report.tex
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+
+pkg_postinst() {
+ if [ ! -d /etc/rsync ]
+ then
+ mkdir /etc/rsync
+ fi
+}