summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-01-06 19:55:35 +0000
committerMike Gilbert <floppym@gentoo.org>2014-01-06 19:55:35 +0000
commita1b9a5462b9059ee71c35952bce8cd90963c3cd5 (patch)
tree2e0e257249cccc4ab88a1241adc161d572ed82c9 /net-misc
parentReplace multilib_is_native_abi with multilib_build_binaries, bug 485734 (diff)
downloadgentoo-2-a1b9a5462b9059ee71c35952bce8cd90963c3cd5.tar.gz
gentoo-2-a1b9a5462b9059ee71c35952bce8cd90963c3cd5.tar.bz2
gentoo-2-a1b9a5462b9059ee71c35952bce8cd90963c3cd5.zip
Fix pidfile handling in openrc init script.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/libreswan/ChangeLog9
-rw-r--r--net-misc/libreswan/files/libreswan-3.7-openrc-pidfile.patch37
-rw-r--r--net-misc/libreswan/libreswan-3.7-r1.ebuild (renamed from net-misc/libreswan/libreswan-3.7.ebuild)3
3 files changed, 47 insertions, 2 deletions
diff --git a/net-misc/libreswan/ChangeLog b/net-misc/libreswan/ChangeLog
index 87ee123d94c4..6a6f955ff088 100644
--- a/net-misc/libreswan/ChangeLog
+++ b/net-misc/libreswan/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/libreswan
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/libreswan/ChangeLog,v 1.4 2014/01/06 19:29:12 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/libreswan/ChangeLog,v 1.5 2014/01/06 19:55:34 floppym Exp $
+
+*libreswan-3.7-r1 (06 Jan 2014)
+
+ 06 Jan 2014; Mike Gilbert <floppym@gentoo.org>
+ +files/libreswan-3.7-openrc-pidfile.patch, +libreswan-3.7-r1.ebuild,
+ -libreswan-3.7.ebuild:
+ Fix pidfile handling in openrc init script.
06 Jan 2014; Mike Gilbert <floppym@gentoo.org> libreswan-3.7.ebuild,
libreswan-9999.ebuild:
diff --git a/net-misc/libreswan/files/libreswan-3.7-openrc-pidfile.patch b/net-misc/libreswan/files/libreswan-3.7-openrc-pidfile.patch
new file mode 100644
index 000000000000..9c9f696d0834
--- /dev/null
+++ b/net-misc/libreswan/files/libreswan-3.7-openrc-pidfile.patch
@@ -0,0 +1,37 @@
+From ee43bdf59ad20e099093a5de4a7cfe63f0c12ba0 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Mon, 6 Jan 2014 14:43:37 -0500
+Subject: [PATCH] packaging: Fix pidfile handling in openrc init script
+
+Variable is referenced as PLUTO_PIDFILE in start() and stop().
+
+Also, don't initialize PLUTO_OPTS to blank; this allows the sysadmin to
+set it in /etc/conf.d/ipsec.
+---
+ initsystems/openrc/ipsec.init.in | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/initsystems/openrc/ipsec.init.in b/initsystems/openrc/ipsec.init.in
+index f3ab2f9..c121897 100755
+--- a/initsystems/openrc/ipsec.init.in
++++ b/initsystems/openrc/ipsec.init.in
+@@ -1,7 +1,5 @@
+ #!/sbin/runscript
+
+-PLUTO_OPTS=""
+-
+ name="ipsec pluto daemon"
+ extra_commands="configtest"
+ extra_started_commands="reload"
+@@ -12,7 +10,7 @@ description_reload="reloads the configuration - does not affect existing connect
+ PLUTO_BINARY=${PLUTO_BINARY:-@FINALLIBDIR@/pluto}
+ PLUTO_CONFFILE=${PLUTO_CONFFILE:-@FINALCONFFILE@}
+ IPSEC_BINARY=${IPSEC_BINARY:-@FINALSBINDIR@/ipsec}
+-PLUTO_PID=${PLUTO_PID:-/var/run/pluto/pluto.pid}
++PLUTO_PIDFILE=${PLUTO_PIDFILE:-/var/run/pluto/pluto.pid}
+
+ depend() {
+ need net
+--
+1.8.5.2
+
diff --git a/net-misc/libreswan/libreswan-3.7.ebuild b/net-misc/libreswan/libreswan-3.7-r1.ebuild
index ae17b7149d0b..c037750c512c 100644
--- a/net-misc/libreswan/libreswan-3.7.ebuild
+++ b/net-misc/libreswan/libreswan-3.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/libreswan/libreswan-3.7.ebuild,v 1.4 2014/01/06 19:29:11 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/libreswan/libreswan-3.7-r1.ebuild,v 1.1 2014/01/06 19:55:34 floppym Exp $
EAPI=5
@@ -48,6 +48,7 @@ RDEPEND="${COMMON_DEPEND}
src_prepare() {
epatch "${FILESDIR}/libreswan-3.7-curl.patch"
epatch "${FILESDIR}/libreswan-3.7-openrc.patch"
+ epatch "${FILESDIR}/libreswan-3.7-openrc-pidfile.patch"
epatch_user
}