summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-08-12 05:12:53 +0000
committerMike Frysinger <vapier@gentoo.org>2014-08-12 05:12:53 +0000
commit4a36be88367992a439df68d24227e37808f78599 (patch)
tree2490e794c46f6242ac6a8a37e1690647ecab41aa /net-misc
parentNew package required by newer gsutil #516026 by Bruno Ricci. (diff)
downloadgentoo-2-4a36be88367992a439df68d24227e37808f78599.tar.gz
gentoo-2-4a36be88367992a439df68d24227e37808f78599.tar.bz2
gentoo-2-4a36be88367992a439df68d24227e37808f78599.zip
Version bump #516026 by Bruno Ricci.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gsutil/ChangeLog8
-rw-r--r--net-misc/gsutil/files/gsutil-4.4-use-friendy-version-checks.patch22
-rw-r--r--net-misc/gsutil/gsutil-4.4.ebuild44
3 files changed, 73 insertions, 1 deletions
diff --git a/net-misc/gsutil/ChangeLog b/net-misc/gsutil/ChangeLog
index a0e4da134ada..1ae5e527b39f 100644
--- a/net-misc/gsutil/ChangeLog
+++ b/net-misc/gsutil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/gsutil
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gsutil/ChangeLog,v 1.15 2014/02/25 01:13:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsutil/ChangeLog,v 1.16 2014/08/12 05:12:53 vapier Exp $
+
+*gsutil-4.4 (12 Aug 2014)
+
+ 12 Aug 2014; Mike Frysinger <vapier@gentoo.org>
+ +files/gsutil-4.4-use-friendy-version-checks.patch, +gsutil-4.4.ebuild:
+ Version bump #516026 by Bruno Ricci.
*gsutil-3.38 (25 Feb 2014)
diff --git a/net-misc/gsutil/files/gsutil-4.4-use-friendy-version-checks.patch b/net-misc/gsutil/files/gsutil-4.4-use-friendy-version-checks.patch
new file mode 100644
index 000000000000..0443d109b588
--- /dev/null
+++ b/net-misc/gsutil/files/gsutil-4.4-use-friendy-version-checks.patch
@@ -0,0 +1,22 @@
+--- a/setup.py
++++ b/setup.py
+@@ -35,7 +35,7 @@ management tasks, including:
+ """
+
+ requires = [
+- 'boto==2.30.0',
++ 'boto>=2.30.0',
+ 'crcmod>=1.7',
+ 'gcs-oauth2-boto-plugin>=1.7',
+ 'google-api-python-client>=1.1',
+@@ -43,9 +43,7 @@ requires = [
+ 'pyOpenSSL>=0.13',
+ 'python-gflags>=2.0',
+ 'retry_decorator>=1.0.0',
+- # Not using 1.02 because of:
+- # https://code.google.com/p/socksipy-branch/issues/detail?id=3
+- 'SocksiPy-branch==1.01',
++ 'SocksiPy-branch>=1.01',
+ ]
+
+ dependency_links = [
diff --git a/net-misc/gsutil/gsutil-4.4.ebuild b/net-misc/gsutil/gsutil-4.4.ebuild
new file mode 100644
index 000000000000..f0a8ce62015e
--- /dev/null
+++ b/net-misc/gsutil/gsutil-4.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsutil/gsutil-4.4.ebuild,v 1.1 2014/08/12 05:12:53 vapier Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="command line tool for interacting with cloud storage services"
+HOMEPAGE="https://github.com/GoogleCloudPlatform/gsutil"
+SRC_URI="http://commondatastorage.googleapis.com/pub/${PN}_${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=dev-python/boto-2.30.0[${PYTHON_USEDEP}]
+ >=dev-python/crcmod-1.7
+ >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/gcs-oauth2-boto-plugin-1.7[${PYTHON_USEDEP}]
+ >=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
+ >=dev-python/python-gflags-2.0[${PYTHON_USEDEP}]
+ >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/socksipy-1.01[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( README.md CHANGES.md )
+
+PATCHES=(
+ "${FILESDIR}/${P}-use-friendy-version-checks.patch"
+ "${FILESDIR}/${PN}-3.37-drop-http_proxy-clearing.patch"
+)
+
+python_test() {
+ export BOTO_CONFIG=${FILESDIR}/dummy.boto
+ ${PYTHON} gslib/__main__.py test -u || die "tests failed"
+}