summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Marichez <falco@gentoo.org>2007-07-26 13:07:19 +0000
committerRaphaël Marichez <falco@gentoo.org>2007-07-26 13:07:19 +0000
commit2e8f2a07dbc619c305e5db263b55e7d8b08588ed (patch)
treedc4b1386d14a9856dc70f331863a164cffb59599 /net-misc
parentdev-dotnet/monodevelop-0.14 - fixes in configure.in (bug #183956) (diff)
downloadgentoo-2-2e8f2a07dbc619c305e5db263b55e7d8b08588ed.tar.gz
gentoo-2-2e8f2a07dbc619c305e5db263b55e7d8b08588ed.tar.bz2
gentoo-2-2e8f2a07dbc619c305e5db263b55e7d8b08588ed.zip
Version bump for testing
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/socat/ChangeLog8
-rw-r--r--net-misc/socat/files/digest-socat-2.0.0_beta13
-rw-r--r--net-misc/socat/socat-2.0.0_beta1.ebuild45
3 files changed, 55 insertions, 1 deletions
diff --git a/net-misc/socat/ChangeLog b/net-misc/socat/ChangeLog
index 28d3b6c5dc11..f2b100b89be9 100644
--- a/net-misc/socat/ChangeLog
+++ b/net-misc/socat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/socat
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/ChangeLog,v 1.31 2007/04/14 21:28:27 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/ChangeLog,v 1.32 2007/07/26 13:07:19 falco Exp $
+
+*socat-2.0.0_beta1 (26 Jul 2007)
+
+ 26 Jul 2007; Raphael Marichez <falco@gentoo.org>
+ +socat-2.0.0_beta1.ebuild:
+ Version bump for testing
14 Apr 2007; Marcelo Goes <vanquirius@gentoo.org>
-files/socat-1.4.3.0-noptytest.patch, -files/socat-1.4.3.0-tmp-tail.patch,
diff --git a/net-misc/socat/files/digest-socat-2.0.0_beta1 b/net-misc/socat/files/digest-socat-2.0.0_beta1
new file mode 100644
index 000000000000..d723eaeafa8c
--- /dev/null
+++ b/net-misc/socat/files/digest-socat-2.0.0_beta1
@@ -0,0 +1,3 @@
+MD5 7d9051225f267d61b6deb545091d2ec9 socat-2.0.0-b1.tar.bz2 325120
+RMD160 0d8da4cb2fc0e6d041ff114beb24e2d63251748c socat-2.0.0-b1.tar.bz2 325120
+SHA256 d311e2d9295236778302095e19aaf6fb2538753e28cd313208944521b82b6d79 socat-2.0.0-b1.tar.bz2 325120
diff --git a/net-misc/socat/socat-2.0.0_beta1.ebuild b/net-misc/socat/socat-2.0.0_beta1.ebuild
new file mode 100644
index 000000000000..d15f4766f707
--- /dev/null
+++ b/net-misc/socat/socat-2.0.0_beta1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-2.0.0_beta1.ebuild,v 1.1 2007/07/26 13:07:19 falco Exp $
+
+inherit eutils
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+MY_P=${P/_beta/-b}
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="ssl readline ipv6 tcpd"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ virtual/libc"
+
+src_compile() {
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap) \
+ || die "econf failed"
+ emake || die
+}
+
+src_test() {
+ TMPDIR="${T}" make test || die 'self test failed'
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ dodoc BUGREPORTS CHANGES DEVELOPMENT EXAMPLES \
+ FAQ FILES PORTING README SECURITY VERSION
+ docinto examples
+ dodoc *.sh
+ dohtml doc/*.html doc/*.css
+}