summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Jackson <iggy@gentoo.org>2004-10-04 04:09:48 +0000
committerBrian Jackson <iggy@gentoo.org>2004-10-04 04:09:48 +0000
commitb49a05d2694a1101236ae3f53971077e9a29a555 (patch)
tree1e845e8be4bd2f024737834255ec988044159add /net-misc/zaptel
parentswitched custom ARCH setting code to use set_arch_to_* from eutils (Manifest ... (diff)
downloadgentoo-2-b49a05d2694a1101236ae3f53971077e9a29a555.tar.gz
gentoo-2-b49a05d2694a1101236ae3f53971077e9a29a555.tar.bz2
gentoo-2-b49a05d2694a1101236ae3f53971077e9a29a555.zip
switched custom ARCH setting code to use set_arch_to_* from eutils, also used some functions from kmod instead of homebrew stuff
Diffstat (limited to 'net-misc/zaptel')
-rw-r--r--net-misc/zaptel/ChangeLog6
-rw-r--r--net-misc/zaptel/zaptel-1.0.0.ebuild18
2 files changed, 13 insertions, 11 deletions
diff --git a/net-misc/zaptel/ChangeLog b/net-misc/zaptel/ChangeLog
index ccd24f0a5758..bc672a812d61 100644
--- a/net-misc/zaptel/ChangeLog
+++ b/net-misc/zaptel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/zaptel
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/ChangeLog,v 1.15 2004/09/23 23:57:02 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/ChangeLog,v 1.16 2004/10/04 04:09:48 iggy Exp $
+
+ 03 Oct 2004; <iggy@gentoo.org> zaptel-1.0.0.ebuild:
+ switched custom ARCH setting code to use set_arch_to_* from eutils, also
+ used some functions from kmod instead of homebrew stuff
*zaptel-1.0.0 (24 Sep 2004)
diff --git a/net-misc/zaptel/zaptel-1.0.0.ebuild b/net-misc/zaptel/zaptel-1.0.0.ebuild
index 143f237cc0fc..5a2dce1968cd 100644
--- a/net-misc/zaptel/zaptel-1.0.0.ebuild
+++ b/net-misc/zaptel/zaptel-1.0.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/zaptel-1.0.0.ebuild,v 1.1 2004/09/23 23:57:02 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/zaptel-1.0.0.ebuild,v 1.2 2004/10/04 04:09:48 iggy Exp $
IUSE="devfs26"
-inherit eutils
+inherit eutils kmod
DESCRIPTION="Pseudo-TDM engine"
HOMEPAGE="http://www.asterisk.org"
@@ -29,7 +29,7 @@ pkg_setup() {
einfo "Otherwise quit this ebuild, rebuild your kernel and reboot"
# show an nice warning message about zaptel not supporting devfs on 2.6
- if [ $(echo $KV | cut -d. -f1) -eq 2 ] && [ $(echo $KV|cut -d. -f2) -eq 6 ]; then
+ if is_kernel 2 6 ; then
echo
einfo "You're using zaptel with linux-2.6:"
ewarn " Zaptel doesn't support devfs with 2.6, you'll need to use udev or disable devfs"
@@ -37,7 +37,7 @@ pkg_setup() {
echo
ewarn "There's an experimental patch which adds devfs support when using linux-2.6, but:"
ewarn " 1. It's an ugly hack atm and needs a cleanup..."
- ewarn " 2. I was only abled to test loding / unloading with the ztd-eth driver..."
+ ewarn " 2. I was only able to test loading / unloading with the ztd-eth driver..."
ewarn " 3. I _really_ don't know if it works with real hardware..."
echo
eerror " 4. And more important: This is not officially supported by Digium / the Asterisk project!!!"
@@ -80,16 +80,14 @@ src_unpack() {
src_compile() {
# workaround for 2.6 build system
- if [ $(echo $KV | cut -d. -f1) -eq 2 ] && [ $(echo $KV|cut -d. -f2) -eq 6 ]; then
+ if is_kernel 2 6 ; then
einfo "Enabled 2.6 module building workaround..."
addwrite /usr/src/linux
fi
- if use x86; then
- make ARCH="i386" || die
- else
- make || die
- fi
+ set_arch_to_kernel
+ make || die
+ set_arch_to_portage
}
src_install() {