summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2010-12-23 20:44:07 +0000
committerThomas Kahle <tomka@gentoo.org>2010-12-23 20:44:07 +0000
commitb211611a47163d9c8f6c5ab1281f2b5ebb563ad4 (patch)
tree63b41ae13a33419461049b6539797eaadba56300 /net-misc/wicd
parentBump to 6.3.1. Upstream was revived at a new location. Tarballs from github d... (diff)
downloadgentoo-2-b211611a47163d9c8f6c5ab1281f2b5ebb563ad4.tar.gz
gentoo-2-b211611a47163d9c8f6c5ab1281f2b5ebb563ad4.tar.bz2
gentoo-2-b211611a47163d9c8f6c5ab1281f2b5ebb563ad4.zip
Fix deps (bug #342613 and bug #342615)
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'net-misc/wicd')
-rw-r--r--net-misc/wicd/ChangeLog7
-rw-r--r--net-misc/wicd/wicd-1.7.1_beta2-r2.ebuild105
2 files changed, 111 insertions, 1 deletions
diff --git a/net-misc/wicd/ChangeLog b/net-misc/wicd/ChangeLog
index 9a3ae63dc4b4..3eada3861d6a 100644
--- a/net-misc/wicd/ChangeLog
+++ b/net-misc/wicd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/wicd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.77 2010/12/21 15:52:35 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.78 2010/12/23 20:44:07 tomka Exp $
+
+*wicd-1.7.1_beta2-r2 (23 Dec 2010)
+
+ 23 Dec 2010; Thomas Kahle <tomka@gentoo.org> +wicd-1.7.1_beta2-r2.ebuild:
+ Fix deps (bug #342613 and bug #342615)
21 Dec 2010; Dane Smith <c1pher@gentoo.org> metadata.xml:
Add myself as a maintainer.
diff --git a/net-misc/wicd/wicd-1.7.1_beta2-r2.ebuild b/net-misc/wicd/wicd-1.7.1_beta2-r2.ebuild
new file mode 100644
index 000000000000..6d983e8f61f9
--- /dev/null
+++ b/net-misc/wicd/wicd-1.7.1_beta2-r2.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/wicd-1.7.1_beta2-r2.ebuild,v 1.1 2010/12/23 20:44:07 tomka Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
+inherit eutils distutils
+
+MY_P=${P/_beta/b}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A lightweight wired and wireless network manager for Linux"
+HOMEPAGE="http://wicd.sourceforge.net/"
+SRC_URI="http://downloads.wicd.net/src/testing/1.7.x/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="X +gtk ioctl libnotify ncurses nls +pm-utils"
+
+DEPEND=""
+# Maybe virtual/dhcp would work, but there are enough problems with
+# net-misc/dhcp that I want net-misc/dhcpcd to be guarenteed to be considered
+# first if none are installed.
+RDEPEND="
+ dev-lang/python[xml]
+ dev-python/dbus-python
+ X? ( gtk? ( dev-python/pygtk
+ || (
+ x11-misc/ktsuss
+ x11-libs/gksu
+ kde-base/kdesu
+ )
+ )
+ )
+ || (
+ net-misc/dhcpcd
+ net-misc/dhcp
+ net-misc/pump
+ )
+ net-wireless/wireless-tools
+ net-wireless/wpa_supplicant
+ || (
+ sys-apps/net-tools
+ sys-apps/ethtool
+ )
+ !gtk? ( dev-python/pygobject )
+ ioctl? ( dev-python/python-iwscan dev-python/python-wpactrl )
+ libnotify? ( dev-python/notify-python )
+ ncurses? (
+ >=dev-python/urwid-0.9.9.1
+ dev-lang/python[ncurses]
+ )
+ pm-utils? ( >=sys-power/pm-utils-1.1.1 )
+ "
+DOCS="CHANGES NEWS AUTHORS README"
+
+src_prepare() {
+ python_copy_sources
+}
+
+src_configure() {
+ local myconf
+ use gtk || myconf="${myconf} --no-install-gtk"
+ use libnotify || myconf="${myconf} --no-use-notifications"
+ use ncurses || myconf="${myconf} --no-install-ncurses"
+ use pm-utils || myconf="${myconf} --no-install-pmutils"
+ configuration() {
+ $(PYTHON) ./setup.py configure --no-install-docs --resume=/usr/share/wicd/scripts/ --suspend=/usr/share/wicd/scripts/ --verbose ${myconf}
+ }
+ python_execute_function -s configuration
+}
+
+src_install() {
+ distutils_src_install
+ keepdir /var/lib/wicd/configurations \
+ || die "keepdir failed, critical for this app"
+ keepdir /etc/wicd/scripts/{postconnect,disconnect,preconnect} \
+ || die "keepdir failed, critical for this app"
+ keepdir /var/log/wicd \
+ || die "keepdir failed, critical for this app"
+ use nls || rm -rf "${D}"/usr/share/locale
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "You may need to restart the dbus service after upgrading wicd."
+ echo
+ elog "To start wicd at boot, add /etc/init.d/wicd to a runlevel and:"
+ elog "- Remove all net.* initscripts (except for net.lo) from all runlevels"
+ elog "- Add these scripts to the RC_PLUG_SERVICES line in /etc/conf.d/rc"
+ elog "(For example, RC_PLUG_SERVICES=\"!net.eth0 !net.wlan0\")"
+ # Maintainer's note: the consolekit use flag short circuits a dbus rule and
+ # allows the connection. Else, you need to be in the group.
+ if ! has_version sys-auth/pambase[consolekit]; then
+ ewarn "Wicd-1.6 and newer requires your user to be in the 'users' group. If"
+ ewarn "you are not in that group, then modify /etc/dbus-1/system.d/wicd.conf"
+ fi
+}