summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-09-29 13:37:42 +0000
committerMike Frysinger <vapier@gentoo.org>2007-09-29 13:37:42 +0000
commit2fae239a433f948142e3e3b3d146c852c260352b (patch)
tree4ec5bd9fc62cf5188f0006f2fa677d0bb235cd65 /net-misc/whois
parentold (diff)
downloadgentoo-2-2fae239a433f948142e3e3b3d146c852c260352b.tar.gz
gentoo-2-2fae239a433f948142e3e3b3d146c852c260352b.tar.bz2
gentoo-2-2fae239a433f948142e3e3b3d146c852c260352b.zip
Version bump.
(Portage version: 2.1.3.9)
Diffstat (limited to 'net-misc/whois')
-rw-r--r--net-misc/whois/ChangeLog7
-rw-r--r--net-misc/whois/files/digest-whois-4.7.233
-rw-r--r--net-misc/whois/whois-4.7.23.ebuild53
3 files changed, 62 insertions, 1 deletions
diff --git a/net-misc/whois/ChangeLog b/net-misc/whois/ChangeLog
index 8f1263224172..b63401e4a11b 100644
--- a/net-misc/whois/ChangeLog
+++ b/net-misc/whois/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/whois
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.95 2007/09/28 17:16:40 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.96 2007/09/29 13:37:42 vapier Exp $
+
+*whois-4.7.23 (29 Sep 2007)
+
+ 29 Sep 2007; Mike Frysinger <vapier@gentoo.org> +whois-4.7.23.ebuild:
+ Version bump.
28 Sep 2007; nixnut <nixnut@gentoo.org> whois-4.7.22.ebuild:
Stable on ppc wrt bug 194009
diff --git a/net-misc/whois/files/digest-whois-4.7.23 b/net-misc/whois/files/digest-whois-4.7.23
new file mode 100644
index 000000000000..8faab1fc5409
--- /dev/null
+++ b/net-misc/whois/files/digest-whois-4.7.23
@@ -0,0 +1,3 @@
+MD5 f0cadc8b484baa32515ff610090db05a whois_4.7.23.tar.gz 61336
+RMD160 042614b6d83368aca07e5878f10cef428e1509e7 whois_4.7.23.tar.gz 61336
+SHA256 1152be0904afedf66107d1b5dc49542913e57c4e2e2dbe62ed35a178d5acad5e whois_4.7.23.tar.gz 61336
diff --git a/net-misc/whois/whois-4.7.23.ebuild b/net-misc/whois/whois-4.7.23.ebuild
new file mode 100644
index 000000000000..c14cac094fba
--- /dev/null
+++ b/net-misc/whois/whois-4.7.23.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-4.7.23.ebuild,v 1.1 2007/09/29 13:37:42 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="improved Whois Client"
+HOMEPAGE="http://www.linux.it/~md/software/"
+SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+RESTRICT="test" #59327
+
+RDEPEND="net-dns/libidn"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-4.7.19-gentoo-security.patch
+ epatch "${FILESDIR}"/${PN}-4.7.2-config-file.patch
+
+ if use nls ; then
+ cd po
+ sed -i -e "s:/usr/bin/install:install:" Makefile
+ else
+ sed -i -e '/ENABLE_NLS/s:define:undef:' config.h
+ sed -i -e "s:cd po.*::" Makefile
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake OPTS="${CFLAGS}" HAVE_LIBIDN=1 || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ make BASEDIR="${D}" prefix=/usr install || die
+ insinto /etc
+ doins whois.conf
+ dodoc README
+
+ if [[ "${USERLAND}" != "GNU" ]]; then
+ mv ${D}/usr/share/man/man1/{whois,mdwhois}.1
+ mv ${D}/usr/bin/{whois,mdwhois}
+ fi
+}