summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-18 23:08:35 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-18 23:08:35 +0000
commitee49f40b43d80bbf0c8e98e54c5d4d6e68758634 (patch)
tree311dff8073c9429df3abcffed613bf0a8a3e4626 /net-misc/wget
parentx86 stable, bug #382951 (diff)
downloadgentoo-2-ee49f40b43d80bbf0c8e98e54c5d4d6e68758634.tar.gz
gentoo-2-ee49f40b43d80bbf0c8e98e54c5d4d6e68758634.tar.bz2
gentoo-2-ee49f40b43d80bbf0c8e98e54c5d4d6e68758634.zip
Version bump. Add explicit build dependency on xz-utils.
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/ChangeLog7
-rw-r--r--net-misc/wget/wget-1.13.4.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/net-misc/wget/ChangeLog b/net-misc/wget/ChangeLog
index 5d8ed0ccc36b..a1090407dfe2 100644
--- a/net-misc/wget/ChangeLog
+++ b/net-misc/wget/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/wget
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.146 2011/09/06 16:43:49 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.147 2011/09/18 23:08:35 radhermit Exp $
+
+*wget-1.13.4 (18 Sep 2011)
+
+ 18 Sep 2011; Tim Harder <radhermit@gentoo.org> +wget-1.13.4.ebuild:
+ Version bump. Add explicit build dependency on xz-utils.
06 Sep 2011; Fabian Groffen <grobian@gentoo.org>
files/wget-1.13-static-link-libz.patch:
diff --git a/net-misc/wget/wget-1.13.4.ebuild b/net-misc/wget/wget-1.13.4.ebuild
new file mode 100644
index 000000000000..94bb50117fc6
--- /dev/null
+++ b/net-misc/wget/wget-1.13.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.13.4.ebuild,v 1.1 2011/09/18 23:08:35 radhermit Exp $
+
+EAPI=4
+
+inherit flag-o-matic
+
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="http://www.gnu.org/software/wget/"
+SRC_URI="mirror://gnu/wget/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug gnutls idn ipv6 nls ntlm +ssl static"
+
+RDEPEND="idn? ( net-dns/libidn )
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/openssl-0.9.6b )
+ )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+REQUIRED_USE="ntlm? ( !gnutls ssl )
+ gnutls? ( ssl )"
+
+DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
+
+src_configure() {
+ # openssl-0.9.8 now builds with -pthread on the BSD's
+ use elibc_FreeBSD && use ssl && append-ldflags -pthread
+ # fix compilation on Solaris, we need filio.h for FIONBIO as used in
+ # the included gnutls -- force ioctl.h to include this header
+ [[ ${CHOST} == *-solaris* ]] && append-flags -DBSD_COMP=1
+
+ use static && append-ldflags -static
+ econf \
+ --disable-rpath \
+ $(use_with ssl ssl $(use gnutls && echo "gnutls" || echo "openssl")) \
+ $(use_enable ssl opie) \
+ $(use_enable ssl digest) \
+ $(use_enable idn iri) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable ntlm) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ use ipv6 && cat "${FILESDIR}"/wgetrc-ipv6 >> "${ED}"/etc/wgetrc
+
+ sed -i \
+ -e "s:/usr/local/etc:${EPREFIX}/etc:g" \
+ "${ED}"/etc/wgetrc \
+ "${ED}"/usr/share/man/man1/wget.1 \
+ "${ED}"/usr/share/info/wget.info
+}