summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-27 08:05:58 +0000
committerJustin Lecher <jlec@gentoo.org>2015-02-27 08:05:58 +0000
commit8bcd49e8c487bd18093f10f1bf016e889604d498 (patch)
tree94715bc185142c1c8416dc147f18c7da7c44b466 /net-misc/vpnc
parentUse more readable CTARGET setup logic. (diff)
downloadgentoo-2-8bcd49e8c487bd18093f10f1bf016e889604d498.tar.gz
gentoo-2-8bcd49e8c487bd18093f10f1bf016e889604d498.tar.bz2
gentoo-2-8bcd49e8c487bd18093f10f1bf016e889604d498.zip
Restrict binary distribution with USE=-bindist, #541450; bump to latest svn snapshot
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'net-misc/vpnc')
-rw-r--r--net-misc/vpnc/ChangeLog9
-rw-r--r--net-misc/vpnc/vpnc-0.5.3_p527-r1.ebuild4
-rw-r--r--net-misc/vpnc/vpnc-0.5.3_p550.ebuild74
3 files changed, 85 insertions, 2 deletions
diff --git a/net-misc/vpnc/ChangeLog b/net-misc/vpnc/ChangeLog
index 68243a08dbe9..f18ef7a81117 100644
--- a/net-misc/vpnc/ChangeLog
+++ b/net-misc/vpnc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/vpnc
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/ChangeLog,v 1.132 2015/01/05 12:55:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/ChangeLog,v 1.133 2015/02/27 08:05:58 jlec Exp $
+
+*vpnc-0.5.3_p550 (27 Feb 2015)
+
+ 27 Feb 2015; Justin Lecher <jlec@gentoo.org> +vpnc-0.5.3_p550.ebuild,
+ vpnc-0.5.3_p527-r1.ebuild:
+ Restrict binary distribution with USE=-bindist, #541450; bump to latest svn
+ snapshot
05 Jan 2015; Justin Lecher <jlec@gentoo.org> vpnc-0.5.3_p527-r1.ebuild:
Fix documentation URL, #534490
diff --git a/net-misc/vpnc/vpnc-0.5.3_p527-r1.ebuild b/net-misc/vpnc/vpnc-0.5.3_p527-r1.ebuild
index 1519ea3ee021..fb0ee7138001 100644
--- a/net-misc/vpnc/vpnc-0.5.3_p527-r1.ebuild
+++ b/net-misc/vpnc/vpnc-0.5.3_p527-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/vpnc-0.5.3_p527-r1.ebuild,v 1.13 2015/01/05 12:55:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/vpnc-0.5.3_p527-r1.ebuild,v 1.14 2015/02/27 08:05:58 jlec Exp $
EAPI=5
@@ -28,6 +28,8 @@ RDEPEND="${DEPEND}
selinux? ( sec-policy/selinux-vpn )
"
+RESTRICT="!bindist? ( bindist )"
+
CONFIG_CHECK="~TUN"
src_prepare() {
diff --git a/net-misc/vpnc/vpnc-0.5.3_p550.ebuild b/net-misc/vpnc/vpnc-0.5.3_p550.ebuild
new file mode 100644
index 000000000000..6fc2443b92f7
--- /dev/null
+++ b/net-misc/vpnc/vpnc-0.5.3_p550.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/vpnc-0.5.3_p550.ebuild,v 1.1 2015/02/27 08:05:58 jlec Exp $
+
+EAPI=5
+
+inherit eutils linux-info systemd toolchain-funcs
+
+DESCRIPTION="Free client for Cisco VPN routing software"
+HOMEPAGE="http://www.unix-ag.uni-kl.de/~massar/vpnc/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="resolvconf +gnutls bindist selinux"
+
+REQUIRED_USE="bindist? ( gnutls )"
+
+DEPEND="
+ dev-lang/perl
+ dev-libs/libgcrypt:0=
+ >=sys-apps/iproute2-2.6.19.20061214[-minimal]
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ resolvconf? ( net-dns/openresolv )
+ selinux? ( sec-policy/selinux-vpn )
+"
+
+RESTRICT="!bindist? ( bindist )"
+
+CONFIG_CHECK="~TUN"
+
+src_prepare() {
+ if ! use gnutls && ! use bindist; then
+ sed -i -e '/^#OPENSSL_GPL_VIOLATION/s:#::g' "${S}"/Makefile || die
+ ewarn "Building SSL support with OpenSSL instead of GnuTLS. This means that"
+ ewarn "you are not allowed to re-distibute the binaries due to conflicts between BSD license and GPL,"
+ ewarn "see the vpnc Makefile and http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440318"
+ else
+ elog "Will build with GnuTLS (default) instead of OpenSSL so you may even redistribute binaries."
+ elog "See the Makefile itself and http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440318"
+ fi
+
+ sed -e 's:test/cert0.pem::g' -i Makefile || die
+
+ tc-export CC
+
+ sed \
+ -e 's:/var/run:/run:g' \
+ -i ChangeLog config.c TODO || die
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+ dodoc README TODO VERSION
+ keepdir /etc/vpnc/scripts.d
+ newinitd "${FILESDIR}/vpnc-3.init" vpnc
+ newconfd "${FILESDIR}/vpnc.confd" vpnc
+ sed -e "s:/usr/local:/usr:" -i "${ED}"/etc/vpnc/vpnc-script || die
+
+ systemd_dotmpfilesd "${FILESDIR}"/vpnc-tmpfiles.conf
+ systemd_newunit "${FILESDIR}"/vpnc.service vpnc@.service
+
+ # COPYING file resides here, should not be installed
+ rm -rf "${ED}"/usr/share/doc/vpnc/ || die
+}
+
+pkg_postinst() {
+ elog "You can generate a configuration file from the original Cisco profiles of your"
+ elog "connection by using /usr/bin/pcf2vpnc to convert the .pcf file"
+ elog "A guide is available at https://wiki.gentoo.org/wiki/Vpnc"
+}