summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-10-27 21:07:53 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-10-27 21:07:53 +0000
commit2b078de96cc8c050044179a149c2cea26d5e8ef7 (patch)
tree9c896d7fb6f8ed003db211f88682454a7d9ce3cc /net-misc/tokyotyrant
parentversion bump (bug #204248) (diff)
downloadgentoo-2-2b078de96cc8c050044179a149c2cea26d5e8ef7.tar.gz
gentoo-2-2b078de96cc8c050044179a149c2cea26d5e8ef7.tar.bz2
gentoo-2-2b078de96cc8c050044179a149c2cea26d5e8ef7.zip
Bump, closes #290808
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/tokyotyrant')
-rw-r--r--net-misc/tokyotyrant/ChangeLog8
-rw-r--r--net-misc/tokyotyrant/tokyotyrant-1.1.37.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/net-misc/tokyotyrant/ChangeLog b/net-misc/tokyotyrant/ChangeLog
index c2374bac5bcb..3c7a179dc2f4 100644
--- a/net-misc/tokyotyrant/ChangeLog
+++ b/net-misc/tokyotyrant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/tokyotyrant
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tokyotyrant/ChangeLog,v 1.2 2009/10/20 18:48:32 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tokyotyrant/ChangeLog,v 1.3 2009/10/27 21:07:53 patrick Exp $
+
+*tokyotyrant-1.1.37 (27 Oct 2009)
+
+ 27 Oct 2009; Patrick Lauer <patrick@gentoo.org>
+ +tokyotyrant-1.1.37.ebuild:
+ Bump, closes #290808
*tokyotyrant-1.1.36 (20 Oct 2009)
diff --git a/net-misc/tokyotyrant/tokyotyrant-1.1.37.ebuild b/net-misc/tokyotyrant/tokyotyrant-1.1.37.ebuild
new file mode 100644
index 000000000000..adc61fcc309f
--- /dev/null
+++ b/net-misc/tokyotyrant/tokyotyrant-1.1.37.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tokyotyrant/tokyotyrant-1.1.37.ebuild,v 1.1 2009/10/27 21:07:53 patrick Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A network interface to Tokyo Cabinet"
+HOMEPAGE="http://1978th.net/tokyotyrant/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug lua"
+
+DEPEND="dev-db/tokyocabinet
+ sys-libs/zlib
+ app-arch/bzip2
+ lua? ( dev-lang/lua )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup tyrant
+ enewuser tyrant -1 -1 /var/lib/${PN} tyrant
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix_makefiles.patch
+ epatch "${FILESDIR}"/fix_testsuite.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable lua)
+}
+
+src_install() {
+ rm ttservctl || die "Install failed"
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ for x in /var/{lib,run,log}/${PN}; do
+ dodir "${x}" || die "Install failed"
+ fowners tyrant:tyrant "${x}"
+ done
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN} || die "Install failed"
+ newconfd "${FILESDIR}/${PN}.confd" ${PN} || die "Install failed"
+
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}