summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2013-02-28 17:09:38 +0000
committerMarc Schiffbauer <mschiff@gentoo.org>2013-02-28 17:09:38 +0000
commit797bc300f330f1a56afa8ed306d161d94ebcdade (patch)
treea602942a3ace6be8882cedd0d7acf9773376b62d /net-misc/telnet-bsd
parentDon't call pkg-config directly, in order not to break cross compilation. (diff)
downloadgentoo-2-797bc300f330f1a56afa8ed306d161d94ebcdade.tar.gz
gentoo-2-797bc300f330f1a56afa8ed306d161d94ebcdade.tar.bz2
gentoo-2-797bc300f330f1a56afa8ed306d161d94ebcdade.zip
Better fix for #459560
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0x296C6CCA35A64134)
Diffstat (limited to 'net-misc/telnet-bsd')
-rw-r--r--net-misc/telnet-bsd/ChangeLog5
-rw-r--r--net-misc/telnet-bsd/telnet-bsd-1.2-r1.ebuild14
2 files changed, 11 insertions, 8 deletions
diff --git a/net-misc/telnet-bsd/ChangeLog b/net-misc/telnet-bsd/ChangeLog
index 507e5989fc56..c6d2907d3c2c 100644
--- a/net-misc/telnet-bsd/ChangeLog
+++ b/net-misc/telnet-bsd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/telnet-bsd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/telnet-bsd/ChangeLog,v 1.49 2013/02/28 11:03:45 mschiff Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/telnet-bsd/ChangeLog,v 1.50 2013/02/28 17:09:38 mschiff Exp $
+
+ 28 Feb 2013; Marc Schiffbauer <mschiff@gentoo.org> telnet-bsd-1.2-r1.ebuild:
+ Better fix for #459560
28 Feb 2013; Marc Schiffbauer <mschiff@gentoo.org> telnet-bsd-1.2-r1.ebuild:
EAPI bump, ebuild cleanups and fix bug #459560
diff --git a/net-misc/telnet-bsd/telnet-bsd-1.2-r1.ebuild b/net-misc/telnet-bsd/telnet-bsd-1.2-r1.ebuild
index 5d02a2e9a3ff..2b40aa854a60 100644
--- a/net-misc/telnet-bsd/telnet-bsd-1.2-r1.ebuild
+++ b/net-misc/telnet-bsd/telnet-bsd-1.2-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/telnet-bsd/telnet-bsd-1.2-r1.ebuild,v 1.22 2013/02/28 11:03:45 mschiff Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/telnet-bsd/telnet-bsd-1.2-r1.ebuild,v 1.23 2013/02/28 17:09:38 mschiff Exp $
EAPI=5
-inherit eutils autotools
+inherit eutils autotools toolchain-funcs
DESCRIPTION="Telnet and telnetd ported from OpenBSD with IPv6 support"
HOMEPAGE="ftp://ftp.suse.com/pub/people/kukuk/ipv6/"
@@ -14,25 +14,25 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
IUSE="nls xinetd"
-RDEPEND="sys-libs/ncurses[-tinfo]"
+RDEPEND="sys-libs/ncurses"
DEPEND="${RDEPEND}
!net-misc/netkit-telnetd
- xinetd? ( sys-apps/xinetd )"
+ xinetd? ( sys-apps/xinetd )
+ virtual/pkgconfig"
src_prepare() {
epatch "${FILESDIR}"/${P}-fbsd.patch
+ eautoreconf
}
src_configure() {
- eautoreconf
-
# FreeBSD doesn't seem to support PIE neither does hppa
if use kernel_FreeBSD || use hppa; then
export libc_cv_fpie="no"
fi
econf
- emake
+ emake CFLAGS="${CFLAGS} $("$(tc-getPKG_CONFIG)" --libs ncurses)"
}
src_install() {