summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-18 12:21:33 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-18 12:21:33 +0000
commit72da2cea923409f5e1b4cbcdf2e4ff51ff1a9060 (patch)
treeb7451271099fe3a7597872300ce5bc403427a73e /net-misc/tcpsound
parentLock down snakeoil-9999 to the python versions it supports (diff)
downloadgentoo-2-72da2cea923409f5e1b4cbcdf2e4ff51ff1a9060.tar.gz
gentoo-2-72da2cea923409f5e1b4cbcdf2e4ff51ff1a9060.tar.bz2
gentoo-2-72da2cea923409f5e1b4cbcdf2e4ff51ff1a9060.zip
Revision bump: EAPI 4, base eclass, drop unneeded sed
(Portage version: 2.2.0_alpha140/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-misc/tcpsound')
-rw-r--r--net-misc/tcpsound/ChangeLog9
-rw-r--r--net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/net-misc/tcpsound/ChangeLog b/net-misc/tcpsound/ChangeLog
index de001fc7d710..ca0163a54c19 100644
--- a/net-misc/tcpsound/ChangeLog
+++ b/net-misc/tcpsound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/tcpsound
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tcpsound/ChangeLog,v 1.8 2010/04/09 05:10:48 jer Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tcpsound/ChangeLog,v 1.9 2012/10/18 12:21:33 pinkbyte Exp $
+
+*tcpsound-0.3.1-r1 (18 Oct 2012)
+
+ 18 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> +tcpsound-0.3.1-r1.ebuild:
+ Revision bump: EAPI 4, base eclass, drop unneeded sed
09 Apr 2010; Jeroen Roovers <jer@gentoo.org>
files/tcpsound-0.3.1-makefile.patch:
diff --git a/net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild b/net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..70e6ef6faeb6
--- /dev/null
+++ b/net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild,v 1.1 2012/10/18 12:21:33 pinkbyte Exp $
+
+EAPI="4"
+
+inherit base toolchain-funcs
+
+DESCRIPTION="Play sounds in response to network traffic"
+HOMEPAGE="http://www.ioplex.com/~miallen/tcpsound/"
+SRC_URI="http://www.ioplex.com/~miallen/tcpsound/dl/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="net-analyzer/tcpdump
+ media-libs/libsdl
+ dev-libs/libmba"
+
+DOCS=( README.txt elaborate.conf )
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+
+src_prepare() {
+ # Fix paths
+ sed -i -e "s;/usr/share/sounds:/usr/local/share/sounds;/usr/share/tcpsound;g"\
+ "${S}"/src/tcpsound.c "${S}"/elaborate.conf || die 'sed failed'
+
+ base_src_prepare
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}