summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-08 15:54:25 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-08 15:54:25 +0000
commit3375065c06905990f44dcdb99d8ceb16d4759849 (patch)
tree9760dec3d21d41a2b60d6b770fa06223c2114cc9 /net-misc/leechcraft-core
parentBump LeechCraft to 0.5.85, thanks to 0xd34df00d (diff)
downloadgentoo-2-3375065c06905990f44dcdb99d8ceb16d4759849.tar.gz
gentoo-2-3375065c06905990f44dcdb99d8ceb16d4759849.tar.bz2
gentoo-2-3375065c06905990f44dcdb99d8ceb16d4759849.zip
Bump LeechCraft to 0.5.85, thanks to 0xd34df00d
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/leechcraft-core')
-rw-r--r--net-misc/leechcraft-core/ChangeLog8
-rw-r--r--net-misc/leechcraft-core/leechcraft-core-0.5.85.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/net-misc/leechcraft-core/ChangeLog b/net-misc/leechcraft-core/ChangeLog
index 9244b418e027..ab0bcbd84cf0 100644
--- a/net-misc/leechcraft-core/ChangeLog
+++ b/net-misc/leechcraft-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/leechcraft-core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/ChangeLog,v 1.27 2012/09/03 12:14:27 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/ChangeLog,v 1.28 2012/10/08 15:54:25 pinkbyte Exp $
+
+*leechcraft-core-0.5.85 (08 Oct 2012)
+
+ 08 Oct 2012; Sergey Popov <pinkbyte@gentoo.org>
+ +leechcraft-core-0.5.85.ebuild:
+ Bump LeechCraft to 0.5.85, thanks to 0xd34df00d
03 Sep 2012; Sergey Popov <pinkbyte@gentoo.org> leechcraft-core-9999.ebuild:
Applying fix for bug #431436 to live ebuild too
diff --git a/net-misc/leechcraft-core/leechcraft-core-0.5.85.ebuild b/net-misc/leechcraft-core/leechcraft-core-0.5.85.ebuild
new file mode 100644
index 000000000000..081ca7de9cbd
--- /dev/null
+++ b/net-misc/leechcraft-core/leechcraft-core-0.5.85.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/leechcraft-core-0.5.85.ebuild,v 1.1 2012/10/08 15:54:25 pinkbyte Exp $
+
+EAPI="4"
+
+EGIT_REPO_URI="git://github.com/0xd34df00d/leechcraft.git"
+EGIT_PROJECT="leechcraft-${PV}"
+
+inherit eutils confutils leechcraft
+
+DESCRIPTION="Core of LeechCraft, the modular network client"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +sqlite postgres"
+
+DEPEND=">=dev-libs/boost-1.46
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-script:4
+ x11-libs/qt-sql:4[postgres?,sqlite?]"
+RDEPEND="${DEPEND}
+ x11-libs/qt-svg:4"
+
+REQUIRED_USE="|| ( postgres sqlite )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_PLUGINS=False
+ )
+ if [[ ${PV} != 9999 ]]; then
+ mycmakeargs+=( -DLEECHCRAFT_VERSION=${PV} )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ make_desktop_entry leechcraft "LeechCraft" leechcraft.png
+}