summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2011-06-07 20:25:29 +0000
committerVictor Ostorga <vostorga@gentoo.org>2011-06-07 20:25:29 +0000
commit9cdd6c0a24565582ada7a54751d96892e8fc8a3a (patch)
tree6286a92325083d3b5a1ce5273fcb1a631f5e46c5 /net-misc/iodine
parentBased on 2.6.32.41 + genpatches-2.6.32-38 + grsecurity-2.2.2-2.6.32.41-201106... (diff)
downloadgentoo-2-9cdd6c0a24565582ada7a54751d96892e8fc8a3a.tar.gz
gentoo-2-9cdd6c0a24565582ada7a54751d96892e8fc8a3a.tar.bz2
gentoo-2-9cdd6c0a24565582ada7a54751d96892e8fc8a3a.zip
Fixing message given to user when executing test phase, big #370091
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'net-misc/iodine')
-rw-r--r--net-misc/iodine/ChangeLog8
-rw-r--r--net-misc/iodine/files/iodine-0.6.0_rc1-TestMessage.patch17
-rw-r--r--net-misc/iodine/iodine-0.6.0_rc1.ebuild10
3 files changed, 31 insertions, 4 deletions
diff --git a/net-misc/iodine/ChangeLog b/net-misc/iodine/ChangeLog
index 57d6224b8400..12b713e7f7e2 100644
--- a/net-misc/iodine/ChangeLog
+++ b/net-misc/iodine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/iodine
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iodine/ChangeLog,v 1.2 2010/03/16 17:41:28 vostorga Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iodine/ChangeLog,v 1.3 2011/06/07 20:25:29 vostorga Exp $
+
+ 07 Jun 2011; Víctor Ostorga <vostorga@gentoo.org> iodine-0.6.0_rc1.ebuild,
+ +files/iodine-0.6.0_rc1-TestMessage.patch:
+ Fixing message given to user when executing test phase, bug #370091
*iodine-0.6.0_rc1 (16 Mar 2010)
diff --git a/net-misc/iodine/files/iodine-0.6.0_rc1-TestMessage.patch b/net-misc/iodine/files/iodine-0.6.0_rc1-TestMessage.patch
new file mode 100644
index 000000000000..529d242115bd
--- /dev/null
+++ b/net-misc/iodine/files/iodine-0.6.0_rc1-TestMessage.patch
@@ -0,0 +1,17 @@
+diff -NrU5 iodine-0.6.0-rc1.original/Makefile iodine-0.6.0-rc1/Makefile
+--- iodine-0.6.0-rc1.original/Makefile 2009-01-25 15:40:04.000000000 -0600
++++ iodine-0.6.0-rc1/Makefile 2011-06-07 14:09:00.000000000 -0600
+@@ -48,12 +48,11 @@
+ $(RM) $(RM_FLAGS) $(DESTDIR)$(sbindir)/iodine
+ $(RM) $(RM_FLAGS) $(DESTDIR)$(sbindir)/iodined
+ $(RM) $(RM_FLAGS) $(DESTDIR)$(mandir)/man8/iodine.8
+
+ test: all
+- @echo "!! The check library is required for compiling and running the tests"
+- @echo "!! Get it at http://check.sf.net"
++ @echo "Executing tests target"
+ @(cd tests; $(MAKE) TARGETOS=$(TARGETOS) all)
+
+ clean:
+ @echo "Cleaning..."
+ @(cd src; $(MAKE) clean)
diff --git a/net-misc/iodine/iodine-0.6.0_rc1.ebuild b/net-misc/iodine/iodine-0.6.0_rc1.ebuild
index 53282b98e334..bfd846298d8f 100644
--- a/net-misc/iodine/iodine-0.6.0_rc1.ebuild
+++ b/net-misc/iodine/iodine-0.6.0_rc1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iodine/iodine-0.6.0_rc1.ebuild,v 1.1 2010/03/16 17:41:28 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iodine/iodine-0.6.0_rc1.ebuild,v 1.2 2011/06/07 20:25:29 vostorga Exp $
inherit linux-info eutils
@@ -23,6 +23,12 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+src_unpack(){
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-TestMessage.patch
+}
+
src_compile() {
emake CC="$(tc-getCC)" || die "make failed"
}