summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-04-17 14:11:40 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-04-17 14:11:40 +0000
commitd8c917826beb2253d7a9fb71f6a853583293da8b (patch)
treecb185e2d0bff1e1592373bf332da4453c414ac6e /net-misc/icecast
parentRESTRICT="test" as per bug 130922. (diff)
downloadgentoo-2-d8c917826beb2253d7a9fb71f6a853583293da8b.tar.gz
gentoo-2-d8c917826beb2253d7a9fb71f6a853583293da8b.tar.bz2
gentoo-2-d8c917826beb2253d7a9fb71f6a853583293da8b.zip
Fix compilation against curl-7.16, thanks to Daniel Black <dragonheart@gentoo.org>, bug #157756
(Portage version: 2.1.2.4)
Diffstat (limited to 'net-misc/icecast')
-rw-r--r--net-misc/icecast/ChangeLog7
-rw-r--r--net-misc/icecast/files/icecast-2.3.1-nocurlpassword.patch25
-rw-r--r--net-misc/icecast/icecast-2.3.1-r1.ebuild8
3 files changed, 38 insertions, 2 deletions
diff --git a/net-misc/icecast/ChangeLog b/net-misc/icecast/ChangeLog
index b629fde6c642..1238e96d84fb 100644
--- a/net-misc/icecast/ChangeLog
+++ b/net-misc/icecast/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/icecast
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.63 2007/03/09 04:11:44 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.64 2007/04/17 14:11:40 aballier Exp $
+
+ 17 Apr 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/icecast-2.3.1-nocurlpassword.patch, icecast-2.3.1-r1.ebuild:
+ Fix compilation against curl-7.16, thanks to Daniel Black
+ <dragonheart@gentoo.org>, bug #157756
09 Mar 2007; Steve Dibb <beandog@gentoo.org> icecast-2.3.1-r1.ebuild:
fix permissions, bug 144709
diff --git a/net-misc/icecast/files/icecast-2.3.1-nocurlpassword.patch b/net-misc/icecast/files/icecast-2.3.1-nocurlpassword.patch
new file mode 100644
index 000000000000..1aee0cdba227
--- /dev/null
+++ b/net-misc/icecast/files/icecast-2.3.1-nocurlpassword.patch
@@ -0,0 +1,25 @@
+--- ./src/auth_url.c.orig 2007-04-17 22:48:11.000000000 +1000
++++ ./src/auth_url.c 2007-04-17 22:48:59.000000000 +1000
+@@ -112,14 +112,6 @@
+ }
+
+
+-/* make sure that prompting at the console does not occur */
+-static int my_getpass(void *client, char *prompt, char *buffer, int buflen)
+-{
+- buffer[0] = '\0';
+- return 0;
+-}
+-
+-
+ static int handle_returned_header (void *ptr, size_t size, size_t nmemb, void *stream)
+ {
+ auth_client *auth_user = stream;
+@@ -518,7 +510,6 @@
+ curl_easy_setopt (url_info->handle, CURLOPT_WRITEDATA, url_info->handle);
+ curl_easy_setopt (url_info->handle, CURLOPT_NOSIGNAL, 1L);
+ curl_easy_setopt (url_info->handle, CURLOPT_TIMEOUT, 15L);
+- curl_easy_setopt (url_info->handle, CURLOPT_PASSWDFUNCTION, my_getpass);
+ curl_easy_setopt (url_info->handle, CURLOPT_ERRORBUFFER, &url_info->errormsg[0]);
+
+ if (url_info->username && url_info->password)
diff --git a/net-misc/icecast/icecast-2.3.1-r1.ebuild b/net-misc/icecast/icecast-2.3.1-r1.ebuild
index 382dc2401841..20c48decf9e8 100644
--- a/net-misc/icecast/icecast-2.3.1-r1.ebuild
+++ b/net-misc/icecast/icecast-2.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-2.3.1-r1.ebuild,v 1.6 2007/03/09 04:11:44 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-2.3.1-r1.ebuild,v 1.7 2007/04/17 14:11:40 aballier Exp $
inherit eutils
@@ -19,6 +19,12 @@ DEPEND="dev-libs/libxslt
theora? ( media-libs/libtheora )
yp? ( >=net-misc/curl-7.10.0 )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-nocurlpassword.patch"
+}
+
src_compile() {
econf \
--sysconfdir=/etc/icecast2 \