summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPete Michaleas <tutor@gentoo.org>2002-04-26 03:09:38 +0000
committerPete Michaleas <tutor@gentoo.org>2002-04-26 03:09:38 +0000
commitd66d1760716dcb8416cc3a3a731ba2417a2d1783 (patch)
tree3dec9cd27f52a7f556481958c486c58a140b739e /net-misc/icecast
parentUpdated ChangeLog (diff)
downloadgentoo-2-d66d1760716dcb8416cc3a3a731ba2417a2d1783.tar.gz
gentoo-2-d66d1760716dcb8416cc3a3a731ba2417a2d1783.tar.bz2
gentoo-2-d66d1760716dcb8416cc3a3a731ba2417a2d1783.zip
Updated ebuild file to incorporate USE crypt
Diffstat (limited to 'net-misc/icecast')
-rw-r--r--net-misc/icecast/icecast-1.3.12.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/net-misc/icecast/icecast-1.3.12.ebuild b/net-misc/icecast/icecast-1.3.12.ebuild
index 3aec85836c8a..d9a6d6a739c3 100644
--- a/net-misc/icecast/icecast-1.3.12.ebuild
+++ b/net-misc/icecast/icecast-1.3.12.ebuild
@@ -12,19 +12,22 @@ DEPEND="virtual/glibc"
src_compile() {
- ./configure --with-libwrap \
- --with-crypt \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --host=${CHOST} || die
+ local myconf
- emake || die
+ use crypt && myconf="--with-crypt" || myconf="--without-crypt"
+
+ ./configure --with-libwrap \
+ ${myconf} \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --host=${CHOST} || die
+
+ emake || die
}
src_install () {
- make DESTDIR=${D} install || die
- dodoc AUTHORS BUGS CHANGES COPYING FAQ INSTALL README TESTED TODO
-
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS CHANGES COPYING FAQ INSTALL README TESTED TODO
}