summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-02-19 13:43:17 +0000
committerThomas Kahle <tomka@gentoo.org>2013-02-19 13:43:17 +0000
commitc6d17753005a57a5f1e7dc8af59a8bbd9fec5545 (patch)
treefd048af1ad3c82ea208ec726ad987a694ee303fd /net-misc/directvnc
parentVersion bumps (diff)
downloadgentoo-2-c6d17753005a57a5f1e7dc8af59a8bbd9fec5545.tar.gz
gentoo-2-c6d17753005a57a5f1e7dc8af59a8bbd9fec5545.tar.bz2
gentoo-2-c6d17753005a57a5f1e7dc8af59a8bbd9fec5545.zip
bump and maintenance (proxy-commit)
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC)
Diffstat (limited to 'net-misc/directvnc')
-rw-r--r--net-misc/directvnc/ChangeLog10
-rw-r--r--net-misc/directvnc/directvnc-0.7.6-r1.ebuild43
-rw-r--r--net-misc/directvnc/directvnc-0.7.6.ebuild47
-rw-r--r--net-misc/directvnc/directvnc-0.7.8.ebuild52
-rw-r--r--net-misc/directvnc/files/directvnc-0.7.6-mouse.patch30
-rw-r--r--net-misc/directvnc/files/directvnc-0.7.8-mouse.patch29
-rw-r--r--net-misc/directvnc/metadata.xml1
7 files changed, 164 insertions, 48 deletions
diff --git a/net-misc/directvnc/ChangeLog b/net-misc/directvnc/ChangeLog
index 76509a5ed81b..03a614090d3d 100644
--- a/net-misc/directvnc/ChangeLog
+++ b/net-misc/directvnc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/directvnc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/directvnc/ChangeLog,v 1.27 2013/02/03 12:07:51 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/directvnc/ChangeLog,v 1.28 2013/02/19 13:43:17 tomka Exp $
+
+*directvnc-0.7.6-r1 (19 Feb 2013)
+*directvnc-0.7.8 (19 Feb 2013)
+
+ 19 Feb 2013; Thomas Kahle <tomka@gentoo.org> +directvnc-0.7.6-r1.ebuild,
+ +directvnc-0.7.8.ebuild, +files/directvnc-0.7.6-mouse.patch,
+ +files/directvnc-0.7.8-mouse.patch, -directvnc-0.7.6.ebuild, metadata.xml:
+ bump and maintenance (proxy-commit)
03 Feb 2013; Thomas Kahle <tomka@gentoo.org> metadata.xml:
Pick up for proxy maintainership
diff --git a/net-misc/directvnc/directvnc-0.7.6-r1.ebuild b/net-misc/directvnc/directvnc-0.7.6-r1.ebuild
new file mode 100644
index 000000000000..62b92826ccbd
--- /dev/null
+++ b/net-misc/directvnc/directvnc-0.7.6-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/directvnc/directvnc-0.7.6-r1.ebuild,v 1.1 2013/02/19 13:43:17 tomka Exp $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils autotools-utils
+
+DESCRIPTION="Very thin VNC client for unix framebuffer systems"
+HOMEPAGE="http://drinkmilk.github.com/directvnc/"
+SRC_URI="http://github.com/downloads/drinkmilk/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="+mouse dmalloc"
+
+RDEPEND="dev-libs/DirectFB[fbcon,dynload]
+ virtual/jpeg"
+
+DEPEND="${RDEPEND}
+ dmalloc? ( dev-libs/dmalloc )
+ x11-proto/xproto"
+
+DOCS=( NEWS THANKS )
+
+src_prepare() {
+ # Make mouse support optional
+ use mouse || epatch "${FILESDIR}/${P}-mouse.patch"
+ sed -i -e 's|$(prefix)/share/doc/@PACKAGE@|@docdir@|g' Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ myeconfargs=(
+ $(use_with dmalloc)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/net-misc/directvnc/directvnc-0.7.6.ebuild b/net-misc/directvnc/directvnc-0.7.6.ebuild
deleted file mode 100644
index 67c2cbd94d2b..000000000000
--- a/net-misc/directvnc/directvnc-0.7.6.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/directvnc/directvnc-0.7.6.ebuild,v 1.3 2012/05/05 03:20:44 jdhore Exp $
-
-inherit eutils
-
-DESCRIPTION="Very thin VNC client for unix framebuffer systems"
-HOMEPAGE="http://drinkmilk.github.com/directvnc/"
-SRC_URI="http://github.com/downloads/drinkmilk/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
-IUSE="mouse"
-
-RDEPEND="dev-libs/DirectFB
- virtual/jpeg"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=sys-apps/sed-4
- x11-proto/xproto"
-
-src_unpack() {
- unpack ${A}
-
- # Make mouse support optional
- cd "${S}/src"
- use mouse || epatch "${FILESDIR}/${PN}-mouse.patch"
-}
-
-src_compile() {
- econf || die
-
- # Fix bug #116148, DFBGraphicsDeviceDescription is no longer present in
- # newer DirectFB version, but the application never uses it :-/
- local comment_out="DFBCardCapabilities caps;"
- sed -i -e "s:${comment_out}://${comment_out}:" src/dfb.c
-
- emake DEBUGFLAGS="${CFLAGS}" AM_LDFLAGS="${LDFLAGS}" || die
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
- rm -rf "${D}/usr/doc"
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO
-}
diff --git a/net-misc/directvnc/directvnc-0.7.8.ebuild b/net-misc/directvnc/directvnc-0.7.8.ebuild
new file mode 100644
index 000000000000..e669d60aa5fe
--- /dev/null
+++ b/net-misc/directvnc/directvnc-0.7.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/directvnc/directvnc-0.7.8.ebuild,v 1.1 2013/02/19 13:43:17 tomka Exp $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils autotools-utils
+
+DESCRIPTION="Very thin VNC client for unix framebuffer systems"
+HOMEPAGE="http://drinkmilk.github.com/directvnc/"
+SRC_URI="http://github.com/downloads/drinkmilk/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+mouse dmalloc"
+
+RDEPEND="dev-libs/DirectFB[fbcon,dynload]
+ virtual/jpeg"
+
+DEPEND="${RDEPEND}
+ dmalloc? ( dev-libs/dmalloc )
+ x11-proto/xproto"
+
+DOCS=( NEWS THANKS )
+
+src_prepare() {
+ use mouse || epatch "${FILESDIR}"/${P}-mouse.patch
+
+ # fix package version
+ sed -i -e '/^AM_INIT_AUTOMAKE/s/0.7.7/0.7.8/g' configure.in || die
+ # fix build system don't respect --docdir option
+ sed -i -e 's|$(prefix)/share/doc/@PACKAGE@|@docdir@|g' Makefile.am || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ myeconfargs=(
+ $(use_with dmalloc)
+ )
+
+ autotools-utils_src_configure
+}
+
+pkg_postinst() {
+ einfo "To customize your keyboard mapping, please consult the manual"
+ einfo " commmand: man 7 directvnc-kbmapping"
+}
diff --git a/net-misc/directvnc/files/directvnc-0.7.6-mouse.patch b/net-misc/directvnc/files/directvnc-0.7.6-mouse.patch
new file mode 100644
index 000000000000..71d901661770
--- /dev/null
+++ b/net-misc/directvnc/files/directvnc-0.7.6-mouse.patch
@@ -0,0 +1,30 @@
+diff --git a/src/dfb.c b/src/dfb.c
+old mode 100755
+new mode 100644
+index 8de0f0a..0241c82
+--- a/src/dfb.c
++++ b/src/dfb.c
+@@ -28,7 +28,6 @@ IDirectFB *dfb = NULL;
+ IDirectFBSurface *primary;
+ IDirectFBDisplayLayer *layer;
+ IDirectFBInputDevice *keyboard;
+-IDirectFBInputDevice *mouse;
+ IDirectFBEventBuffer *input_buffer;
+ DFBResult err;
+ DFBSurfaceDescription dsc;
+@@ -70,7 +69,6 @@ dfb_init(int argc, char *argv[])
+ primary->GetSize (primary, &opt.client.width, &opt.client.height);
+
+ DFBCHECK(dfb->GetInputDevice( dfb, DIDID_KEYBOARD, &keyboard ));
+- DFBCHECK(dfb->GetInputDevice( dfb, DIDID_MOUSE, &mouse ));
+ DFBCHECK (dfb->CreateInputEventBuffer (dfb, DICAPS_ALL, DFB_TRUE, &input_buffer));
+ }
+
+@@ -84,7 +82,6 @@ dfb_deinit()
+ primary->Release( primary );
+ input_buffer->Release(input_buffer);
+ keyboard->Release( keyboard );
+- mouse->Release( mouse );
+ layer->Release( layer );
+ dfb->Release( dfb );
+ }
diff --git a/net-misc/directvnc/files/directvnc-0.7.8-mouse.patch b/net-misc/directvnc/files/directvnc-0.7.8-mouse.patch
new file mode 100644
index 000000000000..b37b381ae234
--- /dev/null
+++ b/net-misc/directvnc/files/directvnc-0.7.8-mouse.patch
@@ -0,0 +1,29 @@
+diff --git a/src/dfb.c b/src/dfb.c
+index 5335ea2..8f3adbc 100644
+--- a/src/dfb.c
++++ b/src/dfb.c
+@@ -28,7 +28,6 @@ IDirectFB *dfb = NULL;
+ IDirectFBSurface *primary = NULL;
+ IDirectFBDisplayLayer *layer = NULL;
+ IDirectFBInputDevice *keyboard = NULL;
+-IDirectFBInputDevice *mouse = NULL;
+ IDirectFBEventBuffer *input_buffer = NULL;
+ DFBResult err;
+ DFBSurfaceDescription dsc;
+@@ -70,7 +69,6 @@ dfb_init(int argc, char *argv[])
+ primary->GetSize (primary, &opt.client.width, &opt.client.height);
+
+ DFBCHECK(dfb->GetInputDevice( dfb, DIDID_KEYBOARD, &keyboard ));
+- DFBCHECK(dfb->GetInputDevice( dfb, DIDID_MOUSE, &mouse ));
+ DFBCHECK (dfb->CreateInputEventBuffer (dfb, DICAPS_ALL, DFB_TRUE, &input_buffer));
+ }
+
+@@ -87,8 +85,6 @@ dfb_deinit()
+ input_buffer->Release( input_buffer );
+ if ( keyboard )
+ keyboard->Release( keyboard );
+- if ( mouse )
+- mouse->Release( mouse );
+ if ( layer )
+ layer->Release( layer );
+ if ( dfb )
diff --git a/net-misc/directvnc/metadata.xml b/net-misc/directvnc/metadata.xml
index 6be78e3265c1..fbd58c42cf83 100644
--- a/net-misc/directvnc/metadata.xml
+++ b/net-misc/directvnc/metadata.xml
@@ -13,5 +13,6 @@
</maintainer>
<use>
<flag name="mouse">Adds mouse support</flag>
+ <flag name='dmalloc'>Enable debugging with the dmalloc library</flag>
</use>
</pkgmetadata>